8.х вопрос по поиску

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем cdpoma, 24 ноя 2009.

  1. TopicStarter Overlay
    cdpoma
    Offline

    cdpoma

    Регистрация:
    21 окт 2009
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    всем привет, нужна помощь ибо я новичок в 1с :unsure:

    есть справочник, в нем есть реквизит "ключевые слова" (формируется путем слияния 5 реквизитов и описания), мне нужно сделать поиск по этому реквизиту, причем если я в строке поиска напишу "слово1 слово2 слово3 слово4 слово5" то он должен искать по всем словам отдельно.

    Вложения:

    • архив.JPG
      архив.JPG
      Размер файла:
      98,4 КБ
      Просмотров:
      18
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Например вот так.
    Код:
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |	Номенклатура.Ссылка,
    |	Номенклатура.Наименование
    |ИЗ
    |	Справочник.Номенклатура КАК Номенклатура
    |ГДЕ ";
    НужноВставлятьИЛИ = Ложь;			   
    МассивСтрок =  ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(ПоисковыйЗапрос," ");
    Для Каждого Строка из Массивстрок цикл
    Если НужноВставлятьИЛИ Тогда
    Запрос.Текст = Запрос.Текст + " ИЛИ ";
    Иначе
    НужноВставлятьИЛИ = Истина; // для первого цикла, далее перед каждым условием вставляем ИЛИ
    КонецЕсли;
    
    Запрос.Текст = Запрос.Текст + " Наименование ПОДОБНО " +""""+"%"+Строка+"%"+"""";
    КонецЦикла;		
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока выборка.Следующий() Цикл
    Cообщить(" "+Выборка.Наименование);
    КонецЦикла;
    
    
  3. TopicStarter Overlay
    cdpoma
    Offline

    cdpoma

    Регистрация:
    21 окт 2009
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    lazy благодарю, попробуем..
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Лучше использовать полнотекстовый поиск - будет быстрее и удобнее.
    ПОДОБНО не шибко быстро работает

Поделиться этой страницей