8.х Вопрос по отборам в СКД

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Виктор13245234, 8 авг 2018.

  1. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    245
    Симпатии:
    6
    Баллы:
    29
    Коллеги, добрый день! Работаю в Бухгалтерии 3.0 последнего релиза. Программно заполняю отборы в пользовательских настройках в отчете Оборотно сальдовая ведомость по счету. Все отборы хорошо заполняются.

    Вопрос: Как сделать поля для отбора недоступными для изменения?

    Код:
    ТекЭлементыПользНастроек = Настройки.Элементы;
           
            Для Каждого Настройка Из ТекЭлементыПользНастроек Цикл
               
                Если ТипЗнч(Настройка) = Тип("ОтборКомпоновкиДанных") Тогда
                    Для Каждого ТекОтбор Из Настройка.Элементы Цикл
                        Если ТекОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Субконто2") Тогда
                            ТекОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
                            ТекОтбор.ТипПримененияОтбораКомпоновкиДанных = Истина;
                            ТекОтбор.ПравоеЗначение = СписокСкладов;
                            ТекОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
                        КонецЕсли;       
                    КонецЦикла;   
                КонецЕсли;
               
            КонецЦикла;   
    
    Не срабатывает ТекОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;


    Кто сталктвался? Заранее спасибо!

Поделиться этой страницей