7.7 вопрос новичка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем smaal, 1 ноя 2009.

  1. TopicStarter Overlay
    smaal
    Offline

    smaal

    Регистрация:
    1 ноя 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Задача: нужно вывести только помеченные элементы списка значений
    помогите разобраться

    Код:
     Процедура ПриОткрытии()
    
    спр=создатьобъект("справочник.должности");
    спр.выбратьэлементы();  
    пока спр.получитьэлемент()=1 цикл
    сз.добавитьзначение(спр.текущийэлемент());
    КонецЦикла;
    
    
    КонецПроцедуры
    
    Процедура Сформировать()   
    табл=создатьобъект("таблица");
    
    Запрос=СоздатьОбъект("Запрос");
    ТекстЗапроса="
    |Сотр=Справочник.Сотрудники.Наименование;
    |Долж=Справочник.Сотрудники.Должность;
    |Группировка Долж;
    |Группировка Сотр;
    |";
    Запрос.Выполнить(ТекстЗапроса);
    
    для ном = 1 по сз.размерсписка() цикл;
    если сз.пометка(ном)=1 тогда
    сз.получитьзначение(ном); 
    конецесли;
    
    конеццикла;
    пока запрос.группировка("долж")=1 цикл
    табл.ВывестиСекцию("Дол");
    Пока запрос.Группировка("сотр")=1 Цикл
    Табл.вывестиСекцию("Сот");
    КонецЦикла;
    конеццикла;
    
    табл.показать();
    
    КонецПроцедуры
    
    
    
    я хоть в правильном направлении двигаюсь?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Перед запросом выгружайте помеченные элементы из СЗ в другой список. В запросе используйте
    Код:
    Условие (Долж в НовыйСписок);
    
    
  4. TopicStarter Overlay
    smaal
    Offline

    smaal

    Регистрация:
    1 ноя 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое!
Похожие темы
  1. 5June
    Ответов:
    5
    Просмотров:
    1.161
  2. revend
    Ответов:
    6
    Просмотров:
    375
  3. Nike32rus
    Ответов:
    9
    Просмотров:
    416
Загрузка...

Поделиться этой страницей