8.х Внешняя Печатная Форма Подхватывает не тот Док

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Sergey Volynkin, 7 фев 2016.

  1. TopicStarter Overlay
    Sergey Volynkin
    Offline

    Sergey Volynkin

    Регистрация:
    18 янв 2016
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, такая проблема, внешняя печатная форма, которая я создал для справочника "ДоговорыКонтрагентов" подхватывает только самый последний созданный договор.

    Не могу разобраться, в чем причина.

    Док включен в подсистему БСП Печать

    Выбираю в отладчике форм(в самих документах история повторяется, т.е. из док. 001 печатает док 002)
    Элемент справочника, например, с кодом 00001, а получаю данные из дока 00002. В чем может быть причина?

    Код для регистрации обработки в системе


    Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть – ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов…

    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Справочник.ДоговорыКонтрагентов");
    //МассивНазначений.Добавить("Документ.СчетНаОплатуПокупателей");//Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);

    ПараметрыРегистрации.Вставить("Наименование", "Договор"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Информация", "Тест");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);


    Команды = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(Команды, "Договор", "Договор", "ВызовСерверногоМетода", Ложь, "ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", Команды);

    Возврат ПараметрыРегистрации;

    КонецФункции

    Функция ПолучитьТаблицуКоманд()

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //Это может быть любая текстовая строка, уникальная в пределах данной обработки
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;

    КонецФункции

    Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;

    КонецПроцедуры

    Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Договор") Тогда
    ИмяПараметровПечати = "Договор";
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Договор", "Договор",
    ПечатьДоговор(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода),,"Договор");
    КонецЕсли;
    КонецПроцедуры

    Вложения:

    Последнее редактирование: 7 фев 2016
  2. TopicStarter Overlay
    Sergey Volynkin
    Offline

    Sergey Volynkin

    Регистрация:
    18 янв 2016
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
  3. Ktyf
    Offline

    Ktyf Опытный в 1С

    Регистрация:
    16 янв 2013
    Сообщения:
    457
    Симпатии:
    12
    Баллы:
    29
    А что у вас в массивеОбъектов? Смотрели?

Поделиться этой страницей