8.х Внешняя печатная Форма Акт + Счет Фактура

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем vall-n-rol, 19 окт 2012.

  1. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    1С:Предприятие 8.2 (8.2.14.540)
    Бухгалтерия для Казахстана, редакция 2.0, разработка для Казахстана: «1С-Рейтинг», 2011 (2.0.7.9)

    Приветствую всех! Подскажите пожалуйста как совместить 2 макета 1ый(Акт), 2ой(Счет фактура),
    так чтоб они распологались в виде книжки т.е, А4(ЛАндшафт) поделить на 2 строннички !
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    ну такого как в Ворде, что разделить на книжную - нет.

    Делайте через области. Т.е сначала одну облась - Акт, а потом к ней присоеденяйте с/ф область
  3. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    и в Акте и Счет Фактуре, имеются Табличные части с ними проблема немогу представить как их вывести(
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    не совсем понял? всмесле как вывести? ну вы берете 2 процедуры из стандартной конфы, и переносите их во ВПФ, где у Вас будет один макет из 2х с/ф. НУ там надо писать алгоритм,когда что присоединять - не все так просто на самом деле
  5. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    а примера такого ниге не видел?
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Когда то видел, в семерке, но не помню уже. А кстати у Приходного касового ордера, похожая форма, она на две части разделена, что бы одну потом отрывать
  7. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    Это не то , шас буду пробывать в одном макете делать спс
  8. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    Подскажите как поступить в такой ситуации?

    Вложения:

    • АктСчФ.JPG
      АктСчФ.JPG
      Размер файла:
      150,4 КБ
      Просмотров:
      127
  9. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    подскажите пожалуйста!
  10. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    что не получается конкретно?
  11. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    на рисунке видно что только, после вывода табличной части Акта и дет продолжение строки Счета фактуры, я не могу сообразить как сделать чтобы не было этого пробела,
  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    сделайте макет с двумя вертикальными областями. Организуйте вывод одной, потом вывод второй области, потом присоедините вторую область к первой.

    иначе вам надо каким то образом отслеживать паралдлельный вывод обеих областей (если вы именно параллельно выводите)
  13. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    если я сделаю макет с 2 мя вертикальными облостями, допустим Акт-сверху , счетФактура -с низу а как тогда мне их присаеденить друг к другу , чтоб Получилось так как на рисунке - акт и СчетФактура располагались как на книжке
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    я имела ввиду 2 вертикальные области, это одна слева, вторая справа... (секции)
  15. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    я так и делаю, С лева 1вая секция Акт справа Счет фактура, вывожу область Акта затем присоединяю область СчФактуры , когда я вывожу область табл.части(Акта) то следующая область СчФактуры присоединяется к последней сточке, в рез-те чего образуется пробел, в этом проблема вот код
    Код:
    // Вывести табличную часть
    ОбластьМакета = Макет.ПолучитьОбласть("Акт|ШапкаТаблицы");
    ОбластьМакета2 = Макет.ПолучитьОбласть("СчетФактура|ШапкаТаблицы");
    ОбластьМакета2.Параметры.Доверенность = ДанныеДляПечати.Доверенность;
    
    ОбластьСтроки = Макет.ПолучитьОбласть("Акт|Строка");
    ОбластьСтроки2 = Макет.ПолучитьОбласть("СчетФактура|Строка");
    ТабДок.Вывести(ОбластьМакета);
    ТабДок.Присоединить(ОбластьМакета2);
    НомерСтроки = 0;
    
    Для Каждого СтрокаТабличнойЧасти Из KZERT21asd54as5d78as7d54as5d4 Цикл
    
    НомерСтроки = НомерСтроки + 1;
    
    ОбластьСтроки.Параметры.Заполнить(СтрокаТабличнойЧасти);
    ОбластьСтроки.Параметры.НомерСтроки = НомерСтроки;
    ОбластьСтроки.Параметры.Товар = СокрЛП(СтрокаТабличнойЧасти.Товар);
    
    ТабДок.Вывести(ОбластьСтроки);
    
    КонецЦикла;
    ОбластьСтроки2.Параметры.СпособОтправления = ДанныеДляПечати.СпособОтправления;
    ТабДок.Присоединить(ОбластьСтроки2);
  16. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    я бы поробовала так (конечно наверное не самое оптимальное, но...), использовать несколько табдоков:

    Код:
    ТабДок = Новый ТабличныйДокумент;
    //здесь какие то общие области для обеих частей можно вывести
    тд = Новый ТабличныйДокумент;
    //выводим только левую часть, все данные в тд
    Табдок.Вывести(тд);
    тд.очистить();
    //теперь выводим правую часть, все данные в тд
    ТабДок.Присоединить(тд);
    тд.очистить();
    попробуйте по такому принципу вывести...
  17. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    сп буду пробывать
  18. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    вот код вывода
    Код:
    ТабДок1.Вывести(ОбластьМакета);
    ТабДок.Вывести(ТабДок1);
    ТабДок1.очистить();
    ТабДок.Присоединить(ТабДок1);
    ТабДок1.очистить();
    
    Возврат ТабДок;
    2 рис. результат! как сделать чтоб он Секцию С СчетФактурой Не с новой строки вывел, а присоеденил с 1 строки Акта

    Вложения:

  19. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    по тому куску кода, что вы привели, как-то сложно судить о том, что не так...
  20. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    Код:
    ТабДок1 = Новый ТабличныйДокумент;
    
    Макет  = ПолучитьМакет("АктСчетФактураЛандшафт");//Документы.РеализацияТоваровУслуг.ПолучитьМакет("Акт");
    ТабДок1.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_АктиСФ";
    // Зададим параметры макета
    ТабДок1.ПолеСверху		 = 0;
    ТабДок1.ПолеСлева		  = 10;
    ТабДок1.ПолеСнизу		  = 0;
    ТабДок1.ПолеСправа		 = 0;
    ТабДок1.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок|Акт");
    ОбластьМакета.Параметры.ТекстЗаголовка = РаботаСДиалогами.СформироватьЗаголовокДокумента(Ссылка, "Акт", глСписокПрефиксовУзлов);
    ТабДок1.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик|Акт");
    ПредставлениеПоставщика = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(KZERT215sa5d754545a4sd21, Ссылка.Дата), "ПолноеНаименование,");
    ОбластьМакета.Параметры.ПредставлениеПоставщика = СокрЛП(ПредставлениеПоставщика);
    ОбластьМакета.Параметры.Поставщик = KZERT215sa5d754545a4sd21;
    ТабДок1.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("Покупатель|Акт");
    ПредставлениеПолучателя = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата), "ПолноеНаименование,");
    ОбластьМакета.Параметры.ПредставлениеПолучателя = СокрЛП(ПредставлениеПолучателя);
    ОбластьМакета.Параметры.Получатель = Шапка.Получатель;
    ТабДок1.Вывести(ОбластьМакета);
    
    Если ЗначениеЗаполнено(Шапка.Основание) Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Основание|Акт");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ТабДок1.Вывести(ОбластьМакета);
    КонецЕсли;
    
    ЕстьСкидки = Ложь;
    
    // Вывести табличную часть
    ОбластьМакета = Макет.ПолучитьОбласть("ШапкаТаблицы|Акт");
    ОбластьСтроки = Макет.ПолучитьОбласть("Строка|Акт");
    
    ТабДок1.Вывести(ОбластьМакета);
    НомерСтроки = 0;
    
    Для Каждого СтрокаТабличнойЧасти Из KZERT21asd54as5d78as7d54as5d4 Цикл
    
    НомерСтроки = НомерСтроки + 1;
    
    ОбластьСтроки.Параметры.Заполнить(СтрокаТабличнойЧасти);
    ОбластьСтроки.Параметры.НомерСтроки = НомерСтроки;
    ОбластьСтроки.Параметры.Товар = СокрЛП(СтрокаТабличнойЧасти.Товар);
    
    ТабДок1.Вывести(ОбластьСтроки);
    
    КонецЦикла;
    
    Если KZERT21asd54as5d78as7d54as5d4 <> Неопределено Тогда
    
    Сумма    = KZERT21asd54as5d78as7d54as5d4.Итог("Сумма");
    СуммаНДС = KZERT21asd54as5d78as7d54as5d4.Итог("СуммаНДС");
    
    Иначе
    
    Сумма    = 0;
    СуммаНДС = 0;
    
    КонецЕсли;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Итого|Акт");
    ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(Сумма);
    ТабДок1.Вывести(ОбластьМакета);
    
    Если Шапка.УчитыватьНДС Тогда
    
    ОбластьМакета = Макет.ПолучитьОбласть("ИтогоНДС|Акт");
    ОбластьМакета.Параметры.ВсегоНДС = ОбщегоНазначения.ФорматСумм(СуммаНДС);
    ОбластьМакета.Параметры.НДС	  = ?(Шапка.СуммаВключаетНДС, "В том числе НДС", " Сумма НДС");
    ТабДок1.Вывести(ОбластьМакета);
    
    КонецЕсли;
    
    СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью|Акт");
    ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего оказано услуг " + НомерСтроки
    + ", на сумму " + ОбщегоНазначения.ФорматСумм(СуммаКПрописи, Шапка.ВалютаДокумента);
    ОбластьМакета.Параметры.СуммаПрописью  = ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, Шапка.ВалютаДокумента);
    ТабДок1.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("Подписи|Акт");
    
    //Если Ссылка.БанковскийСчетОрганизации.Пустая() Тогда
    // СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(KZERT215sa5d754545a4sd21, Шапка.Дата);
    //Иначе
    // СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(KZERT215sa5d754545a4sd21, Шапка.Дата, ,Ссылка.БанковскийСчетОрганизации);
    //КонецЕсли;
    //
    //ОбластьМакета.Параметры.Организация			  = СведенияОбОрганизации.ПолноеНаименование;
    //ОбластьМакета.Параметры.РНН_БИНОрганизации	   = ОбщегоНазначения.ПолучитьРегистрационныйНомерОрганизацииКонтрагентаВПечатнуюФорму(СведенияОбОрганизации, Шапка.Дата);
    //ОбластьМакета.Параметры.АдресОрганизации		 = СведенияОбОрганизации.ЮридическийАдрес;
    //ОбластьМакета.Параметры.РасчетныйСчетОрганизации = СведенияОбОрганизации.НомерСчета + " в " + СведенияОбОрганизации.Банк + " ,"
    //+ СведенияОбОрганизации.АдресБанка;
    //
    //
    //ОбластьМакета.Параметры.БИКОрганизации		   = СведенияОбОрганизации.БИК;			 
    //ОбластьМакета.Параметры.ДолжностьОтветственного  = Шапка.ДолжностьОтветственного;
    //ОбластьМакета.Параметры.ФИООтветственного	    = Шапка.ФИООтветственного;
    //
    //СведенияОПокупателе = ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
    //ОбластьМакета.Параметры.Контрагент			   = СведенияОПокупателе.ПолноеНаименование;
    //ОбластьМакета.Параметры.РНН_БИНКонтрагента	   = ОбщегоНазначения.ПолучитьРегистрационныйНомерОрганизацииКонтрагентаВПечатнуюФорму(СведенияОПокупателе, Шапка.Дата);
    //ОбластьМакета.Параметры.АдресКонтрагента		 = СведенияОПокупателе.ЮридическийАдрес;
    //ОбластьМакета.Параметры.РасчетныйСчетКонтрагента = СведенияОПокупателе.НомерСчета + " в " + СведенияОПокупателе.Банк + " ,"
    //+ СведенияОПокупателе.АдресБанка;
    //
    //ОбластьМакета.Параметры.БИККонтрагента		   = СведенияОПокупателе.БИК;
    
    ТабДок1.Вывести(ОбластьМакета);
    ТабДок.Вывести(ТабДок1);
    ТабДок1.очистить();
    //////////////////////СчетФактура*********************************************************
    KZERT215sa5d754545a4sd21 = ОбщегоНазначения.ПолучитьСтруктурнуюЕдиницу(ДанныеДляПечати.Организация, ДанныеДляПечати.СтруктурноеПодразделение);
    
    СведенияОПокупателе = ОбщегоНазначения.СведенияОЮрФизЛице(ДанныеДляПечати.Контрагент,ДанныеДляПечати.Дата, ,ДанныеДляПечати.СчетКонтрагента);
    СведенияОПоставщике = ОбщегоНазначения.СведенияОЮрФизЛице(ДанныеДляПечати.Организация,ДанныеДляПечати.Дата, ,ДанныеДляПечати.СчетОрганизации);
    
    СведенияОГрузоотправителе = Новый Структура;
    Если ЗначениеЗаполнено(ДанныеДляПечати.Грузоотправитель) Тогда
    СведенияОГрузоотправителе = ОбщегоНазначения.СведенияОЮрФизЛице(ДанныеДляПечати.Грузоотправитель, ДанныеДляПечати.Дата);
    КонецЕсли;
    
    СведенияОГрузополучателе = Новый Структура;
    Если ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель) Тогда
    СведенияОГрузополучателе = ОбщегоНазначения.СведенияОЮрФизЛице(ДанныеДляПечати.Грузополучатель, ДанныеДляПечати.Дата);
    КонецЕсли;
    // Выводим шапку накладной
    
    ТекстДопСчетФактура = "";
    Если ДанныеДляПечати.Дополнительная Тогда
    ТекстДопСчетФактура = "Дополнительный Счет-фактура" + ?(ЗначениеЗаполнено(ДанныеДляПечати.ОсновнойСчетФактура), " к " +
    "Счету-фактуре №" + ОбщегоНазначения.ПолучитьНомерНаПечать(ДанныеДляПечати.ОсновнойСчетФактура) + " от " + Формат(ДанныеДляПечати.ОсновнойСчетФактура.Дата,"ДФ=dd.MM.yyyy" ),"");
    КонецЕсли;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок|СчетФактура");
    ОбластьМакета.Параметры.ДопСчетФактура = ТекстДопСчетФактура;
    ОбластьМакета.Параметры.Заполнить(ДанныеДляПечати);
    // Строку даты оборота по реализации выводим только если реализации в РФ или РБ
    //Если ДанныеДляПечати.Дата<Дата(2010,7,1) ИЛИ НЕ ЗначениеЗаполнено(ДанныеДляПечати.СтранаНазначения.УчастникТаможенногоСоюза) Тогда
    // ОбластьМакета.Область("ДатаОборотаПоРеализации").Видимость = Ложь;
    //Иначе
    // ОбластьМакета.Параметры.ДатаОборотаПоРеализации = Формат(ДанныеДляПечати.Дата,"ДФ=dd.MM.yyyy" );   
    //КонецЕсли;
    
    ОбластьМакета.Параметры.Номер = РаботаСДиалогами.СформироватьЗаголовокДокумента(ДанныеДляПечати, "Счет-фактура", глСписокПрефиксовУзлов);
    ТабДок1.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик|СчетФактура");
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ОбщегоНазначения.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование,");
    ТабДок1.Вывести(ОбластьМакета);
    
    //***************************************************************
    //ОбластьМакета.Параметры.СвидетельствоПоНДС = "Свидетельство о постановке на регистрационный учет по НДС, "+
    //		    ОбщегоНазначения.ОписаниеОрганизации(СведенияОПоставщике, "СвидетельствоПоНДС,");
    //		   
    ////Реквизиты поставщика
    //ПредставлениеРНН_БИНПоставщика = "";
    //РННиБИНПоставщика = ОбщегоНазначения.ПолучитьРегистрационныйНомерОрганизацииКонтрагентаВПечатнуюФорму(СведенияОПоставщике, ДанныеДляПечати.Дата, Истина, ПредставлениеРНН_БИНПоставщика, , Истина); 
    //ОбластьМакета.Параметры.РННИАдресПоставщика	  = РННиБИНПоставщика  + ", " +  ОбщегоНазначения.ОписаниеОрганизации(СведенияОПоставщике, "ЮридическийАдрес,");
    //ОбластьМакета.Параметры.ПредставлениеРНН_БИНПоставщика = ПредставлениеРНН_БИНПоставщика;
    //
    //ОбластьМакета.Параметры.РасчетныйСчетПоставщика    = ОбщегоНазначения.ОписаниеОрганизации(СведенияОПоставщике, "НомерСчета,Банк,БИК,");
    //
    //ТТН = "";
    //ТТН = РаботаСДиалогами.СформироватьЗаголовокДокумента(Ссылка);
    //ОбластьМакета.Параметры.ТТН = ТТН;
    //
    ////Реквизиты грузоотправителя
    //ПредставлениеРНН_БИНГрузоотправителя = "";
    //РННиБИНГрузоотправителя = ОбщегоНазначения.ПолучитьРегистрационныйНомерОрганизацииКонтрагентаВПечатнуюФорму(СведенияОГрузоотправителе, ДанныеДляПечати.Дата, Истина, ПредставлениеРНН_БИНГрузоотправителя, , Истина); 
    //ОбластьМакета.Параметры.ПредставлениеГрузоотправителя  = РННиБИНГрузоотправителя  + ", " +  ОбщегоНазначения.ОписаниеОрганизации(СведенияОГрузоотправителе, "ПолноеНаименование,ЮридическийАдрес,");
    //ОбластьМакета.Параметры.ПредставлениеРНН_БИНГрузоотправителя = ПредставлениеРНН_БИНГрузоотправителя;
    //
    ////Реквизиты грузополучателя
    //ПредставлениеРНН_БИНГрузополучателя = "";
    //РННиБИНГрузополучателя = ОбщегоНазначения.ПолучитьРегистрационныйНомерОрганизацииКонтрагентаВПечатнуюФорму(СведенияОГрузополучателе, ДанныеДляПечати.Дата, Истина, ПредставлениеРНН_БИНГрузополучателя, , Истина); 
    //ОбластьМакета.Параметры.ПредставлениеГрузополучателя  = РННиБИНГрузополучателя  + ", " +  ОбщегоНазначения.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ЮридическийАдрес,");
    //ОбластьМакета.Параметры.ПредставлениеРНН_БИНГрузополучателя = ПредставлениеРНН_БИНГрузополучателя;
    //
    //
    ////Реквизиты покупателя
    //ОбластьМакета.Параметры.ПредставлениеПокупателя    = ОбщегоНазначения.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование,");
    //
    ////Вывод БИН, если он заполнен 
    //ПредставлениеРНН_БИНПокупателя = "";
    //РННиБИНПокупателя = ОбщегоНазначения.ПолучитьРегистрационныйНомерОрганизацииКонтрагентаВПечатнуюФорму(СведенияОПокупателе, ДанныеДляПечати.Дата, Истина, ПредставлениеРНН_БИНПокупателя, , Истина); 
    //ОбластьМакета.Параметры.РННИАдресПокупателя = РННиБИНПокупателя  + ", " +  ОбщегоНазначения.ОписаниеОрганизации(СведенияОПокупателе, "ЮридическийАдрес,");
    //ОбластьМакета.Параметры.ПредставлениеРНН_БИНПокупателя = ПредставлениеРНН_БИНПокупателя;
    //
    //ОбластьМакета.Параметры.РасчетныйСчетПокупателя = ОбщегоНазначения.ОписаниеОрганизации(СведенияОПокупателе, "НомерСчета,Банк,БИК,");
    //ОбластьМакета.Параметры.Валюта = ДанныеДляПечати.ВалютаДокумента;
    //
    //ТабДок1.Вывести(ОбластьМакета);
    //ОбластьМакета = Макет.ПолучитьОбласть("Строка1");
    //ИтогоСуммаНДС = 0;
    //ИтогоВсего    = 0;
    //ВыборкаСтрокТовары = KZERT21ывф24выа521ваыas121(ДанныеДляПечати);
    //Инд = 1;
    //Для Каждого Строчка Из ВыборкаСтрокТовары Цикл
    //
    // ОбластьМакета.Параметры.Заполнить(Строчка);
    // ОбластьМакета.Параметры.НомерСтроки = Инд;
    // ТабДок1.Вывести(ОбластьМакета);
    // Инд = Инд + 1;
    //КонецЦикла;
    //ОбластьМакета = Макет.ПолучитьОбласть("Итого1");
    //ОбластьМакета.Параметры.ИтогоСуммаНДС    = ВыборкаСтрокТовары.Итог("СуммаНДС");
    //ОбластьМакета.Параметры.ИтогоСтоимостьБезНДС  = ВыборкаСтрокТовары.Итог("СтоимостьБезНДС");
    //ОбластьМакета.Параметры.ИтогоВсего	   = ВыборкаСтрокТовары.Итог("Всего");
    //ОбластьМакета.Параметры.ИтогоСуммаАкциза   = ВыборкаСтрокТовары.Итог("СуммаАкциза");
    //ТабДок1.Вывести(ОбластьМакета);
    //ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
    //ОбластьМакета.Параметры.Заполнить(ДанныеДляПечати);
    //
    //Руководители = ОбщегоНазначения.ОтветственныеЛицаОрганизаций(KZERT215sa5d754545a4sd21, ДанныеДляПечати.Дата);
    ////заполним уполномоченного за главного бухгалтера для подписи счета-фактуры
    //Если ЗначениеЗаполнено(Руководители.УполномоченныйПодписыватьСчетаФактурыЗаГлавногоБухгалтера) Тогда
    // ДолжностьГлБухгалтера = ?(НЕ ЗначениеЗаполнено(Руководители.УполномоченныйПодписыватьСчетаФактурыЗаГлавногоБухгалтераДолжность), "<Должность не указана>: ", Руководители.УполномоченныйПодписыватьСчетаФактурыЗаГлавногоБухгалтераДолжность + ": "); 
    // ОбластьМакета.Параметры.ФИОГлавногоБухгалтера = ДолжностьГлБухгалтера + Руководители.УполномоченныйПодписыватьСчетаФактурыЗаГлавногоБухгалтера;
    //Иначе
    // ДолжностьГлБухгалтера = "Главный бухгалтер: ";
    // ГлавныйБухгалтер = ?(НЕ ЗначениеЗаполнено(Руководители.ГлавныйБухгалтер), "Не предусмотрен", Руководители.ГлавныйБухгалтер);
    // ОбластьМакета.Параметры.ФИОГлавногоБухгалтера = ДолжностьГлБухгалтера + ГлавныйБухгалтер;
    //КонецЕсли;
    //
    ////заполним уполномоченного за руководителя для подписи счета-фактуры
    //Если ЗначениеЗаполнено(Руководители.УполномоченныйПодписыватьСчетаФактурыЗаРуководителя) Тогда
    // ДолжностьРуководителя = ?(НЕ ЗначениеЗаполнено(Руководители.УполномоченныйПодписыватьСчетаФактурыЗаРуководителяДолжность), " ", Руководители.УполномоченныйПодписыватьСчетаФактурыЗаРуководителяДолжность + ": "); 
    // ОбластьМакета.Параметры.ФИОРуководителя =  ДолжностьРуководителя + Руководители.УполномоченныйПодписыватьСчетаФактурыЗаРуководителя;
    //Иначе
    // ДолжностьРуководителя = "Руководитель: "; 
    // ОбластьМакета.Параметры.ФИОРуководителя = ДолжностьРуководителя + Руководители.Руководитель;
    //КонецЕсли;   
    //
    //Если НЕ  ДанныеДляПечати.Ответственный.ФизЛицо.Пустая() Тогда
    // ДанныеОтветственногоЛица = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(ДанныеДляПечати.Организация, ДанныеДляПечати.Ответственный.ФизЛицо, ДанныеДляПечати.Дата);
    // ОбластьМакета.Параметры.ФИОИсполнителя = ДанныеОтветственногоЛица.Представление;
    // ОбластьМакета.Параметры.ДолжностьИсполнителя = ДанныеОтветственногоЛица.Должность;
    //КонецЕсли; 
    
    
    ТабДок.Присоединить(ТабДок1);
    ТабДок1.очистить();
    
    Возврат ТабДок;
    

Поделиться этой страницей