8.х Внешняя обработка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Goth, 23 апр 2007.

  1. TopicStarter Overlay
    Goth
    Offline

    Goth

    Регистрация:
    4 апр 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    У меня есть внешняя обработка. Во внешней обработке есть документ с табличным полем. как перебрать все элементы табличного поля.
  2. dend
    Offline

    dend Опытный в 1С

    Регистрация:
    9 апр 2007
    Сообщения:
    175
    Симпатии:
    0
    Баллы:
    26
    Для Каждого Строка Из ИмяТабличногоПоля(или ТабличнойЧасти) Цикл
    КонецЦикла
  3. TopicStarter Overlay
    Goth
    Offline

    Goth

    Регистрация:
    4 апр 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Как сделать так, чтобы если в поле, где есть флажок, стоит галочка выполнялось нужное мне условие.
    Вот моя процедура.

    Код:
    Процедура Торг12(ЭтотЗаказ) ЭКСПОРТ
    
    Для Каждого Строка ИЗ ТаблицаЗаказов Цикл 
    
    Если ЭлементыФормы.ФлагЗаказа.Значение=Истина И ЭлементыФормы.ФлагПроведенных.Значение=Истина Тогда
    ПечатьТОРГ12(ЭтотЗаказ);            
    ИначеЕсли ЭлементыФормы.ФлагПроведенных.Значение=Ложь И ЭлементыФормы.ФлагЗаказа.Значение=Истина Тогда
    Предупреждение("Необходимо провести документ");
    Иначе
    Продолжить;
    КонецЕсли;    
    
    КонецЦикла;
    
    КонецПроцедуры 
    
    :unsure:
Похожие темы
  1. Alexander2
    Ответов:
    3
    Просмотров:
    634
Загрузка...

Поделиться этой страницей