7.7 Внешняя обработка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем al-mark, 3 фев 2009.

  1. TopicStarter Overlay
    al-mark
    Offline

    al-mark

    Регистрация:
    3 фев 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Решил себе в помощь замутить в 1с Предприниматель внешнюю обработку, которая будет печатать квитанцию для оплаты налогов через Сбербанк . Возникла проблема, список открывается с наименованиями, но при выборе строка остается пустой.
    Подскажите что не так сделал?

    Вложения:

  2. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Вы бы код показали, а не форму.
  3. TopicStarter Overlay
    al-mark
    Offline

    al-mark

    Регистрация:
    3 фев 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1

    Вложения:

  4. unknown181538
    Offline

    unknown181538

    Регистрация:
    24 фев 2008
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    Я бы сделал элемент на форме "Поле со списком", и добавлял бы значения в процедуре "ПриОткрытии". А то получается, что вы при начале выбора все значения создаете. Можте и так конечно можно.
  5. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Во-первых, код лучше текстом вставлять, а не картинкой:)
    Во-вторых, если СтатусСоставителя - это идентификатор поля ввода, то зачем еще и переменную с таким именем использовать?
    В-третьих, зачем создавать списки значений каждый раз при выборе элемента?
    В общем, чтобы работало, нужно сделать примерно так:

    Код:
    //поле ввода на форме имеет идентификатор "СтатусСоставителя" и тип "текст"
    Перем сзСтатусСоставителя; //список значений для нашего поля
    
    Процедура ПриОткрытии()
    сзСтатусСоставителя = СоздатьОбъект("СписокЗначений");
    сзСтатусСоставителя.ДобавитьЗначение("02","02-налоговый агент");
    сзСтатусСоставителя.ДобавитьЗначение("09","09-налогоплательщик (плательщик сборов) - ИП");
    //и т.д. по списку
    КонецПроцедуры
    
    Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога)
    Если ИдентЭлемДиалога = "СтатусСоставителя" Тогда
    сзСтатусСоставителя.ВыбратьЗначение(СтатусСоставителя,,,,2);
    ИначеЕсли ИдентЭлемДиалога = "ОснованиеПлатежа" Тогда
    //и т.д. по элементам
    КонецЕсли;
    КонецПроцедуры
    
    P.S. Как сказали выше, в таких случаях лучше использовать поле со списком
  6. TopicStarter Overlay
    al-mark
    Offline

    al-mark

    Регистрация:
    3 фев 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо за помощь!
Похожие темы
  1. Alexander2
    Ответов:
    3
    Просмотров:
    635
Загрузка...

Поделиться этой страницей