8.х Внешняя обработка вывод результатов в таблчасть

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Игорь322, 1 дек 2016.

  1. TopicStarter Overlay
    Игорь322
    Offline

    Игорь322

    Регистрация:
    2 ноя 2016
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    И так по порядку. Есть Обработка внешняя в ней есть ТаблЧасть. Есть форма и на ней указываются параметры для запроса и кнопка сформировать результат. Указываю параметры нажимаю сформировать выдает такую ошибку
    {ВнешняяОбработка.ГруповоеСохранениеПечатныхФорм.Форма.Форма.Форма(23)}: Значение не является значением объектного типа (Показать)
    ТабличнаяЧасть.Показать ();

    в чем может быть проблема? я думаю в кнопки, через консоль запрос работает хорошо

    код кнопки
    &НаКлиенте
    Процедура Сформировать(Команда)

    ТабличнаяЧасть = Формирование();

    ТабличнаяЧасть.Показать ();

    КонецПроцедуры


    &НаСервере
    Функция Формирование () Экспорт

    ОбъектОбработка = РеквизитФормыВЗначение("Объект");

    ТабличнаяЧасть = ЭтотОбъект.ЗапросРеализацияСчетФактура();

    Возврат ТабличнаяЧасть ;

    КонецФункции



    код запроса

    &НаСервере
    Функция ЗапросРеализацияСчетФактура () Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Дата,
    | РеализацияТоваровУслуг.Проведен,
    | РеализацияТоваровУслуг.Организация,
    | РеализацияТоваровУслуг.Контрагент,
    | СчетФактураВыданный.ДокументОснование,
    | РеализацияТоваровУслуг.Номер
    |ИЗ
    | Документ.СчетФактураВыданный КАК СчетФактураВыданный
    | ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    | ПО СчетФактураВыданный.ДокументОснование = РеализацияТоваровУслуг.Ссылка
    |ГДЕ
    | РеализацияТоваровУслуг.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания
    | И РеализацияТоваровУслуг.Проведен = &Проведен
    | И РеализацияТоваровУслуг.Организация = &Организация
    | И РеализацияТоваровУслуг.Контрагент В(&Контрагент)
    | И РеализацияТоваровУслуг.Ссылка = &Ссылка" ;




    Запрос.УстановитьПараметр("ДатаНачала",Объект.Период.ДатаНачала );
    Запрос.УстановитьПараметр("ДатаОкончания",Объект.Период.ДатаОкончания );
    Запрос.УстановитьПараметр("Проведен",Объект.Проведенные );
    Запрос.УстановитьПараметр("Организация",Объект.Организация );
    Запрос.УстановитьПараметр("Контрагент",ЭтаФорма.Контрагент);
    Запрос.УстановитьПараметр("Ссылка",Объект.РеализацияТоваровУслуг);

    НомерПП = 1;
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Объект.ТабличнаяЧасть.Очистить();
    Пока Выборка.Следующий() Цикл
    НовСтр = Объект.ТабличнаяЧасть.Добавить();
    НовСтр.НомерПП = НомерПП;
    НомерПП = НомерПП + 1;
    НовСтр.РеализацияТИУ = "" +ЭтаФорма.Контрагент + " " + Объект.РеализацияТоваровУслуг.Номер + " " + Объект.РеализацияТоваровУслуг.Дата ;
    НовСтр.СчетфактураВыданный = "" +ЭтаФорма.Контрагент + " " + Объект.РеализацияТоваровУслуг.Номер + " " + Объект.РеализацияТоваровУслуг.Дата ;


    КонецЦикла;



    Возврат Истина
    КонецФункции
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.438
    Симпатии:
    328
    Баллы:
    104
    У табличной части нет метода Показать().
  3. TopicStarter Overlay
    Игорь322
    Offline

    Игорь322

    Регистрация:
    2 ноя 2016
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    а какой есть?
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    15.088
    Симпатии:
    543
    Баллы:
    204
    Игорь, вы сами писали этот код ?
    --- Объединение сообщений, 1 дек 2016 ---
    Никакого нет, она и так отображается.
  5. TopicStarter Overlay
    Игорь322
    Offline

    Игорь322

    Регистрация:
    2 ноя 2016
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    да сам, до этого так делал, с макетом. в макете норм все выводилось. думал так же получиться сделать с табчастью
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    15.088
    Симпатии:
    543
    Баллы:
    204
    Спешу вас огорчить, табличный документ и таблица значений разный тип данных. Вы хотя бы справку в конфигураторе почитайте
  7. TopicStarter Overlay
    Игорь322
    Offline

    Игорь322

    Регистрация:
    2 ноя 2016
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    да я уже понял что разные.
    я вот что подумал на кнопку назначить сразу функцию с запросом
  8. web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    926
    Симпатии:
    4
    Баллы:
    29
    :D:D:D, Игорек, читай внимательно Синтакс-помощник, там вссеееее написано. Например ты знаешь что тип твоей переменной ТабличнаяЧасть - табличная часть, открываешь :

    upload_2016-12-1_15-3-45.png

    и так со всеми объектами и типами 1С. Удачи!
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    15.088
    Симпатии:
    543
    Баллы:
    204
    Так же можно результат запроса выгрузить в таблицу значений и показать ее, методом ВыбратьСтроку()
  10. TopicStarter Overlay
    Игорь322
    Offline

    Игорь322

    Регистрация:
    2 ноя 2016
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    все сделал вот, что получилось


    Код:
    &НаКлиенте
    Процедура Сформировать(Команда)
     
        Формирование ();
     
    КонецПроцедуры
    
    
    &НаСервере
    Процедура Формирование ()  Экспорт
     
        ОбъектОбработка    = РеквизитФормыВЗначение("Объект");
        ЗапросРеализацияСчетФактура();
     
         
    КонецПроцедуры
    
    
    &НаСервере  
    Процедура  ЗапросРеализацияСчетФактура ()     Экспорт
        Запрос         = Новый Запрос;
        Запрос.Текст   =   "ВЫБРАТЬ
                           |    РеализацияТоваровУслуг.Дата,
                           |    РеализацияТоваровУслуг.Проведен,
                           |    РеализацияТоваровУслуг.Организация,
                           |    РеализацияТоваровУслуг.Контрагент,
                           |    СчетФактураВыданный.ДокументОснование,
                           |    РеализацияТоваровУслуг.Номер
                           |ИЗ
                           |    Документ.СчетФактураВыданный КАК СчетФактураВыданный
                           |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                           |        ПО СчетФактураВыданный.ДокументОснование = РеализацияТоваровУслуг.Ссылка
                           |ГДЕ
                           |    РеализацияТоваровУслуг.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания
                           |    И РеализацияТоваровУслуг.Проведен = &Проведен
                           |    И РеализацияТоваровУслуг.Организация = &Организация
                           |    И РеализацияТоваровУслуг.Контрагент В(&Контрагент)"  ;
     
     
     
     
        Запрос.УстановитьПараметр("ДатаНачала",Объект.Период.ДатаНачала );
        Запрос.УстановитьПараметр("ДатаОкончания",Объект.Период.ДатаОкончания );
        Запрос.УстановитьПараметр("Проведен",Объект.Проведенные );  
        Запрос.УстановитьПараметр("Организация",Объект.Организация );
        Запрос.УстановитьПараметр("Контрагент",ЭтаФорма.Контрагент);
        //Запрос.УстановитьПараметр("Ссылка",Объект.РеализацияТоваровУслуг.Ссылка);
     
        НомерПП =    1;
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать();
        Объект.ТабличнаяЧасть.Очистить();
        Пока Выборка.Следующий() Цикл
            НовСтр = Объект.ТабличнаяЧасть.Добавить();
            НовСтр.НомерПП =   НомерПП;
            НомерПП = НомерПП +   1;      
            НовСтр.РеализацияТИУ = Выборка.Контрагент + " " + Выборка.Номер + " "   + Выборка.Дата   ;
            НовСтр.СчетфактураВыданный =  "" +Выборка.Контрагент + " " + Выборка.Номер + " "   + Выборка.Дата   ;
         
    
        КонецЦикла;
         
    КонецПроцедуры
    Последнее редактирование модератором: 2 дек 2016
  11. web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    926
    Симпатии:
    4
    Баллы:
    29
    ну и? весь твой код кончается на том что ты формируешь запрос на реврере, что дальше будешь делать?
    --- Объединение сообщений, 1 дек 2016 ---
    ааа, нет
    --- Объединение сообщений, 1 дек 2016 ---
    просто читать код не удобно вне конфигуратора :)

Поделиться этой страницей