7.7 Внешняя обработка выдает ошибку

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем decker, 30 окт 2013.

  1. TopicStarter Overlay
    decker
    Offline

    decker

    Регистрация:
    30 окт 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Имеется 1С 7.7 ТиС 9.2, оптово-розничная конфигурация 7.70.932 и внешняя обработка Печать этикеток на А4 с позиционированием.
    При попытке напечатать этикетки по приходной накладной выдает сообщение:
    Код:
    Конт.ВыбратьСтроки();
    {\\INSTR\1С БАЗЫ\ПБОЮЛ\EXTFORMS\PRNFORMS\ПЕЧАТЬ ЭТИКЕТОК НА А4 С ПОЗИЦИОНИРОВАНИЕМ .ERT(406)}: Поле агрегатного объекта не обнаружено (ВыбратьСтроки)
    Прошу помощи участников сообщества, тк обработка довольно удобная для тех кто не имеет принтера этикеток.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Сначала запишите документ, а потом отправляйте на печать. Или при передаче параметров используйте глВзятьКонтекст
  3. TopicStarter Overlay
    decker
    Offline

    decker

    Регистрация:
    30 окт 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Документ (приходная накладная) записан и проведен.
    При замене (404) Конт = Форма.Параметр => Конт = Форма.Параметр.Получить("Контекст") обработка выдает ошибку

    Код:
    ТаблицаТоваров1.Номенклатура = Конт.Номенклатура;
    {\\INSTR\1С БАЗЫ\ПБОЮЛ\EXTFORMS\PRNFORMS\ПЕЧАТЬ ЭТИКЕТОК НА А4 С ПОЗИЦИОНИРОВАНИЕМ .ERT(409)}: Поле агрегатного объекта не обнаружено (Номенклатура)
    
    Модуль обработки:
    Код:
    Перем СтрокНаЛист, КолонокНаЛист, ТаблицаПечати;
    Перем Список;
    Перем ЗнП,ЗнНеП,ТекСтрокаВТаблице,расшифровка;
    Перем ТаблицаТоваров;
    
    Процедура Сформировать() Далее
    Процедура ОбрФорматБумаги()  Далее  
    //_____________________________________________________________________________
    Процедура ВриВыбореЯрлыка()  
    ОбрФорматБумаги()   ;
    //Если Ярлык = 1 Тогда
    // ТаблицаПечати = "70_37_Ярлык"
    //Иначе
    // ТаблицаПечати = "70_37";
    //КонецЕсли;
    КонецПроцедуры //ВриВыбореЯрлыка()
    //******************************************************************************
    Процедура ВыделитьВсе(Тип)
    Для ТекСтрока = 1 по ТЗ.КоличествоСтрок() Цикл
    Для ТекКолонка = 1 По ТЗ.КоличествоКолонок() Цикл
    ТЗ.УстановитьЗначение(ТекСтрока,ТекКолонка,Тип);
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
    //*****************************************************************************
    Процедура ОбрФорматБумаги()  
    Если ФорматБумаги.ТекущаяСтрока() = 1 Тогда
    СтрокНаЛист   = 1;
    КолонокНаЛист = 1;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "210_297_Ярлык"
    Иначе
    ТаблицаПечати = "210_297";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 2 Тогда
    СтрокНаЛист   = 2;
    КолонокНаЛист = 1;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "210_148_Ярлык"
    Иначе
    ТаблицаПечати = "210_148";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 3 Тогда
    СтрокНаЛист   = 3;
    КолонокНаЛист = 1;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "210_99_Ярлык"
    Иначе
    ТаблицаПечати = "210_99";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 4 Тогда
    СтрокНаЛист   = 2;
    КолонокНаЛист = 2;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "105_148_Ярлык"
    Иначе
    ТаблицаПечати = "105_148";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 5 Тогда
    СтрокНаЛист   = 3;
    КолонокНаЛист = 2;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "105_99_Ярлык"
    Иначе
    ТаблицаПечати = "105_99";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 6 Тогда
    СтрокНаЛист   = 4;
    КолонокНаЛист = 2;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "105_74_Ярлык"
    Иначе
    ТаблицаПечати = "105_74";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 7 Тогда
    СтрокНаЛист   = 5;
    КолонокНаЛист = 2;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "105_59_Ярлык"
    Иначе
    ТаблицаПечати = "105_59";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 8 Тогда
    СтрокНаЛист   = 7;
    КолонокНаЛист = 2;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "105_42_Ярлык"
    Иначе
    ТаблицаПечати = "105_42";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 9 Тогда
    СтрокНаЛист   = 7;
    КолонокНаЛист = 3;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "70_42_Ярлык"
    Иначе
    ТаблицаПечати = "70_42";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 10 Тогда
    СтрокНаЛист   = 8;
    КолонокНаЛист = 3;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "70_37_Ярлык"
    Иначе
    ТаблицаПечати = "70_37";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 11 Тогда
    СтрокНаЛист   = 10;
    КолонокНаЛист = 4;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "48_25_Ярлык"
    Иначе
    ТаблицаПечати = "48_25";
    КонецЕсли;
    ИначеЕсли ФорматБумаги.ТекущаяСтрока() = 12 Тогда
    СтрокНаЛист   = 13;
    КолонокНаЛист = 5;
    Если Ярлык = 1 Тогда
    ТаблицаПечати = "38_21_Ярлык"
    Иначе
    ТаблицаПечати = "38_21";
    КонецЕсли;
    КонецЕсли;
    //Если ФорматБумаги.ТекущаяСтрока() = 1 Тогда
    // СтрокНаЛист   = 8;
    // КолонокНаЛист = 3;
    // Если Ярлык = 1 Тогда
    //  ТаблицаПечати = "70_37_Ярлык"
    // Иначе
    //  ТаблицаПечати = "70_37";
    // КонецЕсли;
    // Форма.Ярлык .Видимость(1);
    // Форма.Ярлык1.Видимость(1);
    // Ярлык =1;
    //Иначе
    // Форма.Ярлык .Видимость(0);
    // Форма.Ярлык1.Видимость(0);
    // Если ФорматБумаги.ТекущаяСтрока() = 2 Тогда
    //  СтрокНаЛист   = 10;
    //  КолонокНаЛист = 4;
    //  ТаблицаПечати = "48_25";
    // КонецЕсли;
    //КонецЕсли;  
    ТекСтрока  = 0;
    ТекКолонка = 0;	  
    ТЗ.Очистить();
    Для ТекКолонка = 1 По КолонокНаЛист Цикл
    ТЗ.НоваяКолонка(,"Число",4,0,,3);
    ТЗ.ВыводитьПиктограммы(ТекКолонка,1);
    КонецЦикла;
    ТекСтрока = 0;
    Для ТекСтрока = 1 По СтрокНаЛист Цикл
    ТЗ.НоваяСтрока();
    КонецЦикла;
    КонецПроцедуры
    //******************************************************************************
    Функция ПерерисовкаНазванийЗакладок()	
    Врем = Форма.Закладки.ПолучитьЗначение(2);
    Форма.Закладки.УстановитьЗначение(2, Врем,?(глМножественныйФильтрЗадан(ТаблицаМФ)=1,"(!) ","")+"Множественный фильтр");
    КонецФункции // ПерерисовкаНазванийЗакладок
    //*****************************************************************************
    Процедура УправлениеДиалогом()
    ТекСтрока = Форма.Закладки.ТекущаяСтрока();
    Форма.ИспользоватьСлой(Форма.Закладки.ПолучитьЗначение(ТекСтрока));
    КонецПроцедуры // УправлениеДиалогом()
    //*****************************************************************************
    Процедура ПриВыбореЗакладки(НомерЗакладки,ЗначениеЗакладки)
    УправлениеДиалогом();
    ПерерисовкаНазванийЗакладок();
    КонецПроцедуры // ПриВыбореЗнакладки()
    //******************************************************************************
    // ВыбратьПоФильтру()
    Процедура ВыбратьПоФильтру()
    
    Перем  ВидЗначенияПодбора;
    ВидЗначенияПодбора=СокрЛП(ТаблицаМФ.Вид);
    
    Если ПустоеЗначение(ВидЗначенияПодбора)=1 Тогда
    Возврат;
    КонецЕсли;
    
    СписокПараметров=СоздатьОбъект("СписокЗначений");
    СписокПараметров.ДобавитьЗначение("",				"ИмяВызвавшейФормы");
    СписокПараметров.ДобавитьЗначение(ТаблицаМФ.Тип,	 "Тип");
    СписокПараметров.ДобавитьЗначение(ВидЗначенияПодбора,"Вид");
    СписокПараметров.ДобавитьЗначение(СписокЭлементовМФ, "Объекты");
    ТаблицаМФ.ФлВкл=2;
    ОткрытьФорму("Обработка.ПодборОбъектов#",СписокПараметров);
    КонецПроцедуры // ВыбратьПоФильтру
    //*****************************************************************************
    Процедура ОбработкаКликаПоТаблице1()
    ТекКолонка = ТаблицаТоваров1.ТекущаяКолонка();
    ТекСтрока  = ТаблицаТоваров1.ТекущаяСтрока();
    Если ТекКолонка = "Количество" Тогда
    Кол = ТаблицаТоваров1.Количество;
    ВвестиЧисло(Кол,"Введите количество",2,0);
    ТаблицаТоваров1.УстановитьЗначение(ТекСтрока,ТекКолонка,Кол);
    Иначе
    ОткрытьФорму(ТаблицаТоваров1.Номенклатура);
    КонецЕсли;
    КонецПроцедуры
    //*****************************************************************************
    Процедура ФормТаблТоваров()
    Перем Запрос, ТекстЗапроса;
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "Номенклатура = Справочник.Номенклатура.ТекущийЭлемент;
    |ШтрихКод	 = Справочник.Номенклатура.БазоваяЕдиница.ШтрихКод;
    |Группировка Номенклатура;
    |Условие(Номенклатура в СписокЭлементовМФ);
    |";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    ТаблицаТоваров=СоздатьОбъект("ТаблицаЗначений");
    ТаблицаТоваров.НоваяКолонка("Номенклатура","Справочник.Номенклатура");
    ТаблицаТоваров.НоваяКолонка("Количество"  ,"Число",2,0);
    ТаблицаТоваров.НоваяКолонка("ШтрихКод"	,"Строка");
    Пока Запрос.Группировка(1) = 1 Цикл  
    Если Запрос.Номенклатура.ЭтоГруппа()=0 Тогда
    ТаблицаТоваров.НоваяСтрока();
    ТаблицаТоваров.Номенклатура = Запрос.Номенклатура;
    ТаблицаТоваров.Количество   = 1;
    ТаблицаТоваров.ШтрихКод	 = Запрос.ШтрихКод;  
    КонецЕсли;
    КонецЦикла;
    ТаблицаТоваров1.Загрузить(ТаблицаТоваров);
    Форма.Закладки.ТекущаяСтрока(1);
    ПриВыбореЗакладки(1,Форма.Закладки.ПолучитьЗначение(1));
    КонецПроцедуры
    //******************************************************************************
    // ОбработкаКликаПоТаблице()
    Процедура ОбработкаКликаПоТаблице()
    ТекКолонка = ТЗ.ТекущаяКолонка();
    ТекСтрока  = ТЗ.ТекущаяСтрока();
    Если (ТЗ.ПолучитьЗначение(ТекСтрока,ТекКолонка) = 0) или (ТЗ.ПолучитьЗначение(ТекСтрока,ТекКолонка) = 1) Тогда
    ТЗ.УстановитьЗначение(ТекСтрока,ТекКолонка,ЗнП);
    Иначе
    ТЗ.УстановитьЗначение(ТекСтрока,ТекКолонка,ЗнНеП);
    КонецЕсли;
    КонецПроцедуры // ОбработкаКликаПоТаблице()()
    //******************************************************************************
    // Сформировать(Штрихкод, Устройство)
    Процедура Сформировать()
    
    Если ТаблицаТоваров1.КоличествоСтрок() = 0  Тогда
    Предупреждение("Не создан перечень ТМЦ для печати");
    Возврат;
    КонецЕсли;
    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица(ТаблицаПечати);
    
    ТекПозицияТовара = 1;
    Кол_ = -1;
    Для ТекСтрока = 1 По ТЗ.КоличествоСтрок() Цикл
    Для ТекКолонка = 1 По ТЗ.КоличествоКолонок() Цикл
    Если ТЗ.ПолучитьЗначение(ТекСтрока,ТекКолонка) = 1 Тогда
    Товар	= "";
    ПечТовар = "";
    Если ФорматБумаги.ТекущаяСтрока() = 2 Тогда
    ПечТовар = "."+РазделительСтрок+"."+РазделительСтрок+".";  
    КонецЕсли;
    Код	  = "";
    ПечЦена  = "";
    ПечСтрана= "";  
    ПечДата = "";
    ПечДиз="";
    Иначе																	
    Если Кол_  = -1  Тогда
    Кол_ = ТаблицаТоваров1.ПолучитьЗначение(ТекПозицияТовара,"Количество");
    КонецЕсли;
    Товар	= ТаблицаТоваров1.ПолучитьЗначение(ТекПозицияТовара,"Номенклатура");
    ПечСтрана= Товар.СтранаПроисхождения;
    //ПечТовар = ?(Константа.ПоказыватьАртикул=1,"арт. "+СокрЛП(Товар.Артикул),"")+РазделительСтрок;
    //Если Ярлык = 2 Тогда
    // ПечТовар = ПечТовар + СокрЛП(Товар.Комментарий);
    //Иначе
    ПечТовар = СокрЛП(Товар.Наименование);
    ПечКод =   Товар.Код;
    ПечДата =  ТекущаяДата();
    ПечДиз = "Дизайн Сити";
    //Если ФорматБумаги.ТекущаяСтрока() = 2 Тогда
    // //только 3 строки
    // Поз = Найти(ПечТовар,"ГОСТ");
    // Если Поз <> 0 Тогда
    //	 ПечТовар = Лев(ПечТовар,Поз-1);
    // КонецЕсли;
    //КонецЕсли;
    //КонецЕсли;
    Код	  = Товар.БазоваяЕдиница.ШтрихКод;	
    ЦенаЦены = ""; ЕдЦены   = ""; ВалЦены  = "";
    Если глВернутьЦену(Товар,ТипЦен,РабочаяДата(),ЦенаЦены,ЕдЦены,ВалЦены) = 1 Тогда
    ЦенаЦены = ЦенаЦены/ЕдЦены.Коэффициент*Товар.БазоваяЕдиница.Коэффициент;
    ЦенаЦены = глПересчет(ЦенаЦены,ВалЦены,РабочаяДата(),Константа.ВалютаБухУчета,РабочаяДата());
    ПечЦена  = СокрЛП(Формат(ЦенаЦены,"Ч15.2-'"));
    Иначе
    ПечЦена  = "";
    КонецЕсли;
    Если Кол_ = 1 Тогда
    ТекПозицияТовара = ТекПозицияТовара + 1;
    Если ТекПозицияТовара > ТаблицаТоваров1.КоличествоСтрок() Тогда
    Если ТекСтрока = 1 Тогда
    ИмяСтроки = "СтрокаПервая"  
    ИначеЕсли ТекСтрока = ТЗ.КоличествоСтрок() Тогда
    ИмяСтроки = "СтрокаПоследняя";
    Иначе
    ИмяСтроки = "СтрокаСледующая";
    КонецЕсли;
    
    Если ТекКолонка = 1 Тогда
    Таб.ВывестиСекцию(ИмяСтроки+"|Колонка1");
    Иначе
    Таб.ПрисоединитьСекцию(ИмяСтроки+"|Колонка"+Строка(ТекКолонка));
    КонецЕсли;
    Перейти ~Конец;
    КонецЕсли;
    Кол_ = -1;
    Иначе
    Кол_ = Кол_ - 1;
    КонецЕсли;
    КонецЕсли;		
    
    Если ТекСтрока = 1 Тогда
    ИмяСтроки = "СтрокаПервая"  
    ИначеЕсли ТекСтрока = ТЗ.КоличествоСтрок() Тогда
    ИмяСтроки = "СтрокаПоследняя";
    Иначе
    ИмяСтроки = "СтрокаСледующая";
    КонецЕсли;
    
    Если ТекКолонка = 1 Тогда
    Таб.ВывестиСекцию(ИмяСтроки+"|Колонка1");
    Иначе
    Таб.ПрисоединитьСекцию(ИмяСтроки+"|Колонка"+Строка(ТекКолонка));
    КонецЕсли;
    
    КонецЦикла;
    КонецЦикла;
    
    ~Конец:
    Таб.Опции(0, 0, 0, 0, "ПечатьЭтикетки", "ПечатьЭтикетки");
    Таб.ПараметрыСтраницы(1,,,0,0,0,0,0,0);
    Таб.Показать("Печать Этикетки");
    КонецПроцедуры
    //******************************************************************************
    // Предопределенная процедура
    Процедура ОбработкаПодбора(Значение)
    Если (СписокЭлементовМФ.НайтиЗначение(Значение)=0) Тогда
    Представление=""+Значение;
    Если ТипЗначенияСтр(Значение)="Справочник" Тогда
    Если СокрЛП(Метаданные.Справочник(Значение.Вид()).Владелец) <> "Метаданные" Тогда
    Представление=Представление+" ("+Значение.Владелец+")";
    КонецЕсли;
    КонецЕсли;
    СписокЭлементовМФ.ДобавитьЗначение(Значение,Представление);
    ТаблицаМФ.ФлВкл=2;
    КонецЕсли;
    КонецПроцедуры  // ОбработкаПодбора
    //******************************************************************************
    // Предопределенная процедура
    Процедура ВводНового()
    УправлениеДиалогом();
    ПерерисовкаНазванийЗакладок();
    ТаблицаМФ.ВыводитьПиктограммы("ФлВкл");
    КонецПроцедуры // ВводНового()
    //******************************************************************************
    // Предопределенная процедура
    Процедура ПриОткрытии()  
    ТаблицаМФ.ВидимостьКолонки("Тип"			,0);
    ТаблицаМФ.ВидимостьКолонки("Вид"			,0);
    ТаблицаМФ.ВидимостьКолонки("СписокЭлементов",0);		
    ТаблицаМФ.ВидимостьКолонки("ТипМФ"		  ,0);
    ТаблицаМФ.ВидимостьКолонки("ИмяПеременной"  ,0);
    ТаблицаМФ.ВыводитьПиктограммы("ФлВкл");
    
    УправлениеДиалогом();
    ПерерисовкаНазванийЗакладок();  
    
    ФорматБумаги.УдалитьВсе();
    
    ФорматБумаги.ДобавитьЗначение(1,"А4/1(210х297)");	 //1
    ФорматБумаги.ДобавитьЗначение(1,"А4/2(210х148,5)");   //2
    ФорматБумаги.ДобавитьЗначение(1,"А4/3(210х99)");	  //3
    ФорматБумаги.ДобавитьЗначение(1,"А4/4(105,0х148,5)"); //4
    ФорматБумаги.ДобавитьЗначение(1,"А4/6(105,0х99,0)");  //5
    ФорматБумаги.ДобавитьЗначение(1,"А4/8(105,0х74,3)");  //6
    ФорматБумаги.ДобавитьЗначение(1,"А4/10(105,0х59,4)"); //7
    ФорматБумаги.ДобавитьЗначение(1,"А4/14(105,0х42,3)"); //8
    ФорматБумаги.ДобавитьЗначение(1,"А4/21(70,0х42,3)");  //9
    ФорматБумаги.ДобавитьЗначение(1,"А4/24(70,0х37,0)");  //10
    ФорматБумаги.ДобавитьЗначение(1,"А4/40(48,5х25,4)");  //11
    ФорматБумаги.ДобавитьЗначение(1,"А4/65(38,0х21,2)");  //12
    
    ФорматБумаги.ТекущаяСтрока(12);
    ОбрФорматБумаги();
    ВыделитьВсе(ЗнНеП);
    ТипЦен = Константа.РозничныйТипЦен;
    
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    Конт = Форма.Параметр.Получить("Контекст");  //Конт = Форма.Параметр;
    
    Конт.ВыбратьСтроки();
    Пока Конт.ПолучитьСтроку() = 1 Цикл
    ТаблицаТоваров1.НоваяСтрока();
    ТаблицаТоваров1.Номенклатура = Конт.Номенклатура;
    ТаблицаТоваров1.Количество   = Конт.Количество;
    КонецЦикла;
    КонецЕсли;
    
    КонецПроцедуры // ПриОткрытии()
    //******************************************************************************
    // добавим закладки
    Форма.ИспользоватьЗакладки(1);
    Форма.Закладки.ДобавитьЗначение("Кнопки,Печать","Основная");
    Форма.Закладки.ДобавитьЗначение("МФ,Кнопки","Множественный фильтр");
    Форма.Закладки.ТекущаяСтрока(1);
    // инициализация переменных множественного фильтра
    ТипМФ.УдалитьВсе();
    ТипМФ.ДобавитьЗначение("одно из");
    ТипМФ.ДобавитьЗначение("все кроме");
    ТаблицаМФ.УдалитьСтроки();
    Пока ТаблицаМФ.КоличествоКолонок()>0 Цикл
    ТаблицаМФ.УдалитьКолонку(1);
    КонецЦикла;
    ТаблицаМФ.НоваяКолонка("Тип");
    ТаблицаМФ.НоваяКолонка("Вид");
    ТаблицаМФ.НоваяКолонка("ИмяПеременной");
    ТаблицаМФ.НоваяКолонка("СписокЭлементов"); // список элементов, по которым производим фильтрацию
    ТаблицаМФ.НоваяКолонка("ТипМФ"); // текущая строка списка ТипМФ
    ТаблицаМФ.НоваяКолонка("ФлВкл","Число",1,,"Вкл",5,,); // фильтр включен ("1" или "0")
    ТаблицаМФ.НоваяКолонка("Представление",,,,"Вид фильтра:");
    ТаблицаМФ.ВыводитьПиктограммы("ФлВкл");
    
    //				  тип		  вид		   переменная  название
    глДобавитьВТаблицуМФ(ТаблицаМФ,"Справочник","Номенклатура", "Номенклатура",  "По номенклатуре");
    глДобавитьВТаблицуМФ(ТаблицаМФ,"Справочник","ЗначенияСвойств", "Номенклатура",  "По свойствам номенклатуры");
    ТекСтрокаВТаблице="";
    ЗнП   = 2;
    ЗнНеП = 1;  
    
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А вы там своего ничего не дописывали/не убирали? Судя по коду ТаблицаТоваров1 - реквизит формы. Но почему-то не вижу где определяются колонки этой таблицы. Отсюда и ошибка
  5. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    Код:
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    сообщить (ТипЗначенияСтр(Форма.Параметр));
    
    Конт = Форма.Параметр.Получить("Контекст");  //Конт = Форма.Параметр;
    
    Сообщить(Конт);
    Сообщить(ТипЗначенияСтр(Конт));
    что сообщит ??

    Процедура ФормТаблТоваров()
    ТаблицаТоваров1.Загрузить(ТаблицаТоваров);

    лучше-бы топик-стартер сам файл обработки выложил
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    угу... Если бы еще эта процедура вызывалась при открытии
  7. TopicStarter Overlay
    decker
    Offline

    decker

    Регистрация:
    30 окт 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Ничего не дописывал, кроме того, что указано в 3 посту.
    Отладчик не работает, к сожалению.
    Обработка Посмотреть вложение 16647

    Вложения:

  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Мой пост №6... У вас в таблице не определены колонки

    Код:
    ....
    ФорматБумаги.ТекущаяСтрока(12);
    ОбрФорматБумаги(); 
    ВыделитьВсе(ЗнНеП);
    ТипЦен = Константа.РозничныйТипЦен;
    
    ТаблицаТоваров1.НоваяКолонка("Номенклатура","Справочник.Номенклатура");
    ТаблицаТоваров1.НоваяКолонка("Количество","Число",2,0);
    ТаблицаТоваров1.НоваяКолонка("ШтрихКод","Строка",13);
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    Конт = Форма.Параметр.Получить("Контекст");  //Конт = Форма.Параметр;
    
    Конт.ВыбратьСтроки();
    Пока Конт.ПолучитьСтроку() = 1 Цикл
    ТаблицаТоваров1.НоваяСтрока();
    ТаблицаТоваров1.Номенклатура = Конт.Номенклатура;
    ТаблицаТоваров1.Количество   = Конт.Количество;
    КонецЦикла;
    КонецЕсли;
    ...
    
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А говорите что ничего не изменяли.....
  10. TopicStarter Overlay
    decker
    Offline

    decker

    Регистрация:
    30 окт 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Эта проблема решилась, но обработка выводит на печать только первый лист :(
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А потом что? Ошибка есть? Сколько позиций в таблице отмечено? Какой формат печати?

Поделиться этой страницей