[РЕШЕНО] Внешняя обработка для Заказа Покупателя, нужна помощь

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем zhonya, 21 мар 2014.

  1. TopicStarter Overlay
    zhonya
    Offline

    zhonya

    Регистрация:
    21 мар 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток.
    У меня стоит задача - чтобы в Заказе Покупателя в печатной форме выводилось поле Дополнительное Описание Номенклатуры.
    8.2 Комплексная автоматизация.
    Сделал внешнюю печатную форму, добавил Основное изображение, а вот как вытащить Дополнительное Описание Номенклатуры для указанной в Заказе Номенклатуры не могу домыслить. Прошу подсказать, как это сделать.
    Ниже часть модуля объекта:
    Код:
    СекцияОбластьНомера = ОбластьНомера;
    СекцияОбластьКодов = ОбластьКодов;
    СекцияНоменклатура = ОбластьТовар;
    СекцияОбластьДанных = ОбластьДанных;
    СекцияОбластьСкидок = ОбластьСкидок;
    СекцияОбластьСуммы = ОбластьСуммы;
    СекцияКартинка = ОбластьКартинка_БезКартинки;
    Картинка = Неопределено;
    СекцияОписание = ОбластьОписание_БезОписания;
    Описание = Неопределено;
    Если ЗначениеЗаполнено(ПараметрыПозиции.Номенклатура.ОсновноеИзображение) Тогда
    Картинка = ПараметрыПозиции.Номенклатура.ОсновноеИзображение.Хранилище.Получить();
    КонецЕсли;
    Если ЗначениеЗаполнено(ПараметрыПозиции.Номенклатура.ДополнительноеОписаниеНоменклатуры) Тогда
    Описание = ПараметрыПозиции.Номенклатура.ДополнительноеОписаниеНоменклатуры;
    КонецЕсли;
    
    Если ЗначениеЗаполнено(Картинка) Тогда
    СекцияОбластьНомера = ОбластьНомера_Картинка;
    СекцияОбластьКодов = ОбластьКодов_Картинка;
    СекцияНоменклатура = ОбластьТовар_Картинка;
    СекцияКартинка = ОбластьКартинка;
    СекцияОбластьДанных = ОбластьДанных_Картинка;
    СекцияОбластьСкидок = ОбластьСкидок_Картинка;
    СекцияОбластьСуммы = ОбластьСуммы_Картинка;
    СекцияКартинка.Рисунки["Изображение"].Картинка = Картинка;
    КонецЕсли;
    
    Если ЗначениеЗаполнено(Описание) Тогда
    СекцияОбластьНомера = ОбластьНомера_Описание;
    СекцияОбластьКодов = ОбластьКодов_Описание;
    СекцияНоменклатура = ОбластьТовар_Описание;
    СекцияОписание = ОбластьОписание;
    СекцияОбластьДанных = ОбластьДанных_Описание;
    СекцияОбластьСкидок = ОбластьСкидок_Описание;
    СекцияОбластьСуммы = ОбластьСуммы_Описание;
    //СекцияОписание = ОбластьОписание_Описание;
    КонецЕсли;
    
    Если оставлять все так, то при вызове печати из Заказа Покупателя выводится изображение номенклатуры и пустая колонка Описание.
    Заранее спасибо за ответы
  2. TopicStarter Overlay
    zhonya
    Offline

    zhonya

    Регистрация:
    21 мар 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Помогли на другом форуме: http://forum-1c.ru/index.php?topic=37125.0
    Вот решение:
    Сделал вот так:
    Если ЗначениеЗаполнено(Описание) Тогда
    СекцияОбластьНомера = ОбластьНомера_Описание;
    СекцияОбластьКодов = ОбластьКодов_Описание;
    СекцияНоменклатура = ОбластьТовар_Описание;
    СекцияОписание = ОбластьОписание;
    СекцияОбластьДанных = ОбластьДанных_Описание;
    СекцияОбластьСкидок = ОбластьСкидок_Описание;
    СекцияОбластьСуммы = ОбластьСуммы_Описание;
    ОбластьОписание.Параметры.Описание = Описание;

Поделиться этой страницей