7.7 Внешний отчет

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Яна93, 24 апр 2012.

  1. TopicStarter Overlay
    Яна93
    Offline

    Яна93

    Регистрация:
    24 апр 2012
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Помогите пожалуйста...в общем отчет формируется пустым без данных..вроде все выбираю правильно..и период и ФК..все равно не выводит данных в отчете...Платформа 7.7 конфигурация Торговля и склад..


    Код:
    Процедура Сформировать()
    ТабЗ=СоздатьОбъект("ТаблицаЗначений");
    ТабЗ.НоваяКолонка("ФК");
    ТабЗ.НоваяКолонка("Время");
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Док=СоздатьОбъект("Документ.ПКО");
    Док.ВыбратьДокументы(ДатаНач,ДатаКон);
    Таб.ВывестиСекцию("Шапка");
    Если ПустоеЗначение(ФК)=0 Тогда
    Пока Док.ПолучитьДокумент()=1 Цикл
    ТабЗ.НоваяСтрока();
    ТабЗ.ФК=Док.Фин;
    ТабЗ.Время=Док.ТекВремя;
    КонецЦикла;
    ТабЗ.Сортировать("ФК,Время",1);
    ТабЗ.ВыбратьСтроки();
    Пока ТабЗ.ПолучитьСтроку()=1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    Таб.Показать();
    КонецЕсли;
    КонецПроцедуры
    Процедура ПриОткрытии()
    ДатаКон=Дата(ТекущаяДата()+1);
    ДатаНач=ДатаКон;
    КонецПроцедуры
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а если передать данные в Секцию Строка? Вы же просто секцию вывели, надо заполнить ее данными перед выводом (наверняка там есть параметры)
  3. TopicStarter Overlay
    Яна93
    Offline

    Яна93

    Регистрация:
    24 апр 2012
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Да я бухгалтер по образованию..самоучка вот такая.;) а как это сделать? какую процедуру ввести? я просто по шаблонам ее писала..)
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    выложите скрин макета отчета пожалуйста
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Лучше сам отчет.....

Поделиться этой страницей