8.х Внешние печатные формы в управляемом приложении 1С 8.3

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Tihonidy, 27 фев 2014.

  1. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Спасибо буду изучать. Не можете посоветовать с какой начать?
  2. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    И на той я уже начал экспериментировать. Вот она ещё до экспериментов, на стадии работы http://rghost.ru/7vs9FYJmt
  3. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Я в настройка нашел что можно настроить печать Акта на передачу прав из Реализации товаров и услуг через настройку печать объектов. Ставлю галочку напротив Акта на передачу прав, но печатная форма не появляется. Макет в конфигурации уже был.
    [​IMG]
    Всё понял это настройка печати комплектов докаментов.
    Последнее редактирование: 27 ноя 2015
  4. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    В моих ВПФ нехватает Функция Печать () Экспорт.
    Последнее редактирование: 3 дек 2015
  5. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Где находится Функция Печать ()Экспорт для Торг12? В реализацииТоваровИУслуг найти немогу. Откуда 1с её формирует?

    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
     
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
     
    Наименование = УказатьНаименованиеВнешнейПечатнойФормы();
     
    МассивНазначений.Добавить(ПолучитьМетаданныеДокументаПечати());
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ВПФ Акт на передачу прав");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", "Акт на передачу прав");
     
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, Наименование, УказатьНаименованиеКомандыПечати(), "ВызовСерверногоМетода", Истина, "ПечатьMXL");
     
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
     
    Возврат ПараметрыРегистрации;
     
    КонецФункции
    Функция ПолучитьТаблицуКоманд()
     
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
     
    Возврат Команды;
    КонецФункции
    Функция УказатьНаименованиеВнешнейПечатнойФормы()
    Наименование = ЭтотОбъект.Метаданные().Представление();
    Возврат Наименование;
    КонецФункции
    Функция УказатьНаименованиеКомандыПечати()
    Наименование = ЭтотОбъект.Метаданные().ПолноеИмя();
    Возврат Наименование;
    КонецФункции
    Функция ПолучитьМетаданныеДокументаПечати()
    ПолноеИмя = Документ.Метаданные().ПолноеИмя();
    Возврат ПолноеИмя;
    КонецФункции
    Функция ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
     
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда. Представление = Представление;
    НоваяКоманда. Идентификатор= Идентификатор;
    НоваяКоманда. Использование= Использование;
    НоваяКоманда. ПоказыватьОповещение= ПоказыватьОповещение;
    НоваяКоманда. Модификатор= Модификатор;
     
    КонецФункции
     
    Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
     
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
    КоллекцияПечатныхФорм,
    УказатьНаименованиеКомандыПечати(),
    УказатьНаименованиеВнешнейПечатнойФормы(),
    ПечатьФормы(МассивОбъектов));
     
    КонецПроцедуры
     
    Функция ПечатьФормы(МассивОбъектов) Экспорт
    ТабДок = новый ТабличныйДокумент;
     
    Макет = ПолучитьМакет("Макет");
     
    ОбластьШапки  = Макет.ПолучитьОбласть("Шапка");
    ОбластьСтрока  = Макет.ПолучитьОбласть("Строка");
    ОбластьИтогоПоСтранице  = Макет.ПолучитьОбласть("ИтогоПоСтранице");
    ОбластьВсего  = Макет.ПолучитьОбласть("Всего");
    ОбластьПодвал  = Макет.ПолучитьОбласть("Подвал");
     
    возврат ТабДок;
    КонецФункции
    Последнее редактирование: 3 дек 2015
  6. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Краткое изложение в обработке (см. вложение)

    Вложения:

  7. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Сделал ВПФ на 11.2 заработала. Теперь надо под 11.1 переделать, а то не хочет запускаться..
    Под 11.1 пишет:
    {ВнешняяОбработка.АктНаПередачуПрав.МодульОбъекта(91)}: Метод объекта не обнаружен (ПолучитьДанныеДляПечатнойФормыАктНаПередачуПрав)
    ДанныеДляПечати = МенеджерОбъекта.ПолучитьДанныеДляПечатнойФормыАктНаПередачуПрав(ПараметрыПечати, СтруктураОбъектов.Значение);
  8. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    В 11.1 не было документа Акт на передачу прав в конфигурации и я сделал в 11.2. В УТ 11.2 форма работает. Теперь при запуске в 11.1 он ссылается на ссылки которые были 11.2, но нет в 11.1. Скопировал функцию из 11.2 в ВПФ ПолучитьДанныеДляПечатнойФормыАктНаПередачуПрав но он всеравно ругается. Надо наверно ссылку поправлять где он её ищет?
    Тут наверно в средней строке надо менять?
    МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(СтруктураОбъектов.Ключ);
    ДанныеДляПечати = МенеджерОбъекта.ПолучитьДанныеДляПечатнойФормыАктНаПередачуПрав(ПараметрыПечати, СтруктураОбъектов.Значение);
    ЗаполнитьТабличныйДокументАктНаПередачуПрав(ТабличныйДокумент, ДанныеДляПечати, ОбъектыПечати);
    --- Объединение сообщений, 4 дек 2015 ---
    Поменял на так :
    ДанныеДляПечати = ПолучитьДанныеДляПечатнойФормыАктНаПередачуПрав(ПараметрыПечати, СтруктураОбъектов.Значение);
    Теперь:
    {ОбщийМодуль.УправлениеПечатью.Модуль(517)}: Ошибка при вызове метода контекста (ПолучитьМакет)
    Результат = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(ПутьКМетаданным).ПолучитьМакет(ПутьКОбъектуМетаданных);
    по причине:
    Недопустимое значение параметра (параметр номер '1')
    Недопустимое значение параметра (параметр номер '1')
    Последнее редактирование: 4 дек 2015
  9. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Сегодня ещё получилось создать ВПФ Коммерческого предложения. Подскажите как сделать что при формирование печатной формы подхватывалось изображение (Факсимиле) внизу страницы?
  10. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    В Синтаксис помощнике см. "ТабличныйДокумент.Рисунки"
    Ex. "ТабличныйДокумент.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка)"
  11. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Поле объекта не обнаружена Подпись
  12. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    http://rghost.ru/7XLtn9yzh
    Сделал ВПФ Коммерческого предложения. Логотип который есть в нем выходит в печатной форме, а вот с факсимиле проблема. Пробовал по примеру кода логотипа сделать неполучилось.
  13. sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей