8.х УТ Внешние печатные формы после обновления на 11.1.4.11

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем elite128, 11 мар 2014.

  1. TopicStarter Overlay
    elite128
    Offline

    elite128 Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    108
    Симпатии:
    0
    Баллы:
    26
    После обновления до УТ 11.1.4.11 перестали работать внешние печатные формы, вываливаются с ошибкой:

    2014-03-11 10-24-09 Скриншот экрана.png

    Снова 1С переписала процедуры печати?
  2. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    может что-то намудрила, попробуйте до 11.1.4.13
  3. TopicStarter Overlay
    elite128
    Offline

    elite128 Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    108
    Симпатии:
    0
    Баллы:
    26
    не могу, увы
    у меня УТ+CRM
    судя по всему поменяли логику вывода печатных форм внешних
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.745
    Симпатии:
    509
    Баллы:
    204
    Это они запросто могли делать, только обычно в файле обновления пишут, что поменяли :)
    Либо что на что нужно поменять.
  5. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    они там по 1/3 не пишут, 100% это только в БУХ полная раскладка чего было изменено
    и в последнее время только изредка есть для УТ, а ранее вообще не было
  6. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    там просто могли с кодом намудрить, 11.1.4.12 даже отозван был сразу и ещё один ранее, после моего письма им из-за головотяпства ихнего, что-то там в общем модуле не так написали и всё с ошибкой валилось.
  7. TopicStarter Overlay
    elite128
    Offline

    elite128 Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    108
    Симпатии:
    0
    Баллы:
    26
    надеюсь 11.1.4.11 не оч глючный, тут еще у нас привязка к рарусу теперь, с внедрением CRM
    на 11.1.4.11 только в пятницу конфиг выпустили
  8. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    они уже 11.1.5 планируют в конце марта, 11.1.5.4 уже пробный есть и там есть отличия от 11.1.4
  9. TopicStarter Overlay
    elite128
    Offline

    elite128 Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    108
    Симпатии:
    0
    Баллы:
    26
    я про совместный конфиг рарус CRM+УТ, они его с задержкой приличной делают
  10. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    просто 11.1.4 уже на 8.3 перевели вот по этому и задержка была большая вероятно
  11. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    в 11.1.2.28 было так
    Код:
    // Формирует печатную форму по внешнему источнику
    //
    // Параметры:
    //   Ссылка (СправочникСсылка.ДополнительныеОтчетыИОбработки) Внешняя обработка
    //   ПараметрыИсточника (Структура)
    //       |- ИдентификаторКоманды (Строка) Список макетов, перечисленных через запятую
    //       |- ОбъектыНазначения    (Массив)
    //   КоллекцияПечатныхФорм (ТаблицаЗначений) см. УправлениеПечатьюПереопределяемый.ПечатьПоВнешнемуИсточнику()
    //   ОбъектыПечати         (СписокЗначений)  см. УправлениеПечатьюПереопределяемый.ПечатьПоВнешнемуИсточнику()
    //   ПараметрыВывода       (Структура)       см. УправлениеПечатьюПереопределяемый.ПечатьПоВнешнемуИсточнику()
    //
    Процедура ПечатьПоВнешнемуИсточнику(Ссылка, ПараметрыИсточника, КоллекцияПечатныхФорм,
        ОбъектыПечати, ПараметрыВывода) Экспорт
       
        Если Не ПолучитьФункциональнуюОпцию("ИспользоватьДополнительныеОтчетыИОбработки") Тогда
            Возврат;
        КонецЕсли;
       
        КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(ПараметрыИсточника.ИдентификаторКоманды);
       
        ПараметрыВывода = УправлениеПечатью.ПодготовитьСтруктуруПараметровВывода();
       
        ОбъектыПечати = Новый СписокЗначений;
       
        ВнешняяОбработкаОбъект = ПолучитьОбъектВнешнейОбработки(Ссылка);
       
        Если ВнешняяОбработкаОбъект = Неопределено Тогда
            ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru = 'Внешняя обработка ""%1"" (тип ""%2"") не обслуживается подсистемой ""Дополнительные отчеты и обработки""'"),
                Строка(Ссылка),
                Строка(ТипЗнч(Ссылка))
            );
        КонецЕсли;
       
        ВнешняяОбработкаОбъект.Печать(
            ПараметрыИсточника.ОбъектыНазначения,
            КоллекцияПечатныхФорм,
            ОбъектыПечати,
            ПараметрыВывода
        );
       
        // Проверим, все ли макеты были сформированы
        Для Каждого Стр Из КоллекцияПечатныхФорм Цикл
            Если Стр.ТабличныйДокумент = Неопределено Тогда
                ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                    НСтр("ru = 'В обработчике печати не был сформирован табличный документ для: %1'"),
                    Стр.ИмяМакета
                );
                ВызватьИсключение(ТекстСообщенияОбОшибке);
            КонецЕсли;
           
            Стр.ТабличныйДокумент.КоличествоЭкземпляров = Стр.Экземпляров;
        КонецЦикла;
    
    КонецПроцедуры
    
  12. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    а в 11.1.5.4 сейчас так
    Код:
    // Формирует печатную форму по внешнему источнику
    //
    // Параметры:
    //   Ссылка (СправочникСсылка.ДополнительныеОтчетыИОбработки) Внешняя обработка
    //   ПараметрыИсточника - Структура -
    //       * ИдентификаторКоманды - Строка - Список макетов, перечисленных через запятую
    //       * ОбъектыНазначения    (Массив)
    //   КоллекцияПечатныхФорм - ТаблицаЗначений - см. описание процедуры Печать() в документации.
    //   ОбъектыПечати         (СписокЗначений)  см. описание процедуры Печать() в документации.
    //   ПараметрыВывода       - Структура -       см. описание процедуры Печать() в документации.
    //
    Процедура ПечатьПоВнешнемуИсточнику(Ссылка, ПараметрыИсточника, КоллекцияПечатныхФорм,
        ОбъектыПечати, ПараметрыВывода) Экспорт
       
        Если Не ПолучитьФункциональнуюОпцию("ИспользоватьДополнительныеОтчетыИОбработки") Тогда
            Возврат;
        КонецЕсли;
       
        КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(ПараметрыИсточника.ИдентификаторКоманды);
       
        ПараметрыВывода = УправлениеПечатью.ПодготовитьСтруктуруПараметровВывода();
       
        ОбъектыПечати = Новый СписокЗначений;
       
        ВнешняяОбработкаОбъект = ПолучитьОбъектВнешнейОбработки(Ссылка);
       
        Если ВнешняяОбработкаОбъект = Неопределено Тогда
            ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru = 'Внешняя обработка ""%1"" (тип ""%2"") не обслуживается подсистемой ""Дополнительные отчеты и обработки""'"),
                Строка(Ссылка),
                Строка(ТипЗнч(Ссылка)));
        КонецЕсли;
       
        ВнешняяОбработкаОбъект.Печать(
            ПараметрыИсточника.ОбъектыНазначения,
            КоллекцияПечатныхФорм,
            ОбъектыПечати,
            ПараметрыВывода);
       
        // Проверим, все ли макеты были сформированы
        Для Каждого Стр Из КоллекцияПечатныхФорм Цикл
            Если Стр.ТабличныйДокумент = Неопределено Тогда
                ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                    НСтр("ru = 'В обработчике печати не был сформирован табличный документ для: %1'"),
                    Стр.ИмяМакета);
                ВызватьИсключение(ТекстСообщенияОбОшибке);
            КонецЕсли;
           
            Стр.ТабличныйДокумент.КоличествоЭкземпляров = Стр.Экземпляров;
        КонецЦикла;
    
    КонецПроцедуры
    
  13. TopicStarter Overlay
    elite128
    Offline

    elite128 Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    108
    Симпатии:
    0
    Баллы:
    26
    Пришлось вставлять кусок кода в типовую, поправил

Поделиться этой страницей