8.х Внедрение внешней обработки в основной модуль документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Panchos, 19 мар 2007.

  1. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    У меня есть внешняя обработка. В модуле внешней обработки есть процедура

    Код:
    Процедура Расписка(Рейс, Задание)
    ....
    ....
    ....
    КонецПроцедуры
    
    В модуле документа пишу 1с пишу
    
    Процедура ПечатьОбработки()кнопка
    
    Рейс = .....
    
    Задание = .....
    
    Расписка(Рейс, Задание)
    
    КонецПроцедуры
    
    Пишет ошибку, что Процедура или Функция с таким именем не определена.
  2. Vladoff
    Offline

    Vladoff

    Регистрация:
    16 мар 2007
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Откровенно говоря, не совсем понятна ситуация. Если вы стараетесь вызвать эту процедуру из модуля документа, а сама она в обработке, то обязательно перед определением процедуры напишите «Экспорт»
  3. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Написал, все выдает ошибку, что имя процедуры или функции не определено расписка(Рейс, задание)
  4. Vladoff
    Offline

    Vladoff

    Регистрация:
    16 мар 2007
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Обработка = Обработки.<ИмяОбработки>.Создать();
    Обработка.<ИмяПроцедуры>(<параметры>);
  5. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Поместите процедуру в глобальный модуль и, как уже посоветовал Владислав, поставьте оператор Экспорт
    Код:
    Процедура Расписка(Рейс, Задание) Экспорт
    ....
    ....
    ....
    КонецПроцедуры
    

Поделиться этой страницей