7.7 "Висит" на старте или нет?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем X-Man, 12 ноя 2007.

  1. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    432
    Симпатии:
    3
    Баллы:
    29
    Здравствуйте, уважаемые профессионалы. Очень нужна ваша помощь. Проблема, точнее, вопрос, следующий: можно ли средствами встроенного языка проверить, "висит" ли кто на старте или нет? Под выражением "висит на старте" следует понимать следующую ситуацию: пользователь еще не подключился к информационной базе, однако окно "Авторизация доступа" открыто. Пожалуйста, очень вас прошу, подскажите. Заранее благодарен.
  2. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    432
    Симпатии:
    3
    Баллы:
    29
    Блин, ну что такое. Все заходят и ничего не говорят:(
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Признак того что кто - то весит файлик 1cv7flt.lst, но кто весит по нему не поймешь, да и из 1с никак, потому что пока хоть ктото в 1с -есть сей файлик существует, боролся драконовскими методами с юзерами, вплоть до полного отключения от базы и с дальнейшим подключением после промывания мозгов.

    Через администрирование винды видно кто именно держит сесию к симу файлу, там можно отстрелить пользователя но как из 1с :unsure: так и не нашел
  4. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    432
    Симпатии:
    3
    Баллы:
    29
    Спасибо, конечно, МаххаМ, но, судя по всему, ты меня не понял. Мне по барабану на тех, кто уже В базе, нужно лишь установить факт "зависания" именно на старте, а не в системе, так что твой метод не годиться.


    Из положения вышел сам следующим образом: написал функцию, которая проверяет, висит кто на старте или нет:
    Код:
    //*****************************************************
    Функция НектоВиситНаСтарте()
    ФС.КопироватьФайл(КаталогИБ() + "USRDEFusers.usr",КаталогИБ() + "USRDEFusers.tmp",0);  
    ФС.УдалитьФайл(КаталогИБ() + "USRDEFusers.usr");
    Если ФС.СуществуетФайл(КаталогИБ() + "USRDEFusers.usr") = 0 Тогда 
    //никто не висит на старте
    ФС.КопироватьФайл(КаталогИБ() + "USRDEFusers.tmp",КаталогИБ() + "USRDEFusers.usr",0);//Восстановили файл пользователей
    ФС.УдалитьФайл(КаталогИБ() + "USRDEFusers.tmp");//Удалили временный файл
    Возврат 0;
    Иначе
    ФС.УдалитьФайл(КаталогИБ() + "USRDEFusers.tmp");//Удалили временный файл
    Возврат 1;
    КонецЕсли;
    КонецФункции
    
    
    А далее проверяется в цикле

    Пока НектоВиситНаСтарте() = 1 Цикл
    Состояние("Ожидание возможности доступа к файлу пользователей, подождите...");
    КонецЦикла;


    Чем чревато, кто что думает?

Поделиться этой страницей