7.7 Видсубконто.......

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 1 апр 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Народ вопрос как сделать чтобы при выборе из списка менялся реквизит "Субконто".Например если выбран из списка "Оплата Заказа Поставщика" Реквизит "Субконто"менялся на справочник "Контрагенты",а если из списка выбирался "Выбор денег под отчет"-то реквизит "Субконто" менялся на справочник Сотрудники.
    Код:
    //***********************************************************
    Функция ВалНаименование()
    Если РСчет.Выбран() = 1 Тогда
    Возврат СокрЛП(РСчет.Валюта.Кратко);
    Иначе
    Возврат СокрЛП("");
    КонецЕсли;
    КонецФункции
    //***********************************************************
    Процедура ИзмСуммаВал()
    Ст = ВидНДС.Ставка.Получить(ДатаДок);
    НДС = СуммаБезНдс * Ст / (1 + Ст);
    КонецПроцедуры
    //***********************************************************
    Процедура ИзмВидОперации()
    Значение = сВидыОпераций.ПолучитьЗначение(сВидыОпераций.ТекущаяСтрока());
    Позиция = Найти(Значение,",");
    Счет = СчетПоКоду(Сред(Значение,1,?(Позиция <> 0,Позиция-1,СтрДлина(Значение))));
    КонецПроцедуры
    //**********************************************************
    Процедура УстВидОперации()
    Для Инд = 1 по сВидыОпераций.РазмерСписка() Цикл
    Если Найти(сВидыОпераций.ПолучитьЗначение(Инд),Строка(Счет)) <> 0 Тогда
    сВидыОпераций.ТекущаяСтрока(Инд);
    Возврат;
    КонецЕсли;
    КонецЦикла;
    сВидыОпераций.ТекущаяСтрока(2);
    КонецПроцедуры
    Процедура ВводНового(ПризнакКопирования)
    УстВидОперации();
    КонецПроцедуры
    //***********************************************************
    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);
    сВидыОпераций.ДобавитьЗначение("631,632","Оплата заказа поставщика");
    сВидыОпераций.ДобавитьЗначение("","Прочие операции");
    сВидыОпераций.ДобавитьЗначение("3721,3722","Выдача денег под отчет");
    сВидыОпераций.ДобавитьЗначение("311,312,313,314","Сдача денег в банк");
    УстВидОперации();
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вот пример из ОСВ по счету типовой конфы.

    Код:
    
    НазначитьСчет(ВыбВидСубконто1, Счет, 1);
    Форма.Субконто1.НазначитьТип(ВыбВидСубконто1);
    
    ВыбВидСубконто1 - реквизит формы. Тип - неопределен
    Счет - реквизит формы типа счет
    установит тип первого субконто.
  3. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ИзмСуммаВал()
    Ст = ВидНДС.Ставка.Получить(ДатаДок);
    НДС = СуммаБезНдс * Ст / (1 + Ст);
    КонецПроцедуры
    //***********************************************************
    Функция ВалНаименование()
    Если РСчет.Выбран() = 1 Тогда
    Возврат СокрЛП(РСчет.Валюта.Кратко);
    Иначе
    Возврат СокрЛП("");
    КонецЕсли;
    КонецФункции
    //***********************************************************
    Процедура ИзмВидОперации()
    Значение = сВидыОпераций.ПолучитьЗначение(сВидыОпераций.ТекущаяСтрока());
    Позиция = Найти(Значение,",");
    Счет = СчетПоКоду(Сред(Значение,1,?(Позиция <> 0,Позиция-1,СтрДлина(Значение))));
    КонецПроцедуры
    //**********************************************************
    Процедура УстВидОперации()
    Для Инд = 1 по сВидыОпераций.РазмерСписка() Цикл
    Если Найти(сВидыОпераций.ПолучитьЗначение(Инд),Строка(Счет)) <> 0 Тогда
    сВидыОпераций.ТекущаяСтрока(Инд);
    Возврат;
    КонецЕсли;
    КонецЦикла;
    сВидыОпераций.ТекущаяСтрока(2);
    КонецПроцедуры
    Процедура ВводНового(ПризнакКопирования)
    УстВидОперации();
    КонецПроцедуры
    //***********************************************************
    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);
    сВидыОпераций.ДобавитьЗначение("631,632","Оплата заказа поставщика");
    сВидыОпераций.ДобавитьЗначение("","Прочие операции");				 //Это список из него выбор на реквизит формы документа "субконто")
    сВидыОпераций.ДобавитьЗначение("3721,3722","Выдача денег под отчет");
    сВидыОпераций.ДобавитьЗначение("311,312,313,314","Сдача денег в банк");
    УстВидОперации();
    НазначитьСчет(Субконто, Счет, 1);//Субконто реквезит формы документа
    Форма.Субконто.НазначитьТип(Субконто);
    КонецПроцедуры
    //***********************************************************
    не получается блин(((
  4. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    не выбирает((
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    масло масляное....
    Код:
    НазначитьСчет(Субконто, Счет, 1);//Субконто реквезит формы документа
    Форма.Субконто.НазначитьТип(Субконто);
    КонецПроцедуры
    
  6. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    и я так думаю все равно не доходит до меня ..Назначить счет(ВыбвидСубконто(это реквизит формы),Cчет(это значение типа счет на форме),1-это числовой номер субконто в плане счетов )я так понял это когда из списка выбирается "Оплата заказа поставщика" у меня меняется реквизит формы счет и по этому счету идет выбор по субконту в плане счетов и в мой реквизит на форме подставляется выбранный справочник
  7. Vlan
    Online

    Vlan Гость Гость

    У вас опять каша какая-то получается. В списке выбирается текстовое значение, а не счет. Ну и пляшите от этого: ищите СчетПоКоду и значение его субконто присваивайте реквизиту. Как-то так.
  8. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    получилось спасибо большое

Поделиться этой страницей