[РЕШЕНО] Видимость таблицы на управляемой форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Garnet27, 3 авг 2015.

  1. TopicStarter Overlay
    Garnet27
    Offline

    Garnet27 Опытный в 1С

    Регистрация:
    1 июл 2015
    Сообщения:
    65
    Симпатии:
    0
    Баллы:
    26
    Добрый день! Имеется Таблица Значений на управляемой форме. По умолчанию при ее создании снимаю в свойствах значок видимость (не видна для пользователя). Далее необходимо, чтобы при выборе флажка на форме, таблица значений стала видимой. Что-то не получается сделать. Подскажите, как правильно?
    В какой процедуре это надо прописать? Можно ли это делать так, как я делаю:
    Если Флажок = Истина Тогда ТЗ.Видимость = Истина КонецЕсли;
    Заранее большое спасибо.
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    ТЗ - это реквизит формы, а видимость можно у поля формы менять.
    Поле на форме не обязательно именем ТЗ называется.

    В общем случае должно быть так:
    Код:
    &НаКлиенте
    Процедура УстановитьВидимостьДоступность()
         Элементы.<ПолеТабличнаяЧасть>.Видимость = Флажок(как рекивзит формы, либо Объект.Флажок, как реквизит объекта) ;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ФлажокПриИзменении(Элемент)
        УстановитьВидимостьДоступность()
    КонецПроцедуры
    
  3. TopicStarter Overlay
    Garnet27
    Offline

    Garnet27 Опытный в 1С

    Регистрация:
    1 июл 2015
    Сообщения:
    65
    Симпатии:
    0
    Баллы:
    26
    Огромное спасибо! Все получилось!

Поделиться этой страницей