8.х УНФ версионирование справочников и документов

Тема в разделе ""1С:Управление небольшой фирмой УНФ"", создана пользователем 1c-ka, 20 май 2015.

  1. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    Привет!
    Включил версионирование, выдал уже готовый список справочников и документов для отслеживания. Там можно настроить каждый объект отдельно.
    Вопрос в следующем, а как можно редактировать данный список, я почему-то не нашел как это сделать, т.к. из нужных мне документов и справочников в этом списке есть только один.
    УНФ 1.4.9
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Ну УНФ подрукой нет, скажу как в УПП это было и есть
    Этот справочник он по сути дело программно строится по объектам методанных
    --- Объединение сообщений, 20 май 2015 ---
    Там есть вот такая процедурка
    Код:
    Процедура ЗаполнитьТипыОбъектовВДеревеЗначений()
       
        ДеревоОбъектовМетаданных.Строки.Очистить();
       
        Если Метаданные.Справочники.Количество() >0 Тогда
            НовыйЭлементСпр = ДеревоОбъектовМетаданных.Строки.Добавить();
            НовыйЭлементСпр.СинонимНаименованияОбъекта = "Справочники";
            НовыйЭлементСпр.КлассОбъекта = "СправочникиКорень";
        КонецЕсли;
       
        Если Метаданные.Документы.Количество() >0 Тогда
            НовыйЭлементДок = ДеревоОбъектовМетаданных.Строки.Добавить();
            НовыйЭлементДок.СинонимНаименованияОбъекта = "Документы";
            НовыйЭлементДок.КлассОбъекта = "ДокументыКорень";
        КонецЕсли;
       
        Для Каждого Справочник Из Метаданные.Справочники Цикл
            НоваяСтрокаТаблицы = НовыйЭлементСпр.Строки.Добавить();
            НоваяСтрокаТаблицы.ТипОбъекта = Справочник.Имя;
            НоваяСтрокаТаблицы.СинонимНаименованияОбъекта = Справочник.Синоним;
            НоваяСтрокаТаблицы.КлассОбъекта = "Справочники";
            НоваяСтрокаТаблицы.Проводится = Ложь;
           
            Настройка = ВерсионированиеОбъектов.ЗагрузитьНастройкуВерсионированияПоОбъекту(
                                    НоваяСтрокаТаблицы.ТипОбъекта);
           
            НоваяСтрокаТаблицы.ВариантВерсионирования = Настройка;
        КонецЦикла;
       
        Для Каждого Документ Из Метаданные.Документы Цикл
            НоваяСтрокаТаблицы = НовыйЭлементДок.Строки.Добавить();
            НоваяСтрокаТаблицы.ТипОбъекта = Документ.Имя;
            НоваяСтрокаТаблицы.СинонимНаименованияОбъекта = Документ.Синоним;
            НоваяСтрокаТаблицы.КлассОбъекта = "Документы";
            НоваяСтрокаТаблицы.Проводится = ВерсионированиеОбъектов.ДокументПроводится(Документ.Имя);
           
            Настройка = ВерсионированиеОбъектов.ЗагрузитьНастройкуВерсионированияПоОбъекту(
                                    НоваяСтрокаТаблицы.ТипОбъекта);
           
            НоваяСтрокаТаблицы.ВариантВерсионирования = Настройка;
        КонецЦикла;
       
    КонецПроцедуры
  3. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    а почему тогда он не все объекты выводит?
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Ну опять же я не знаю что там в УФН за код. Может это у вас добавленные объекты, а там он выводит же синоним их Справочник.Синоним а у вас либо нет синонима либо он как то отличается от того что ищите
  5. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    это надо лезть в конфигуратор?
  6. meskalin
    Offline

    meskalin Профессионал в 1С Команда форума

    Регистрация:
    15 мар 2012
    Сообщения:
    937
    Симпатии:
    109
    Баллы:
    104
    Вроде все просто и в предприятии

    Снимок.PNG
  7. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    а при чем здесь этот скрин?
  8. meskalin
    Offline

    meskalin Профессионал в 1С Команда форума

    Регистрация:
    15 мар 2012
    Сообщения:
    937
    Симпатии:
    109
    Баллы:
    104
    Это скрин со списком версинифицируемых объектов 1.5.
    Смутило "есть только один нужны мне". Уточняю, чего не хватает в стандартном списке?
  9. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Я так понял автор говорит о том что у вас на скрине Справочники - всего 4 шт а ему например еще хотелось бы версионировать справочник Контрагенты. Вот он и спрашивает как его добавить туда
  10. meskalin
    Offline

    meskalin Профессионал в 1С Команда форума

    Регистрация:
    15 мар 2012
    Сообщения:
    937
    Симпатии:
    109
    Баллы:
    104
    Мне кажется, чтобы редактировать данный список и понимать последствия все таки важно знать какой именно объект?
  11. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Ну я про то что просто так вы этот список не дополните только через код тогда.
    Просто еще смотрите в чем фишка. Версионирование, ну на примере УПП - это по сути дела процедура которая пишет данные в РС, в УПП данная процедура вынесена в подписку на событие
    т.е вам что бы версионирование работало надо будет не только изменить что бы этот список заполнялся, а еще либо добавить этот объект в подписку на собыие и там код посмотреть еще надо
  12. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    вы меня правильно поняли
  13. meskalin
    Offline

    meskalin Профессионал в 1С Команда форума

    Регистрация:
    15 мар 2012
    Сообщения:
    937
    Симпатии:
    109
    Баллы:
    104
    Я тоже правильно понял, только уточнил что именно нужно добавить к тому, что уже есть )
  14. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    Вот смотрите в справочниках из нужных есть только: номеклатура, а еще не помешали бы контрагенты.
    Из документов из нужных только расходные накладные, а еще нужны производство и перемещение запасов.
    И еще прайс-лит тоже не мешало бы отслеживать. Безымянный.png
  15. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    ну я написал направление движения
  16. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    полезу конфигуратор, поищу где это.
    еще самое интересно, это посмотреть все объекты, чтоб не нужно было каждый открывать.
    регистр сведений -> записи о версиях объектов
    очень удобно )
  17. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    в УПП, на все справочники и документы
  18. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    данный список формируется регистром сведений -> НастройкаВерсионированияОбъектов
  19. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    в УПП - да
  20. TopicStarter Overlay
    1c-ka
    Offline

    1c-ka Опытный в 1С

    Регистрация:
    27 май 2014
    Сообщения:
    194
    Симпатии:
    4
    Баллы:
    29
    в УНФ тоже, вот нашел:

    Код:
    &НаСервере
    Процедура ЗаполнитьТипыОбъектовВДеревеЗначений()
       
        ДеревоОМ = РеквизитФормыВЗначение("ДеревоОбъектовМетаданных");
        ДеревоОМ.Строки.Очистить();
       
        // Тип параметра команды ИсторияИзменений содержит состав объектов для которых
        // применяется версионирование
        МассивТипов = Метаданные.ОбщиеКоманды.ИсторияИзменений.ТипПараметраКоманды.Типы();
        ЕстьСправочники = Ложь;
        ЕстьДокументы = Ложь;
        ВсеСправочники = Справочники.ТипВсеСсылки();
        ВсеДокументы = Документы.ТипВсеСсылки();
        УзелСправочники = НеОпределено;
        УзелДокументы = НеОпределено;
       
        Для Каждого Тип Из МассивТипов Цикл
            Если ВсеСправочники.СодержитТип(Тип) Тогда
                Если УзелСправочники = НеОпределено Тогда
                    УзелСправочники = ДеревоОМ.Строки.Добавить();
                    УзелСправочники.СинонимНаименованияОбъекта = "Справочники";
                    УзелСправочники.КлассОбъекта = "01КлассСправочникиКорень";
                    УзелСправочники.КодКартинки = 2;
                КонецЕсли;
                НоваяСтрокаТаблицы = УзелСправочники.Строки.Добавить();
                НоваяСтрокаТаблицы.КодКартинки = 19;
                НоваяСтрокаТаблицы.КлассОбъекта = "КлассСправочники";
               
            ИначеЕсли ВсеДокументы.СодержитТип(Тип) Тогда
                Если УзелДокументы = НеОпределено Тогда
                    УзелДокументы = ДеревоОМ.Строки.Добавить();
                    УзелДокументы.СинонимНаименованияОбъекта = "Документы";
                    УзелДокументы.КлассОбъекта = "02КлассДокументыКорень";
                    УзелДокументы.КодКартинки = 3;
                КонецЕсли;
                НоваяСтрокаТаблицы = УзелДокументы.Строки.Добавить();
                НоваяСтрокаТаблицы.КодКартинки = 20;
                НоваяСтрокаТаблицы.КлассОбъекта = "КлассДокументы";
            КонецЕсли;
            МетаданныеОбъекта = Метаданные.НайтиПоТипу(Тип);
            НоваяСтрокаТаблицы.ТипОбъекта = МетаданныеОбъекта.ПолноеИмя();
            НоваяСтрокаТаблицы.СинонимНаименованияОбъекта = МетаданныеОбъекта.Синоним;
           
            ВариантВерсионирования = ПолучитьФункциональнуюОпцию("ВариантыВерсионированияОбъектов",
                                                Новый Структура("ТипВерсионируемогоОбъекта", НоваяСтрокаТаблицы.ТипОбъекта));
           
            Если ВариантВерсионирования = Ложь Тогда
                ВариантВерсионирования = Перечисления.ВариантыВерсионированияОбъектов.НеВерсионировать;
            КонецЕсли;
           
            НоваяСтрокаТаблицы.ВариантВерсионирования = ВариантВерсионирования;
           
            Если НоваяСтрокаТаблицы.КлассОбъекта = "КлассДокументы" Тогда
                НоваяСтрокаТаблицы.Проводится = ? (МетаданныеОбъекта.Проведение = Метаданные.СвойстваОбъектов.Проведение.Разрешить, Истина, Ложь);
            КонецЕсли;
        КонецЦикла;
        ДеревоОМ.Строки.Сортировать("КлассОбъекта");
        Для Каждого УзелВерхнегоУровня Из ДеревоОМ.Строки Цикл
            УзелВерхнегоУровня.Строки.Сортировать("СинонимНаименованияОбъекта");
        КонецЦикла;
        ЗначениеВРеквизитФормы(ДеревоОМ, "ДеревоОбъектовМетаданных");
       
    КонецПроцедуры
    
    я так одинэсником стану ))))))))
    вы наверное УПП вдоль и поперек знаете

Поделиться этой страницей