7.7 ВДГБ: Учет ГСМ и транспорта в бюджетных учреждениях ред. 7.70.623-1.24

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Olga27, 4 окт 2009.

  1. TopicStarter Overlay
    Olga27
    Offline

    Olga27

    Регистрация:
    4 окт 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Объясните пожалуйста как сделать чтобы в информационной строке документа Авто_Пробег отображался остаток по МОЛ по счет 105.03.
    Конфигурация "ВДГБ: Учет ГСМ и транспорта в бюджетных учреждениях ред. 7.70.623-1.24
  2. TopicStarter Overlay
    Olga27
    Offline

    Olga27

    Регистрация:
    4 окт 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Написал функцию но не знаю как сделать чтобы отбор по МОЛ делался. Подскажите что нужно исправить

    Код:
    Функция ИнформационнаяСтрока()
    
    Перем Стр;   
    
    БухИт = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БухИт.ПериодМ(ИспользоватьДату());     
    
    
    Стр = "";
    Если ТекущийЭлемент().Выбран() = 1 Тогда 
    
    Если ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
    
    Если КонМесяца(ИспользоватьДату()) > КонецРассчитанногоПериодаБИ() Тогда
    Стр = "На " + КонМесяца(ИспользоватьДату()) + " бухгалтерские итоги не рассчитаны!"+РазделительСтрок+
    "Расчет итогов выполняется в режиме"+РазделительСтрок+
    """Операции - Управление бухгалтерскими итогами"".";
    
    Иначе
    Стр = ТекущийЭлемент().Наименование + ": " + БухИт.СКД(СчетПоКоду("105.3"),"К",,,,ТекущийЭлемент()) +
    " " +ТекущийЭлемент().ЕдИзм + РазделительСтрок +
    "Данные актуальны на конец дня " + КонМесяца(ИспользоватьДату());
    КонецЕсли;  
    КонецЕсли;
    КонецЕсли;
    
    Возврат Стр;
    
    КонецФункции // ИнформационнаяСтрока()
    
  3. Sklowsky
    Offline

    Sklowsky

    Регистрация:
    4 ноя 2007
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    В функции БухИт.СКД(СчетПоКоду("105.3"),"К",,,,ТекущийЭлемент()) после ТекущийЭлемент() через запятую положить ссылку на поле с выьранным МОЛ. И ещё счет нужно указать правильно: 105.03
  4. GlebHappy
    Offline

    GlebHappy Опытный в 1С

    Регистрация:
    31 июл 2009
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Ещё и не факт, что 105.03 - полный код счета, потому как обычно потом ещё идет цифирка, обозначающая источник финансирования. Или у Вас все идет без детализации по ИФ???
  5. Sklowsky
    Offline

    Sklowsky

    Регистрация:
    4 ноя 2007
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Если требуются просто остатки топлива по организации или организация работает только по одному виду деятельности, то указания номера счета 105.03. вполне достаточно. Другое дело, что в типовой конфигурации 1С для бюджетных учреждений по аналитике Места хранения ведется учет только по количеству материалов. Поэтому формирование сведений о суммовых остатках на конечную дату таким образом невозможно.
    Для получения такой информации нужно включить по аналитике Места хранения опцию учет по сумме и выполнить полный пересчет итогов..
  6. GlebHappy
    Offline

    GlebHappy Опытный в 1С

    Регистрация:
    31 июл 2009
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Речь не о типовой бюджетной конфигурации, а о чем-то специальном для учета ГСМ - читайте первый пост.
    Хотя по сути Вы правы - вероятен вариант, когда ведется только бюджетная деятельность, следовательно, детализация по источникам финансирования не предусмотрена.

Поделиться этой страницей