7.7 В ЗИК в документе "Начисление отпуска" вместо 29,4 нужно 29,3

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем MyNameNoName, 20 окт 2014.

  1. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    В Конфигурации ЗИК 2.3 (дописанная) в документе "Начисление отпуска" по клавиши Заполнить необходимо заменить расчетный коэффициент, чтобы он брался не 29,4, а 29,3. Не могу понять где он находится.
    Вот сам документ:
    upload_2014-10-20_13-39-28.png
    В конфигураторе вот такая форма:
    upload_2014-10-20_13-40-27.png
    и ни в форме, ни в модуле нет такого коэффициента. Откуда он берется и как проще внести необходимые изменения?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Коэффициент в ТИПОВОЙ находится в константах. Заполнение таблицы для рассчета среднего производится в ГМ
    MyNameNoName нравится это.
  3. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Вот сам код:
    Код:
    Процедура ЗаполнитьТабличнуюЧасть()                         
       
        Если ПроведенВПрошлом=1 Тогда
            Предупреждение("Документ проведен в прошлом периоде. Его нельзя редактировать.",10);
            Возврат
        КонецЕсли;
        Если ПроверкаПриЗаполненииТабличнойЧасти() = 0 Тогда
            глОткрытьОбработчик(ОбработчикСообщений, Вид()+НомерДок);
            Возврат;
        КонецЕсли;
        Если КоличествоСтрок() > 0 Тогда
            Если Вопрос("Прежние данные о среднем заработке будут заменены новыми, продолжить?", "Да+Нет") = "Нет" Тогда
                Возврат;
            КонецЕсли;
        КонецЕсли;
       
        ТабДанныхОСреднем = глЗаполнитьДанныеСреднегоЗаработкаОтпуска(Сотрудник, ПолучитьДатуСобытия(),?(КоличествоМесяцев=1,3,12),ВидОтпуска,ИспользоватьСреднеЧасовойЗаработок);
        ЗагрузитьТабличнуюЧасть(ТабДанныхОСреднем);
       
    КонецПроцедуры // ЗаполнитьТабличнуюЧасть
    Как я понимаю нужный коэффициент храниться в глЗаполнитьДанныеСреднегоЗаработкаОтпуска, видимо где-то это в глобальном модуле (но где он расположен, в самом документе нет).
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вы не знаете где ГМ находится в конфигурации?
    MyNameNoName нравится это.
  5. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Открыл в приложении константы там такой цифры нет. А как в типовой этот коэффициент в константах называется?
    --- Объединение сообщений, 20 окт 2014 ---
    Нашел глобальный модуль сейчас попробую разобраться.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Ищите в ГМ процедуру ПолучитьКоличествоДнейОтпускаПосле102006... Также тот коэффициент присутствует в модуле расчета по отпуску
    MyNameNoName нравится это.
  7. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Огромное спасибо!
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не за что
    MyNameNoName нравится это.
  9. pavl_vs
    Offline

    pavl_vs Профессионал в 1С

    Регистрация:
    18 июн 2011
    Сообщения:
    343
    Симпатии:
    27
    Баллы:
    54
    Если еще не решено.
    Просто в конфигураторе наберите глобальный по всем текстам поиск 29.4

    А значение константы, даже если она присутствует в справочнике, уже давно не обрабатывается.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей