7.7 В счете на оплату отображать задолженность

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Maagnitochka, 15 ноя 2018.

  1. TopicStarter Overlay
    Maagnitochka
    Offline

    Maagnitochka

    Регистрация:
    14 июн 2015
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Помогите, пожалуйста, может быть кто-то делал.
    Хотелось бы в стандартной конфигурации 1С:Бухгалтерия 7.7 Бухгалтерский учет сделать так, чтобы в счете на оплату отображалась задолженность клиента перед Поставщиком на момент выставления данного счета.
    В случает отсутствия задолженности, чтобы оставалась просто пустая строка.
    Последнее редактирование: 15 ноя 2018
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    В чем именно нужна помощь?
    Как получить сумму задолженности или как вывести?
  3. TopicStarter Overlay
    Maagnitochka
    Offline

    Maagnitochka

    Регистрация:
    14 июн 2015
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Как получить сумму задолженности -Shamefullyembarrased-
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Через БухгалтерскиеИтоги запрос к счету 62.1 с фильтром по субконто Контрагенты
  5. TopicStarter Overlay
    Maagnitochka
    Offline

    Maagnitochka

    Регистрация:
    14 июн 2015
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Простите, вот так:
    Код:
            БухИт62 = СоздатьОбъект("БухгалтерскиеИтоги");
            БухИт62.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент, 2); 
            БухИт62.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор, 2); 
            БухИт62.ВыполнитьЗапрос(,ДатаДок,"62.1",,,,,"СК");
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Да! получаем итоги и их выводим.
    Нужно еще учесть нюанс... Если покупатель был поставщиком.. Добавьте 60й счет в анализ с минусом.
  7. TopicStarter Overlay
    Maagnitochka
    Offline

    Maagnitochka

    Регистрация:
    14 июн 2015
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Прошу прощения, можете уточнить "их выводим", как их вывести? Потому что пока не получается(((
  8. TopicStarter Overlay
    Maagnitochka
    Offline

    Maagnitochka

    Регистрация:
    14 июн 2015
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Сделала вот так:
    Код:
        БухИт62 = СоздатьОбъект("БухгалтерскиеИтоги");
            БухИт62.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент, 2);
            БухИт62.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор, 2);
            БухИт62.ВыполнитьЗапрос(,ДатаДок,"62.1",,,,,"СК");  
    если добавлять
    Код:
       БухИт62.ВыбратьСубконто(ВидыСубконто.Контрагенты);
    Все тоже самое.
    А получаю вот так по итогу:

    Вложения:

  9. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.548
    Симпатии:
    59
    Баллы:
    54
    а чё в формуле печ.формы написано и какой тип ячейки
  10. TopicStarter Overlay
    Maagnitochka
    Offline

    Maagnitochka

    Регистрация:
    14 июн 2015
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Получилось. Делюсь, вдруг кому-то пригодится.
    Код:
        БухИт62 = СоздатьОбъект("БухгалтерскиеИтоги");
            БухИт62.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент, 2);
    
            БухИт62.ВыполнитьЗапрос(,ДатаДок,"62.1",,,,,"СК");
            БухИт62.ВыбратьСубконто(1);                                                         
    ДолгПокупателя = БухИт62.СКД();
    
    
    Если  ДолгПокупателя > 0 Тогда                                              
        ДолгПокупателя1 = "ОБРАТИТЕ ВНИМАНИЕ Ваша задолженность составляет: " + ДолгПокупателя;  
    КонецЕсли;    
        Если  ДолгПокупателя < 0 Тогда
        ДолгПокупателя1 = "ОБРАТИТЕ ВНИМАНИЕ С Вашей стороны переплата в размере: " + ДолгПокупателя;  
    КонецЕсли;   
    
    Если ДолгПокупателя = 0 Тогда   
        ДолгПокупателя1 = "Благодарим за обращение в нашу компанию";
    КонецЕсли; 
    Ну соотвественно в печатной форме ставим выражение <ДолгПокупателя1 >
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.508
    Симпатии:
    533
    Баллы:
    204
    Правильнее была бы конструкция Если-ИначеЕсли-КонецЕсли

Поделиться этой страницей