7.7 В реквизит документа - картинку, а лучше три :)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем fate-computers, 9 мар 2016.

  1. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Подскажите, есть ли возможность в документ добавлять картинки, на каждый документ нужно добавить 3 сертификата в формате jpg. ?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да хоть пять.. Что мешает сохранить в виде внешнего файла в формате ГодДокумента_Номер_ВидФалйла (контроль уникальности) в служебном каталоге
    Последнее редактирование: 9 мар 2016
  3. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Хотят из документа просматривать данные сертификаты. Я не знаю как правильно это сделать. Потому и спрашиваю совет
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  5. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Ну простите, я не супер 1с программист. Можно как-то в примерах. Я так понимаю, там просто копирование файла. С изменением названия. И важен вариант просмотра. Спасибо.
  6. man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Тем с прикреплением картинки к номенклатуре создано много, посмотрите что и как, принцип такой же.
    На форме кнопка с выбором сертификата, который хотите посмотреть.
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    совершенно верно.
    1) добавьте кнопку "привязки" картинки к документу
    2) Создаем процедуру привязки
    В ней
    - запрос номера сертификата (1,2,3,4,5...)
    - ФС.ВыбратьФайл (параметры см. в СП) Там же есть предпросмотр картинки
    - копируй выбранный файл в служебный каталог. Имя по принципу ГодДокумента_НомерДок_НомерСертификата

    ГодДокумента нужен чтобы сохранить уникальность
    НомерДок тут не забудьте применить СокрЛП() т.к. длина номера м.б. меньше заявленной
    НомерСертификата номер который вы запросили перед выбором файла
    Последнее редактирование: 10 мар 2016
  8. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Получилось как-то так:
    Процедура Сертификат1()
    Если ПустаяСтрока(СертификатФайл1)=0 Тогда
    Картинка.Загрузить(СертификатФайл1);
    Иначе
    ЗаголовокОкна="Выберите сертификат №1";
    Фильтр="Картинки (*.jpg)|*.jpg";
    Расширение=".jpg";
    Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяНачКаталога,ЗаголовокОкна,Фильтр,Расширение)=0 Тогда
    Возврат;
    Иначе
    КаталогИсходный = СокрЛП(СтрЗаменить(ИмяНачКаталога,КаталогИБ(),""));
    ФайлИсходный=КаталогИсходный+ИмяФайла;
    НовыйФайл=Строка(ДатаГод(ТекущаяДата()));
    НовыйФайл=НовыйФайл+"_"+СокрЛП(НомерДок)+"_Сертификат1.jpg";
    КаталогКуда=СокрЛП(СтрЗаменить(КаталогИсходный,ИмяНачКаталога,КаталогИБ()))+"Certif\";
    //ФС.СоздатьКаталог(КаталогКуда);
    ФайлКуда=КаталогКуда+НовыйФайл;
    ФС.КопироватьФайл(ФайлИсходный,ФайлКуда,0);
    СертификатФайл1=СокрЛП(ФайлКуда);
    Картинка.Загрузить(СертификатФайл1);
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ну примерно так... хотя я бы кое-что переделал.
    как минимум в начале проверил НАЛИЧИЕ файла (при условии что имя не пустое)
  10. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Ну доработки будут :)
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  12. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Вопрос, а можно как-то открыть загруженную картинку, допустим стандартным виндовым просмотрщиком?

    Имя файла у нас есть, типа "выполнить" или что-то подобное есть?
  13. man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Можно.
    Смотри метод ЗапуститьПриложение(ИмяФайла).
  14. TopicStarter Overlay
    fate-computers
    Offline

    fate-computers

    Регистрация:
    12 янв 2016
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Большое Спасибо. Все вышло.

Поделиться этой страницей