7.7 В отчете ошибка - деление на 0

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Borikgogi, 13 май 2014.

  1. TopicStarter Overlay
    Borikgogi
    Offline

    Borikgogi

    Регистрация:
    1 дек 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!
    Прошу помочь в данном вопросе. При формировании отчета идет ошибка -
    ТЗ.ЦенаПрих = (Запр.СуммаБезНДС + Запр.Перевозка)/Запр.Кво;
    {Отчет.АнализДоходности.Форма.Модуль(56)}: Деление на 0

    В этом модуле -
    Запр = СоздатьОбъект("Запрос");
    Дата1 = Дата("01.05.09");
    ТекстЗапроса = "//{{ЗАПРОС(Прибыль)
    |Период с Дата1 по КонДата;
    |ТМЦ = Документ.ПриходнаяНакладная.ТМЦ;
    |СуммаБезНДС = Документ.ПриходнаяНакладная.СуммаБезНДС;
    |Перевозка = Документ.ПриходнаяНакладная.Перевозка;
    |Кво = Документ.ПриходнаяНакладная.Кво;
    |Группировка ТМЦ без групп;
    |Условие(ТМЦ в ВыбТМЦ);
    |";//}}ЗАПРОС

    Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
    Возврат;
    КонецЕсли;
    Пока Запр.Группировка("ТМЦ") = 1 Цикл
    ТЗ.НоваяСтрока();
    ТЗ.ТМЦ = Запр.ТМЦ;
    ТЗ.СуммаБезНДС = Запр.СуммаБезНДС;
    ТЗ.Перевозка = Запр.Перевозка;
    ТЗ.Кво = Запр.Кво;
    ТЗ.ЦенаПрих = (Запр.СуммаБезНДС + Запр.Перевозка)/Запр.Кво;
    КонецЦикла;

    Через консоль узнал что, Запр.Перевозка=0.
    Почему вчера отчет работал, а сегодня уже нет?
    Последнее редактирование: 13 май 2014
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    не заполнен реквизит в документе... Скорее всего строка пустая
    добавьте защиту от дурака

    Если Запр.Кво=0 Тогда
    продолжить;
    КонецЕсли;

    Тз.НоваяСтрока();
    ....
  3. TopicStarter Overlay
    Borikgogi
    Offline

    Borikgogi

    Регистрация:
    1 дек 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Бухгалтерский угодник Спасибо! помогло.
    Теперь есть еще один вопрос: Хочу отловить документы в которых есть данная ошибка. Как это можно сделать?

    Сори, конечно, за глупые вопросы. Я новичек :)

    Нашел. Можно вытянуть номер приходной накладной!
    Последнее редактирование: 13 май 2014
  4. TopicStarter Overlay
    Borikgogi
    Offline

    Borikgogi

    Регистрация:
    1 дек 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Всем спасибо! Проблема решена. Тему можно закрывать.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей