8.х В документе «Реализация Товара» не показывается цена со скидкой

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем J-F, 29 июл 2009.

  1. TopicStarter Overlay
    J-F
    Offline

    J-F Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте

    У меня конфигурация «Управление торговлей». Ред. 10,3

    Так вот. Есть документ «Реализация Товаров» (Ничего не менялось в этом документе, стандатрная поставка)
    Например отпускаем товар «Цемент» покупателю «Пупкину С.С.», а он у нас на «привилегированном положение» т.е. у него скидка на товар «Цемент», установленного в документе «Ценооброзование -> Установка скидки номенклатуры»
    Пример: Цены установленные на «Цемент» 150 рублей. И при продаже любым покупателям будет 155р, а вот когда Пупкину 148, т.к. установлена скидка 2%

    Суть вопроса :)
    При формирования документа в табличной части «Товары» в колонке «Цена» цены указываются без скидки. А колонка «Сумма» всегда показывает сумму уже со скидкой.
    Вот затруднения вышло, как сделать так, чтобы при выборе номенклатуры уже ставилась цена со скидкой?

    Просто не удобно то, что цены указываются без скидки. Хотя сумма все ОК!)

    Вот я предполагал, что сумма рассчитывается в Общем Модуле «ОБРАБОТКА ТАБЛИЧНЫХ ЧАСТЕЙ»

    Код:
    Процедура РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект, СпособРасчета = Неопределено) Экспорт
    
    ИмяТабличнойЧасти = ОбщегоНазначения.ПолучитьИмяТабличнойЧастиПоСсылкеНаСтроку(СтрокаТабличнойЧасти);
    
    МетаданныеДокумента = ДокументОбъект.Метаданные();
    
    Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
    СуммаСкидки = 0;
    
    
    Если (СпособРасчета = Неопределено)
    Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.СУчетомВсехСкидок)
    Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки) Тогда
    Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ПроцентАвтоматическихСкидок", МетаданныеДокумента,
    ИмяТабличнойЧасти) Тогда
    СуммаСкидки = Сумма * СтрокаТабличнойЧасти.ПроцентАвтоматическихСкидок / 100;
    КонецЕсли;
    
    Если (СпособРасчета <> Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки)Тогда
    Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ПроцентСкидкиНаценки", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
    СуммаСкидки = СуммаСкидки + (Сумма * СтрокаТабличнойЧасти.ПроцентСкидкиНаценки / 100);
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    
    СтрокаТабличнойЧасти.Сумма = Сумма - СуммаСкидки;
    КонецПроцедуры // РассчитатьСуммуТабЧасти()
    
    
    
    
    
    Если это, то, но странно. Я отключаю вызов этой процедуры. Расчет со скидкой происходит все равно :(
    Подумал, где-то еще вызывается. Сделал все операторы в процедуре коментами. Тоже самое. Цена расчитывается со скидкой.

    Кому не сложно...Подскажите что и как))))
    Заранее спасибо))
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Вроде в доп настройках пользователя есть галочка.. пересчет скидки.. что то типа пересчитывать сумму а не цену... посмотри может просто этого хватит?

    Каким образом товар заносите? Через подбор?

Поделиться этой страницей