8.х в чём ошибка ?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем GP_, 14 окт 2006.

  1. TopicStarter Overlay
    GP_
    Offline

    GP_ Опытный в 1С

    Регистрация:
    15 авг 2006
    Сообщения:
    195
    Симпатии:
    0
    Баллы:
    26
    итог=0;
    ВыборкаДокументов = Документы.ЧекККМ.Выбрать(Дата1,Дата2);
    Пока ВыборкаДокументов.Следующий() Цикл
    ы=0;
    Для Каждого ТекущаяСтрока Из ВыборкаДокументов.Товары Цикл
    // Действия со строкой табличной части.
    КолСтр = ВыборкаДокументов.Товары.Количество() - 1;
    Для Сч = 0 по КолСтр Цикл
    Если СОКРЛП(ВыборкаДокументов.Товары.Получить(СЧ).Продавец.Наименование) = Продавец.Наименование ТОгда
    сообщить("Провепрка"+ВыборкаДокументов.Товары.Получить(СЧ).Продавец.Наименование + "!!!!!!!!!!1" + Продавец.Наименование );

    // Действия со строкой табличной части.
    Итог = Итог + 1 ;
    Прервать;
    КонецЕсли;
    //сООБЩИТЬ(+ ","+ СОКРЛП(Продавец.Наименование));
    КонецЦикла;
    КонецЦикла;
    ы=ы+1;
    КонецЦикла ;

    сообщить("Всего документов : " + Итог);
    Сообщить("all" +ы);
    Сумм = Итог;
    Итог=0;

    народ что не так подскажите плз..... :unsure:
Похожие темы
  1. Helmut
    Ответов:
    7
    Просмотров:
    1.371
  2. zxcv
    Ответов:
    7
    Просмотров:
    1.048
Загрузка...

Поделиться этой страницей