[РЕШЕНО] УТ11.1 Обработка штрих кодов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Diabl06, 23 ноя 2015.

  1. TopicStarter Overlay
    Diabl06
    Offline

    Diabl06

    Регистрация:
    9 ноя 2015
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Помогите, пожалуйста, с обработкой. Необходимо убрать с лева и с права пробелы у штрих кодов. В программировании 1С несилен, немного умею пользоваться отладчиком.
  2. Ktyf
    Offline

    Ktyf Опытный в 1С

    Регистрация:
    16 янв 2013
    Сообщения:
    457
    Симпатии:
    12
    Баллы:
    29
    а какие пробелы тебя там не устраивают? Покажи?
  3. Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    Функция СокрЛП(Текст) удаляет незначащие символы слева и справа.
  4. TopicStarter Overlay
    Diabl06
    Offline

    Diabl06

    Регистрация:
    9 ноя 2015
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Вдруг кому пригодиться
    Код:
    &НаСервере
    Процедура Команда1НаСервере()
     
        Запрос = Новый Запрос;
        Запрос.Текст =
            "ВЫБРАТЬ
            |   ШтрихкодыНоменклатуры.Штрихкод,
            |   ШтрихкодыНоменклатуры.Номенклатура,
            |   ШтрихкодыНоменклатуры.Характеристика,
            |   ШтрихкодыНоменклатуры.Упаковка
            |ИЗ
            |   РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры";
     
        РезультатЗапроса = Запрос.Выполнить();
        Набор = РегистрыСведений.ШтрихкодыНоменклатуры.СоздатьНаборЗаписей();
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Запись = Набор.Добавить();
            ЗаполнитьЗначенияСвойств(Запись,ВыборкаДетальныеЗаписи);
            Запись.Штрихкод = СокрЛП(Запись.Штрихкод);
        КонецЦикла;
        Набор.Записать();
     
    КонецПроцедуры
    
    &НаКлиенте
    Процедура Команда1(Команда)
        Команда1НаСервере();
    КонецПроцедуры

    Вложения:

    Последнее редактирование модератором: 25 ноя 2015

Поделиться этой страницей