8.х УТ УТ 11 "Погашение задолженности"

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Fura, 7 сен 2011.

  1. TopicStarter Overlay
    Fura
    Offline

    Fura

    Регистрация:
    30 авг 2011
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Есть нередактируемая таблица в справочники "Контрагенты" - "Погашение задолженности", в ней должны первой строкой заполняться данные из регистра накопления запросом.. Но при первом открыти документа все проходит нормально, а при следующих выставляется пустая строка... и так каждый раз.. Помогите разобраться...
    Процедура ПриСозданииНаСервере
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Контрагент", Объект.Ссылка);
    Запрос.Текст =
    "ВЫБРАТЬ
    | ПродажаВРассрочкуОстаткиИОбороты.Покупатель,
    | ПродажаВРассрочкуОстаткиИОбороты.СуммаДолгаРасход КАК Оплачено,
    | ПродажаВРассрочкуОстаткиИОбороты.СуммаДолгаПриход КАК Долг,
    | ПродажаВРассрочкуОстаткиИОбороты.СуммаДолгаКонечныйОстаток КАК КонечныйОстаток
    |ИЗ
    | РегистрНакопления.ПродажаВРассрочку.ОстаткиИОбороты КАК ПродажаВРассрочкуОстаткиИОбороты
    |ГДЕ
    | ПродажаВРассрочкуОстаткиИОбороты.Покупатель = &Контрагент";
    Контрагент = Объект.Наименование;
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
    ВнесеннаяСумма = Элементы.ПогашениеЗадолженностиВнесеннаяСумма;
    ТаблицаЗначений = Объект.ПогашениеЗадолженности;
    НоваяСтрока = ТаблицаЗначений.Добавить();
    НоваяСтрока.ДатаПлатежа = ТекущаяДата();
    НоваяСтрока.Долг = Выборка.Долг;
    НоваяСтрока.ОставшаясяСумма = Выборка.КонечныйОстаток;
    НоваяСтрока.ВнесеннаяСумма = Выборка.Оплачено;
    Объект.ОставшаясяСумма = Выборка.КонечныйОстаток;
    Объект.ДатаПоследнегоПлатежа = НоваяСтрока.ДатаПлатежа;
    КонецЕсли;
    Иначе Если Элементы.ОставшаясяСумма = 0 Тогда
    Выборка = Запрос.Выполнить().Пустой();
    КонецЕсли;
  2. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26
    Отладчик что показывает?
  3. TopicStarter Overlay
    Fura
    Offline

    Fura

    Регистрация:
    30 авг 2011
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Ничего не происходит... При последующих открытии ставится на Выборку... Как сделать так чтобы этот запрос работал, только при первоначальном открытии справочника?
  4. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26
    СправочникОбъект.<Имя справочника> (CatalogObject.<Имя справочника>)
    ЭтоНовый (IsNew)
    Синтаксис:

    ЭтоНовый()
    Возвращаемое значение:

    Тип: Булево.
    Истина - изменяется еще ни разу не записанный элемент; Ложь - элемент уже записан.
    Описание:

    Определяет, записан ли элемент в базу данных.

    Доступность:

    Сервер, толстый клиент, внешнее соединение.
    Пример:

    Если Объект.ЭтоНовый() Тогда
    Объект.Наименование = "Новый элемент";
    КонецЕсли;
  5. TopicStarter Overlay
    Fura
    Offline

    Fura

    Регистрация:
    30 авг 2011
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Это надо перед запросом вставить?
  6. TopicStarter Overlay
    Fura
    Offline

    Fura

    Регистрация:
    30 авг 2011
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    И когда вставляю вылазит ошибка Значение не является значением объектного типа (ЭтоНовый)...

Поделиться этой страницей