[РЕШЕНО] Ут 11.1 внешняя обработка заполнения документа ввод остатков не видит обработчики событий.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alboldinov, 24 сен 2014.

  1. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    При записи документа вылетает ошибка

    Код:
    &НаСервере
    Функция ЗаполнитьДок(ВидДока,Данные,НазвТЧ="",Табл=Неопределено,i)
        Док1 = Новый ("ДокументМенеджер."+ВидДока);
        Док = Док1.СоздатьДокумент();
        Знчн = Неопределено;
        Для каждого Реквизит из Данные Цикл
            НазвРекв = Реквизит.Ключ;
            Знчн = Реквизит.Значение;
            Попытка
                Док[НазвРекв] = Знчн;
            Исключение
                Сообщить("Ключ " + НазвРекв + " не найден");
            КонецПопытки;
        КонецЦикла;
        Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;
        Если НазвТЧ = "" Тогда
            Возврат(Док);
        ИначеЕсли Табл = Неопределено Тогда
            Возврат(Док);
        КонецЕсли;
       
        ТабДок = Док[НазвТЧ];
        ТабДок.Загрузить(Табл);
    
      попытка
        Док.Записать(РежимЗаписиДокумента.Запись);
    Исключение
        КонецПопытки;
        Возврат(Док);
       
    КонецФункции
    
    upload_2014-9-24_9-58-23.png
    upload_2014-9-24_9-58-47.png

Поделиться этой страницей