8.х ут 10.3 как заполнить по группе

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Raideres, 10 июл 2017.

  1. TopicStarter Overlay
    Raideres
    Offline

    Raideres Опытный в 1С

    Регистрация:
    9 фев 2016
    Сообщения:
    470
    Симпатии:
    1
    Баллы:
    29
    Добрый день подскажите как перенести группу в тч перемещения товаров.
    надо с одного склада перенести номенклатуру на другой склад..
    при этом из определенной группы как можно это сделать
  2. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    7.861
    Симпатии:
    501
    Баллы:
    204
    Добрый. Заполнить по определенной группе нельзя типовым механизмом. Только если писать свою обработку.
  3. TopicStarter Overlay
    Raideres
    Offline

    Raideres Опытный в 1С

    Регистрация:
    9 фев 2016
    Сообщения:
    470
    Симпатии:
    1
    Баллы:
    29
    подскажите где я ошибся почему добать выдает ошибку

    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
       Запрос = Новый Запрос;
      Запрос.Текст ="ВЫБРАТЬ
       |   Номенклатура.Ссылка
       |ИЗ
       |   Справочник.Номенклатура КАК Номенклатура
       |ГДЕ
       |   Номенклатура.Родитель = &Родитель";
       Запрос.УстановитьПараметр("Родитель",Справочники.Номенклатура.НайтиПоКоду("00000002634"));
       РезультатЗапроса = Запрос.Выполнить().Выгрузить();
     
        Для каждого Стр из РезультатЗапроса Цикл
      НоваяСтрока = Объект.Товары.Добавить();
      НоваяСтрока.Номенклатура = Стр.Ссылка;
      КонецЦикла
    КонецПроцедуры
    Последнее редактирование модератором: 10 июл 2017
  4. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    7.861
    Симпатии:
    501
    Баллы:
    204
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    ДокументОбъект = Ссылка на документ.ПолучитьОбъект();
       Запрос = Новый Запрос;
      Запрос.Текст ="ВЫБРАТЬ
       |   Номенклатура.Ссылка
       |ИЗ
       |   Справочник.Номенклатура КАК Номенклатура
       |ГДЕ
       |   Номенклатура.Родитель В ИЕРАРХИИ (&Родитель)";
       Запрос.УстановитьПараметр("Родитель",Справочники.Номенклатура.НайтиПоКоду("00000002634"));
       РезультатЗапроса = Запрос.Выполнить().Выгрузить();
        Для каждого Стр из РезультатЗапроса Цикл
      НоваяСтрока = ДокументОбъект.Товары.Добавить();
      НоваяСтрока.Номенклатура = Стр.Ссылка;
      КонецЦикла;
    Попытка
    ДокументОбъект.Записать();
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    КонецПроцедуры
  5. AsadRoman
    Offline

    AsadRoman

    Регистрация:
    22 авг 2011
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Как же все любите циклы. Не проще заполнитьзначениясвойств(ДокументОбъект.Товары, РезультатЗапроса)?

Поделиться этой страницей