8.х Установка времени из секунд

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем v0233, 3 окт 2011.

  1. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Помогите пожалуйста секунды и записать в реквизит время.
    Реквизит ВремяЗвонка, тип "ВРЕМЯ"
    секунды=176;
    Код:
    //не работает
    ВремяЗвонка=Секунды;
    
    
    
  2. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Т.е. нужно рассчитать длительность звонка в часах-минутах-секундах?

    Код:
    Функция ДлительностьЗвонка(Секунд)
    Часов = 0;
    Минут = 0;
    Длительность = "";
    Если Секунд >= 60*60 Тогда
    Часов = Цел(Секунд / (60*60));
    Секунд = Секунд % (60*60);
    Длительность = " "+Часов+" ч";
    КонецЕсли; 
    Если Секунд >= 60 Тогда
    Минут = Цел(Секунд / 60);
    Секунд = Секунд % 60;
    Длительность = Длительность+" "+Минут+" м";
    КонецЕсли;
    Длительность = Длительность+" "+Секунд+" с";
    
    Возврат Длительность;
    КонецФункции
    
  3. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое за функцию.
    Я так и представлял что придется делить и умножать секунды. Но решил не изобретать велосипед, и спросить у профессионалов своего дела.
    Спасибо :angry:
  4. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Я бы делал проще
    Время звонка - Тип дата и время
    ВремяЗвонка=ВремяЗвонка + Секунды;
  5. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Реально, это намного проще. Спасибо

Поделиться этой страницей