8.х установка видимости почему не работает?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем serq82, 23 авг 2011.

  1. TopicStarter Overlay
    serq82
    Offline

    serq82 Опытный в 1С

    Регистрация:
    20 май 2011
    Сообщения:
    77
    Симпатии:
    0
    Баллы:
    26
    1 С 8.2 пытаюсь в бух 2.0 дописать путевые листы.сейчас делаю справочник МоделиАвто.
    Код:
    Процедура ПриОткрытии()
    ЭтоНовый();
    ЭлементыФормы.ТипТС.Видимость 						= Ложь;
    ЭлементыФормы.НадписьТипТС.Видимость 				= Ложь;
    
    Если 
    Автотранспорт = 1
    Тогда
    ЭлементыФормы.ТипТС.Видимость 						= Истина;
    ЭлементыФормы.НадписьТипТС.Видимость 				= Истина;
    КонецЕсли;
    КонецПроцедуры
    
    
    
    Автотранспорт Булево.Почему не работает????
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Думаю нужно обновить форму:)
    Infinita нравится это.
  3. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Во-первых, что значит у Вас в коде
    Код:
    ЭтоНовый();
    
    
    просто так ... без всего...

    Эта конструкция обычно используется в условии...Т.е проверяется, записан объект или нет.
    Код:
    Если ЭтоНовый() Тогда
    
    
    Во-вторых, раз Автотранспорт - это у Вас БУЛЕВО, тогда надо не так
    Код:
    Если Автотранспорт = 1 Тогда
    
    
    ,

    а так:

    Код:
    Если Автотранспорт Тогда
    
    
  4. sgirg
    Offline

    sgirg Опытный в 1С

    Регистрация:
    25 дек 2008
    Сообщения:
    126
    Симпатии:
    0
    Баллы:
    26
    И вообще как то не рационально код написан!
    При открытии Вы выставляете элементам формы видимость = ложь, а когда пограмма доходит до условия и ловит "Истину" у переменной "Автотранспорт", то вы для элементов формы выставляете видимость = Истина. Таким образом два раза меняете видимость у элементов. А зачем?
    Код:
    Если Автотранспорт Тогда
    ЭлементыФормы.ТипТС.Видимость = Истина;
    ЭлементыФормы.НадписьТипТС.Видимость = Истина;
    Иначе
    ЭлементыФормы.ТипТС.Видимость = Ложь;
    ЭлементыФормы.НадписьТипТС.Видимость = Ложь;
    КонецЕсли;
    
    И разберитесь с ЭтоНовый() как было сказано выше))

Поделиться этой страницей