7.7 Установка видимости элемента диалога на форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Skyrim, 10 мар 2011.

  1. TopicStarter Overlay
    Skyrim
    Offline

    Skyrim Опытный в 1С

    Регистрация:
    1 ноя 2010
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    В форму элемента-справочника номенклатура добавил еще одну закладку. На ней разместил нужные элементы диалога и установил им флаг невидимости. Запускаю конфигурацию - элементы диалога видны.
    В процедуре ПриОткрытии() добавил Форма.Список.видимость(0), но элемент всеравно отображается на форме. В чем может быть проблема?
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Добавляйте еще установку видимости и в процедуру ПриВыбореЗакладки():
    Код:
    Процедура ПриВыбореЗакладки(Номер,Значение)
    Если Значение = "Имя_Закладки" Тогда
    Форма.Список.видимость(0);
    КонецЕсли;
    КонецПроцедуры
    
  3. TopicStarter Overlay
    Skyrim
    Offline

    Skyrim Опытный в 1С

    Регистрация:
    1 ноя 2010
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Не помогает. Элемент все равно отображается.
  4. TopicStarter Overlay
    Skyrim
    Offline

    Skyrim Опытный в 1С

    Регистрация:
    1 ноя 2010
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Добавил обработку при изменении реквизита:

    Код:
    Процедура УстВидидимость() 
    
    Если УчетПоСН=Перечисление.ДаНет.Да Тогда
    Форма.Список.видимость(1);
    
    Иначе
    Форма.Список.видимость(0);
    
    КонецЕсли;
    КонецПроцедуры 
    
    
    
    При изменении реквизита элемент отображается как нужно: если учет=да, то элемент видно, учет=нет элемент скрыт.

    Но скрыть элемент при запуске формы так и не получилось.
  5. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    Попробуйте в Процедуре УправлениеДиалогом()
  6. alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Поставьте

    Форма.Обновить(1);

Поделиться этой страницей