8.х Установка стандартной обработки в УНФ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Андрей Серов, 21 мар 2014.

  1. TopicStarter Overlay
    Андрей Серов
    Offline

    Андрей Серов

    Регистрация:
    21 мар 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!

    При установке стандартной обработки "ЗагрузкаДанныхИзТабличногоДокумента" (взял с диска ИТС за декабрь 2013) в УНФ 1.4 появляется ошибка: "Метод объекта не обнаружен (СведенияОВнешнейОбработке)", нашел информацию, что нужно конвертировать, но Конфигуратор при открытии обработки не пишет, что конвертация требуется.
    Надеюсь, что решение не очень сложное, потому что я, пока что, во всем этом очень плохо разбираюсь.
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Вам надо в модуль объекта Вашей обработки вставить код типа такого (пример из демки):
    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
    
        ПараметрыРегистрации = Новый Структура;
        ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
        ПараметрыРегистрации.Вставить("Наименование", НСтр("ru = 'Путеводитель по демонстрационной базе'"));
        ПараметрыРегистрации.Вставить("Версия", "1.0");
        ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
        ПараметрыРегистрации.Вставить("Информация", НСтр("ru = 'Путеводитель содержит описание хозяйственных операций, отраженных в демонстрационной базе, и является удобным средством навигации по документам, регистрирующим эти хозяйственные операции.'"));
    //    ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
    
        ТаблицаКоманд = ПолучитьТаблицуКоманд();
    
        ДобавитьКоманду(ТаблицаКоманд,
            НСтр("ru = 'Путеводитель по демо-базе'"),
            "ПутиводительПоДемоБазе",
            "ОткрытиеФормы",
            Истина,
            "");
       
        ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
        Возврат ПараметрыРегистрации;
    
    КонецФункции // СведенияОВнешнейОбработке()
    
    Функция ПолучитьТаблицуКоманд()
      Команды = Новый ТаблицаЗначений;
      Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
      Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
      Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
      Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
      Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
      Возврат Команды;
    КонецФункции
    
    Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
      НоваяКоманда = ТаблицаКоманд.Добавить();
      НоваяКоманда.Представление = Представление;
      НоваяКоманда.Идентификатор = Идентификатор;
      НоваяКоманда.Использование = Использование;
      НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
      НоваяКоманда.Модификатор = Модификатор;
    КонецПроцедуры
    --- Объединение сообщений, 22 мар 2014 ---
    Но только, насколько я понимаю, эта обработка (ЗагрузкаДанныхИзТабличногоДокумента) для обычных форм. В УНФ она не запустится.
    Или я не в курсе, что уже вышла данная обработка для управляемых форм?
    --- Объединение сообщений, 22 мар 2014 ---
    Так, друзья, а куда делось оформление текста в виде кода???
    Его нет? Или у меня со зрением плохо? :( Нашел :)
    Последнее редактирование: 22 мар 2014
  3. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.429
    Симпатии:
    372
    Баллы:
    104
    обработку надо в режиме обычного приложения пользовать на УФ
    через отладку из конфигуратора
    upload_2014-3-22_19-39-24.png
  4. az-april
    Offline

    az-april Опытный в 1С

    Регистрация:
    25 апр 2014
    Сообщения:
    56
    Симпатии:
    0
    Баллы:
    26
    В режиме обычного приложения тоже с ошибкой вылетают:

    Ошибка подключения внешних метаданных.

    {ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(2260)}: Ошибка при вызове метода контекста (Подключить)
    ПараметрыОбработки.ИмяОбъекта = СокрЛП(Менеджер.Подключить(ПараметрыРегистрации.АдресДанныхОбработки, , Истина));
    по причине:
    Ошибка подключения внешних метаданных
    по причине:
    Неправильный путь к файлу 'e1cib/tempstorage/93845832-c3fc-4052-a0a8-706dc969b8a1'

    Запускается в обычном приложении через "Файл - Открыть..."

Поделиться этой страницей