8.х установка параметров

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем goonia, 14 окт 2011.

  1. TopicStarter Overlay
    goonia
    Offline

    goonia

    Регистрация:
    14 окт 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здраствуйте.

    Помогите пожалуйста вот с такой проблемой.

    Есть код и есть макет. Надо установить параметры запроса и занести все это в макет и вывести.


    Процедура КоманднаяПанель1Сформировать(Кнопка)

    ОбновитьОтчет();

    КонецПроцедуры // КоманднаяПанель1Сформировать()


    Процедура ОбновитьОтчет()
    Если НЕ ЗначениеЗаполнено(ДатаНач) Или НЕ ЗначениеЗаполнено(ДатаКон) Тогда
    Предупреждение("Не выбран период!");
    Возврат;
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(Склад) Тогда
    Предупреждение("Не выбран склад!");
    Возврат;
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(ТипЦены) Тогда
    Предупреждение("Не выбрано тип цены!");
    Возврат;
    КонецЕсли;

    ТабДок = ЭлементыФормы.ТабДок;
    ТабДок.Очистить();

    Макет=ПолучитьМакет("Макет");
    Область=Макет.ПолучитьОбласть("Заголовок");
    Область.Параметры.организация=Организация;
    Область.Параметры.склад=склад;
    Область.Параметры.ДатаНачала=ДатаНач;
    Область.Параметры.ДатаКонца=ДатаКон;
    ТабДок.Вывести(область);


    Область=Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(область);

    Область=Макет.ПолучитьОбласть("ОстатокНачала");
    Область.Параметры.ДатаНачала="Остаток на " + ДатаНач;
    ТабДок.Вывести(область);


    Запрос=новый запрос;
    запрос.установитьПараметр(!!!!!!!!!!!!!!!!!!!!!!);
    Запрос.Текст="ВЫБРАТЬ
    | ХозрасчетныйОстаткиИОбороты.Регистратор КАК Документ,
    | ХозрасчетныйОстаткиИОбороты.Регистратор.Контрагент КАК Поставщик_покупатель,
    | СУММА(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстаток) КАК Товар,
    | СУММА(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстаток * ХозрасчетныйОстаткиИОбороты.КоличествоНачальныйОстаток) КАК ТоварСНаценкой
    |ИЗ
    | РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&ДатаНач, &ДатаКон, Регистратор, , , , ) КАК ХозрасчетныйОстаткиИОбороты
    |
    |СГРУППИРОВАТЬ ПО
    | ХозрасчетныйОстаткиИОбороты.Регистратор,
    | ХозрасчетныйОстаткиИОбороты.Регистратор.Контрагент";
    результат=запрос.Выполнить();

    Область=макет.ПолучитьОбласть("Строка");


    ТабДок.Показать();

    КонецПроцедуры
    Посмотреть вложение 8807

    Вложения:

    • макет.PNG
      макет.PNG
      Размер файла:
      57,6 КБ
      Просмотров:
      23
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    обходи результат запроса в цикле. и заполняй область Строка, и выводи в ТабДок ее.
  3. TopicStarter Overlay
    goonia
    Offline

    goonia

    Регистрация:
    14 окт 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1

    спасибо за подсказку, но дело в том что я новичек в 1с и ничего ещё незнаю) если вас не затруднит, вы могли бы написать код?) заранее благодарен!
  4. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Все! Волшебное слово сказанно "я новичек" - теперь можно расслабиться и ждать когда за вас напишут код, заодно растолкуют куда его нужно вставить, как открыть форму, как обновить БД...

    Знаю куда и что вставить - но писать лен. Т.к. считаю что новичкам, коими бывали все - полезно поковырять самому. Только через шишки приходит уменее.
    Примеров на форуме по работе с отчетами и обработками - туча. Читать и анализировать - ну и делать.
    Работы, новичку (хоть иногда читавшему такую желтенькую книгу) - на час, ну может полтора.
    А сколько тема уже "висит"?

Поделиться этой страницей