Установка Доступности/Видимости Поля

Тема в разделе "Другие решения", создана пользователем Akrisis, 4 мар 2015.

  1. TopicStarter Overlay
    Akrisis
    Offline

    Akrisis

    Регистрация:
    4 мар 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Всем привет. Что то ищу-ищу, рою-рою, но никак не могу найти решение своей проблемы.
    Идея состоит в чем, чтобы в "Форме списка" при выборе в поле "ВидДоговора" , два значения - Если ОдноразовыйДоговор, то скрыть Поля "Организация"(Ну или хотябы доступность убрать), если "МногоразовыйДоговор", то оставить как есть.

    У меня получается просто убрать доступность, без "Если" и тп. Может кто нибудь тыкнет новичка в нужную сторону? Пожалуйста.

    Вот примерный код.
    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        Если Элементы.ПодробныеДанныеВидДоговора.ОдноразовыйДоговор Тогда
           
        Элементы.ПодробныеДанныеОрганизация.Доступность = Ложь;
    Иначе
        Элементы.ПодробныеДанныеОрганизация.Доступность =Истина;
       
        КонецЕсли;
        КонецПроцедуры
    
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Этот код нужно прописывать в обработчике выбора.
    Купите версию для обучения программирования, пожалуйста.
  3. TopicStarter Overlay
    Akrisis
    Offline

    Akrisis

    Регистрация:
    4 мар 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Так она куплена. И Книга полностью прочитана 1С8.2.
    --- Объединение сообщений, 4 мар 2015 ---
    Код:
    &НаКлиенте
    Процедура ПодробныеДанныеВидДоговораОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
        Если Элементы.ПодробныеДанныеВидДоговора.ОдноразовыйДоговор Тогда
           
        Элементы.ПодробныеДанныеОрганизация.Доступность = Ложь;
    Иначе
        Элементы.ПодробныеДанныеОрганизация.Доступность =Истина;
    
    КонецПроцедуры
    

    Так?
    --- Объединение сообщений, 4 мар 2015 ---
    Ладно, тогда другой вопрос. Как обратиться через форму в коде к "перечислению" ?
    Последнее редактирование: 4 мар 2015
  4. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Через код в форме?
    --- Объединение сообщений, 4 мар 2015 ---
    "На сервере" можно напрямую: перечисления.РазделУчета.Основной.
    "На клиенте" посмотрите в справке ПредопределенноеЗначение()
  5. TopicStarter Overlay
    Akrisis
    Offline

    Akrisis

    Регистрация:
    4 мар 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1

    Код:
    Элементы.ПодробныеДанныеВидДоговора = Перечисления.ВидДоговора.ОдноразовыйДоговор
    Получится так? Но так же остается доступным при выборе "ОдноразовыйДоговор"
    [​IMG]
  6. st88
    Offline

    st88 Профессионал в 1С Команда форума

    Регистрация:
    18 окт 2012
    Сообщения:
    1.726
    Симпатии:
    28
    Баллы:
    54
    Так в чем загвоздка?! На первый вопрос вам ответили, на второй тоже...
  7. TopicStarter Overlay
    Akrisis
    Offline

    Akrisis

    Регистрация:
    4 мар 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Все равно не проходит такое чудо. Остается доступным.


    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        Если Элементы.ПодробныеДанныеВидДоговора = Перечисления.ВидДоговора.ОдноразовыйДоговор Тогда
          
        Элементы.ПодробныеДанныеОрганизация.Доступность = Ложь;
    Иначе
        Элементы.ПодробныеДанныеОрганизация.Доступность =Истина;
      
        КонецЕсли;
        КонецПроцедуры
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    НА СЕРВЕРЕ НЕ ДОСТУПНЫ ЭЛЕМЕНТЫ ФОРМЫ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Серверу далеко наплевать на то, что отображается клиенту.
  9. TopicStarter Overlay
    Akrisis
    Offline

    Akrisis

    Регистрация:
    4 мар 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Ага.Спасибо.Досвидания.

Поделиться этой страницей