7.7 Установка цен номенклатуры 1С7.7

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем moris, 29 янв 2009.

  1. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Я не специалист 1с и хотелось бы поинтересоваться у профессионалов:
    Не подскажете, как возможно сделать, что бы курс доллара не влиял на розничные цены продаваемого товара, а только на товар, который приходит по закупке в фирму. Вроде как в 1с 8 есть такое, это можно сделать в установке цены номенклатуры, если я правильно понял. Там можно поставить тип товара закупочный и продажный. В 1с7.7 я такого не нашел. Если не корректно задан вопрос, то прошу прощения за косноязыкость.
    Заранее спасибо за помощь...)))
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Если это опять вопрос по полностью переписанной конфе, то и здесь никто "вслепую" не поможет.

    В типовой ТиС тоже есть виды цен, нужно копать там...
  3. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Каким образом ее сюда выложить?
  4. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    в каталоге базы есть файл 1cv7.md, вот надо его заархивировать и положить...
  5. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Может где-то валюту учета надо поменять и все?


    Выкладываю, вначале тормозит долго, потом страница обновляется и все - файла не вижу прикрепленного. Ничего не выходит...
  6. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Не видя, конечно, трудно рассуждать, но посмотри типы цен. Какие валюты на них стоят? Продажные цены - рассчитываются и хранятся или рассчитываются динамически?
  7. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    :unsure:
    Придумал, как обойти то, что у меня на форум не закачиваются файлы.
    Вот ссылка на файлик.
    http://
    Ссылку удалил, дабы все базу не качали - все равно ответов по теме нет.
  8. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Просили-просили файлик, а как выложил, то сразу тишина... :unsure:

    Вообще Надо что бы Себестоимость, которая в USD и учетная цена не влияла на Нал Мелкопт, Нал Опт и Безнал, которые должны быть в рублях, это если кто вдруг будет это читать и решит помочь...
  9. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Валюты - USD. Продажные цены пересчитываются относительно курса, но их приходится всегда менять вручную, так как цены относитльно курса не меняются...
  10. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Уточни все-таки, что тебе надо. Чтобы продажные цены менялись или не менялись относительно закупочной?
  11. TopicStarter Overlay
    moris
    Offline

    moris

    Регистрация:
    26 янв 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Что бы продажные не менялись при смене курса, а закупочные менялись относительно смененого курса. Курс меняется вручную.
  12. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    У продажных дожно стоять "рассчитываются и хранятся".
  13. loenz
    Offline

    loenz

    Регистрация:
    31 авг 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Занимаюсь сейчас похожей темой для 1С: Торговля и склад 7.7. Необходимо розничные цены на все товары увеличить на 5%. Разобрался как это делается с помощью встроенной обработки формирования цен. Суть проблемы в том, что эта обработка формирует и изменяет цены только по отбору остатков товаров. Т.е. товар в справочнике есть, а остатка по нему нет, то и в отбор формирования цен эти товары не включаются.

    Нашёл несколько выходов:
    1) По всем товарам сделать приход в количестве одной штуки, тогда фожно было бы сформировать новые цены по всем, а потом удалить тот документ "Оприходование ТМЦ". Одно НО! Товаров куча (2500-5000 наименований) даже подбором это долго.

    2) Распечатать отчёт по остаткам ТМЦ, забить по ним приход товаров в количестве 1 шт. по каждому, и т.д.

    Какие ещё есть варианты?
    Может есть обработка схожая на типовую для формирования цен без отбора по остаткам, чтобы формировал для нового типа цен ("Розничная +5%") по ВСЕЙ номенклатуре?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В обработке формирования выключить контроль остатков...
    Код:
    Функция ЕстьОстатокТМЦ(ТМЦ, Остаток, Резерв)
    Возврат 1; //добавили вот эту строчку            
    Рез = 0;
    
    // Если нужно учитывать еще и резервы
    Если Показатель.ТекущаяСтрока() = 2 Тогда
    Остаток = Остаток - Резерв;
    КонецЕсли;		
    
    ТекСтр  = ЗначениеПоказателя.ТекущаяСтрока();
    ТекЗнач = ЗначениеПоказателя.ПолучитьЗначение(ТекСтр, "");
    Если ТекЗнач = "все" Тогда Рез = 1;
    
    ИначеЕсли ТекЗнач = "положительные" Тогда
    
    Если Остаток > 0 Тогда Рез = 1; КонецЕсли;
    
    ИначеЕсли ТекЗнач =  "отрицательные" Тогда
    
    Если Остаток < 0 Тогда Рез = 1; КонецЕсли;
    
    ИначеЕсли ТекЗнач =  "меньше мин. остатка" Тогда
    
    Если Остаток < ТМЦ.МинОстаток Тогда   Рез = 1; КонецЕсли;
    
    КонецЕсли;
    
    Возврат Рез;
    КонецФункции // ЕстьОстатокТМЦ()
    
  15. NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    Или написать обработку, по перебору номенклатуры и присвоения розничной цене нового значения на дату формирования.
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    СМЫСЛ???? Когда можно изменить одну строчку... Трудозатраты не сопоставимы.
  17. baikot
    Offline

    baikot

    Регистрация:
    29 июн 2012
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Всем Здравия! Народ, подскажите, есть похожая проблемка, решения не нашел! Суть проблемы:
    В Документе поступление ТМЦ по кнопке "Подбор" Вылазят Цены "Закупочные", В форме при подборе добавил колонку с ценами "розничные" , вопрос, как теперь туда вставить розничные цены? ГДЕ ХРАНИТСЯ РОЗНИЧНАЯ ЦЕНА НОМЕНКЛАТУРЫ, в какой переменной, функции, регистре? Где капать.
    П.С. Цена розничная -рассчитывается и хранится!
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В одноименном справочнике цены. Получить можно при помощи процедуры ГМ глВернутьЦену

Поделиться этой страницей