8.х Установка 8.2.15.317 на Ubuntu Server 12.04

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем bankir_1c, 9 окт 2012.

  1. TopicStarter Overlay
    bankir_1c
    Offline

    bankir_1c

    Регистрация:
    5 сен 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Установил следующие пакеты:
    Код:
    # aptitude search 1c-e
    i   1c-enterprise82-common
    i   1c-enterprise82-common-nls
    i   1c-enterprise82-server
    i   1c-enterprise82-server-nls
    
    Собрал postgres8.4 из исходников с патчами от 1С. Опция "--disable-integer-datetimes" использовалась.

    Домашняя директория создалась:
    Код:
    drwxr-xr-x  3 usr1cv82	  grp1cv82	   4096 окт.   8 19:30 usr1cv82
    
    /opt/1C создалась:
    Код:
    drwxrwxr-x  3 root root 4096 окт.   8 19:28 1C
    
    Первое, что насторожило - сразу после установки сервер запускается со второго раза. При первом запуске стабильно FAILED, во второй раз запускается нормально. Причём, после первого раза в процессах появляется rmngr.
    Подключаю сервер в оснастке 1CV8 Servers. Сервер подключается без ошибок, а вот кластеров - ни одного. При попытке создать кластер возникает одна из двух ошибок:
    - Ошибка создания кластера: Ошибка информационной базы. Запуск рабочего процесса невозможен из-за конфликта IP портов
    Ну здесь понятно, что на 1541 порту уже крутится rmngr. Убиваю его, пытаюсь добавить кластер снова:
    - Ошибка создания кластера: Ошибка информационной базы. Попытка создания кластера на другом компьютере.

    Причём, до етого я пробовал ставить платформу 8.3.1.531. Платформа встала сразу, сервак запустился с первого раза, кластер создался сам. Но по некоторым причинам (в частности, перенос конфигурации) на 8.3 так и не суждено поработать, нужно поставить именно 8.2.

    Как решить проблему и добавить кластер и информационные базы?
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Попробуйте с 1541 перенсти на 1641
  3. TopicStarter Overlay
    bankir_1c
    Offline

    bankir_1c

    Регистрация:
    5 сен 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    А как ето сделать? Через оснастку или с какими-то параметрами rmngr запустить?
  4. TopicStarter Overlay
    bankir_1c
    Offline

    bankir_1c

    Регистрация:
    5 сен 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Вон оно шо оказалось! Надо было в /etc/hosts дописать полное имя своего сервера после "127.0.0.1 localhost". Сервер 1С отличает имена server и server.localdomain. Причём, я сделал пока что проще - просто пересоздал компьютер по прямому IP. Кластер создался.
    Проблема теперь в другом. При создании информационной базы пишет "Ни один рабочий процесс не доступен".
    Сдаётся мне, сервер частями как-то запускается. Я и rmngr вручную запустил. Теперь пробую запустить rphost, который запускатся не хочет. Почему оно сразу всё нормально не встало...
  5. TopicStarter Overlay
    bankir_1c
    Offline

    bankir_1c

    Регистрация:
    5 сен 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Получилось. Пришлось вручную добавлять рабочий сервер, потом редактировать конфиги, меняя %servername% на %ip%. Потом обратно, согласно конфигам на старом сервере.
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Ну все заработало? Рады за Вас и не заморачивайтесь пока с 8.3
  7. TopicStarter Overlay
    bankir_1c
    Offline

    bankir_1c

    Регистрация:
    5 сен 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Ура! Запахала-таки! Дело оказалось в postgres. Я не знаю, что у него там закешировалось в первых моих попытках собрать из исходников. Во второй раз я снёс все конфиги, исходники и даже сам pbuilder, переустановил всё заново, сделал уже исходя из опыта и инструкции http://kildekode.ru/personal/2003/Ubuntu-Server-10-04-LTS-i386-PostgreSQL-1C-patch-1.htm и теперь импорт базы проходит успешно. Всем спасибо, кто помог! Добра вам :)

Поделиться этой страницей