8.х установить строку в табличной части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем drxa0z, 25 авг 2009.

  1. TopicStarter Overlay
    drxa0z
    Offline

    drxa0z

    Регистрация:
    25 авг 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день

    необходимо сделать активной следующую строку в табличной части документа

    переход по строкам сделал как здесь http://www.1c-pro.ru/index.php?showtopic=15042

    Код:
    Процедура ТабличнаяЧастьКоличествоПриИзменении(Элемент)
    //Получим номер текущей строки табличного поля
    Индекс = ЭлементыФормы.ТабличнаяЧасть.ТекущаяСтрока.НомерСтроки;
    //Если строка не последняя, то сдвинемся вниз
    Если Индекс<ТабличнаяЧасть.Количество() Тогда                            
    //Так как номер строки на единицу больше, чем ее индекс,
    //индекс следующей строки будет совпадать с номером текущей
    ЭлементыФормы.ТабличнаяЧасть.ТекущаяСтрока = ТабличнаяЧасть[Индекс];
    КонецЕсли;
    КонецПроцедуры
    
    
    
    то есть - при окончании редактирования ячейки - переходим на следующую строку

    НО еще было бы неплохо сразу же заходить в ячейку для редактирования
    как например сделал при выборе ячейки

    Код:
    Процедура ТоварыПриАктивизацииЯчейки(Элемент)
    если элемент.текущаяколонка.имя = "Количество"     тогда
    Элемент.ИзменитьСтроку();
    конецесли;
    КонецПроцедуры
    
    
    
    на вопрос - "Зачем?" - на участке очень критична скорость ввода
    табличная часть заполняется по шаблону - оператору необходимо только ОЧЕНЬ быстро проставить количество
  2. Legion
    Offline

    Legion Опытный в 1С

    Регистрация:
    3 мар 2009
    Сообщения:
    57
    Симпатии:
    1
    Баллы:
    29
    Используй ВвестиЧисло(<Число>, <Подсказка>, <Длина>, <Точность>)
    Где числом будет СтрокаТабличнойЧасти.Количество
  3. TopicStarter Overlay
    drxa0z
    Offline

    drxa0z

    Регистрация:
    25 авг 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    не смог победить

    оставил переход на след строку и сделал в свойствах колонки РежимРедактирования - Вход при вводе

    сойдет и так

    тему наверно можно закрыть

Поделиться этой страницей