7.7 Установить курсор на документе из формы обработки

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Borovikov, 29 май 2007.

  1. TopicStarter Overlay
    Borovikov
    Offline

    Borovikov

    Регистрация:
    29 май 2007
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    ПОдскажите. Как из формы обработки установить курсор на требуемом документе в журнале документов.
    Процедура Клик()
    ДокОП = Таб.ПолучитьЗначение(Таб.ТекущаяСтрока(),Таб.ТекущаяКолонка());
    ОткрытьФорму("Журнал."+ ДокОП.Вид() + ".1",);
    КонецПроцедуры

    Описаная процедура просто открывает журнал в котором документ значится. А курсор на документе не устанавливается.
  2. Snake-84
    Offline

    Snake-84 Опытный в 1С

    Регистрация:
    28 янв 2007
    Сообщения:
    110
    Симпатии:
    0
    Баллы:
    26
    А если как-то так:
    ...
    Конт="";
    ОткрытьФорму("Журнал."+ ДокОП.Вид() + ".1",Конт);
    Конт.АктивизироватьОбъект(ДокОП);
    ...
    если нет - то передавай параметром документ и делай "АктивизироватьОбъект" в контексте формы
  3. TopicStarter Overlay
    Borovikov
    Offline

    Borovikov

    Регистрация:
    29 май 2007
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
  4. Snake-84
    Offline

    Snake-84 Опытный в 1С

    Регистрация:
    28 янв 2007
    Сообщения:
    110
    Симпатии:
    0
    Баллы:
    26
    По первому пункту:
    Процедура глАктивизироватьДокумент(Конт, Док) Экспорт // процедура глобального модуля
    Если Док.ДатаДок < Конт.НачалоИнтервала() Тогда
    Конт.УстановитьИнтервал(Док.ДатаДок, Конт.КонецИнтервала(), 1);
    Сообщить("Начало интервала журнала было автоматически изменено и не будет запомнено после закрытия журнала.", "i");
    Сообщить("Установка интервала для всех журналов выполняется из меню Сервис в настройке параметров системы (Параметры) на закладке Журналы.", "i");
    ИначеЕсли Док.ДатаДок > Конт.КонецИнтервала() Тогда
    Конт.УстановитьИнтервал(Конт.НачалоИнтервала(), Док.ДатаДок, 1);
    Сообщить("Конец интервала журнала был автоматически изменен и не будет запомнен после закрытия журнала.", "i");
    Сообщить("Установка интервала для всех журналов выполняется из меню Сервис в настройке параметров системы (Параметры) на закладке Журналы.", "i");
    КонецЕсли;
    Конт.АктивизироватьОбъект(Док);
    КонецПроцедуры // глАктивизироватьДокумент()

    Процедура ПриОткрытии() // в форме списка журнала
    Если ТипЗначенияСтр(Форма.Параметр) = "Документ" Тогда
    глАктивизироватьДокумент(Контекст, Форма.Параметр);
    КонецЕсли;
    КонецПроцедуры // ПриОткрытии()
    это из типовой МиСофта для РБ

    а по второму - в общем журнале отбор возможен по графам отбора и видам документов, а обычном - только по видам документов.
    Все делается в процедуре ПриОткрытии() ... читай ЖКК

Поделиться этой страницей