7.7 Условие в отчете

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем User1c7.7, 14 май 2011.

  1. TopicStarter Overlay
    User1c7.7
    Offline

    User1c7.7

    Регистрация:
    14 май 2011
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Вот модуль отчета.

    Код:
     Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Склад = Документ.ОтчетДляФормы.Склад;
    |Код = Документ.ОтчетДляФормы.Код;
    |Группировка Склад;
    |Группировка Код;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Склад
    Таб.ВывестиСекцию("Склад");
    Пока Запрос.Группировка(2) = 1 Цикл
    // Заполнение полей Код
    Таб.ВывестиСекцию("Код");
    КонецЦикла;
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
    Я начинающий в 1с, сильно не ругайтесь :) Как бы мне отобрать в цикле в одну колонку с кодом к-5,к-6,к-7 а в другую к-1,к-2,к-70. Скажем сразу в запросе я умею отобрать с условием, а мне нужны все записи а потом уже фильтровать в отдельную колонку чтоб посчитать сумму.
  2. 1Cman
    Offline

    1Cman Опытный в 1С

    Регистрация:
    25 июл 2009
    Сообщения:
    308
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если (Запрос.Код = "5") или (Запрос.Код = "6") или (Запрос.Код = "7") Тогда
    //Здесь вставляем, что вам нужно
    ИначеЕсли (Запрос.Код = "1") или (Запрос.Код = "2") или (Запрос.Код = "70") Тогда
    //Здесь вставляем, что вам нужно
    КонецЕсли;
    
    
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    + учтите что группировка не одна... ОБЯЗАТЕЛЬНО 2 цикла иначе будут дубли

Поделиться этой страницей