8.х Управляемые формы.

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Дмитрий Д, 28 окт 2010.

  1. TopicStarter Overlay
    Дмитрий Д
    Offline

    Дмитрий Д

    Регистрация:
    6 авг 2008
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Во общем у меня такая проблема. Нужно сделать управляемое приложение, ну и само собой управляемые формы. Приложение сделал, а вот с формами проблема. Например хочу в управляемой форме при открытии, что бы автоматически появлялась моя организация и ответственный ( в моем случае, тот кто зашел в 1С) так вот в управляемой форме пишу процедуру:
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    Если ЭтоНовый() Тогда
    // Заполнить реквизиты значениями по умолчанию.
    ЗаполнениеДокументовПереопределяемый.ЗаполнитьШапкуДокумента(Объект, глЗначениеПеременной("глТекущийПользователь"));

    Иначе

    // Установить доступность формы с учетом даты запрета редактирования
    РаботаСДиалогамиЗК.УстановитьДоступностьФормыДляРедактирования(Объект, ЭтаФорма);

    КонецЕсли;

    КонецПроцедуры


    Но при открытии документа появляется ошибка: {Документ.ОтпускаОрганизаций.Форма.ФормаДокумента1.Форма(4,7)}: Процедура или функция с указанным именем не определена (ЭтоНовый)
    Если <<?>>ЭтоНовый() Тогда


    Подскажите что с этим делать и как настроить автоматом ответственное лицо… как я понимаю в управляемых формах и обычном приложении все по разному
  2. TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
  3. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    В модуле объекта можно прописать функцию
    Код:
    Функция ПолучитьЗаписьДокумента() Экспорт
    
    Если ЭтоНовый() Тогда
    Возврат Истина
    Иначе
    Возврат Ложь;
    КонецЕсли;
    
    КонецФункции
    
    
    после чего можно из управляемой формы вызвать функцию и узнать новый это документ или нет.
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    IMHO, в 8.2 (что в управляемых формах, что в обычных) заполнение первоначальных данных лучше делать в обработчике ОбработкаЗаполнения.
  5. BVB_berserk
    Offline

    BVB_berserk Опытный в 1С

    Регистрация:
    30 янв 2009
    Сообщения:
    162
    Симпатии:
    0
    Баллы:
    26
    Плюсану - правильный совет.
  6. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54

Поделиться этой страницей