8.х Управление веб-камерой через 1С

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mhl, 2 фев 2011.

  1. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Возможно ли через 1С 8.1 управлять веб-камерой? Может кто реализовывал такое? Нашел в сети пару исходников, но они у меня не работают. Вот они:
    Код:
    Device = Новый COMОбъект("WIA.DeviceManager");
    Количество = Device.DeviceInfos.Count;
    oDevice = Новый Массив(Количество);
    Для К=1 По Количество Цикл
    Если Device.DeviceInfos(к).Type = 3 Тогда
    Попытка
    oDevice[к-1] = Device.DeviceInfos(к).Connect();
    Исключение
    oDevice[к-1] = Неопределено;
    КонецПопытки;
    Иначе
    oDevice[к-1] = Неопределено;
    КонецЕсли;
    КонецЦикла;
    
    Для К = 1 По Количество Цикл
    Если oDevice[к-1] <> Неопределено Тогда
    Item = oDevice[к-1].ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
    Image = Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
    Image.SaveFile("D:\aaa.jpg");
    КонецЕсли;
    КонецЦикла;
    
    и:
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    TempИмя = ПолучитьИмяВременногоФайла("jpg");
    Для К = 1 По DeviceCount Цикл
    Если oDevice[к-1] <> Неопределено Тогда
    Item = oDevice[к-1].ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
    Image = Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
    Image.Height = 1024;
    Image.Width = 1240;
    Image.SaveFile(TempИмя);
    Картинка = Новый Картинка(TempИмя);
    УдалитьФайлы(TempИмя);
    КонецЕсли;
    КонецЦикла;
    Если Не Картинка = Неопределено Тогда    
    ЭлементыФормы.ПолеКартинки1.Картинка = Картинка;
    КонецЕсли;
    КонецПроцедуры
    

Поделиться этой страницей