8.х управление платным обучением

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем morfiy, 24 апр 2008.

  1. TopicStarter Overlay
    morfiy
    Offline

    morfiy

    Регистрация:
    8 апр 2008
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Регистр периодический и подчиненный документу "УчебныйПлан".В ресурсы регистра заношу то,что может изменится:само наименование дисциплины,ее стоимость,КП,оценкаКП.Но опять таже ошибка.
    В прошлый раз все данные:наименование дисциплины,кп,оценка кп-были измерениями,а стоимость-ресурсами-все работало но нельзя было поменять КП и ОценкаКП.Когда переношу из измерений в ресурсы перестает работать,а возвращаю обратно как было-все равно появляется сообщение об ошибке...приходится заново загружать базу.Вообщем теперь не знаю что делать с этим регистром!!!
  2. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Так, раз регистр периодический - вы должны указать его периодичность и, кроме того, сделать движения с периодом. В качестве ресурсов вы тут можете ничего не использовать, а все сделать на измерениях.

    Периодичность задайте минимум месяц - вы не будете менять учебные планы чаще.

    Поставьте у документа "Автоматическое удаление движений" - вероятнее всего, он пытается при перепроведении дописать те же записи в регистр и вылетае тс ошибкой.
  3. TopicStarter Overlay
    morfiy
    Offline

    morfiy

    Регистрация:
    8 апр 2008
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Процедура,которая добавляет найденные документы в табличную часть справочника. Проблема в том что в выборку попадают элементы,циклы выполняются,но в табличную часть ничего не добавляется.Я не правильно использую метод Добавить()?

    Фамилия=ЭлементыФормы.Наименование.Значение;
    ДопСоглашения.Очистить();
    Выборка=Документы.ДополнительноеСоглашение.Выбрать();
    Пока Выборка.Следующий() Цикл
    Если Выборка.Фамилия=Фамилия Тогда
    Объект=ДопСоглашения.Добавить();
    Объект.НомерДопСоглашения=Выборка.Номер;
    Объект.ДатаДопСтоглашения=Выборка.Дата;
    КонецЕсли;
    КонецЦикла;
  4. TopicStarter Overlay
    morfiy
    Offline

    morfiy

    Регистрация:
    8 апр 2008
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Еще вопросик: есть документ УчебныйПлан,Табличная часть "Семестры" и колонки табличной части: НаименованиеДисциплины,КП,ОценкаКП.
    КП типаБулево.Нужно проверять условие:если галочка не стоит в колонк КП,то нельзя поставить оценку.Искала в справочнике,но пока ниче похожего не нашла.Пишу процедуру

    СеместрыПриАктивизацииКолонки(Элемент)

    Строка=ЭлементыФормы.Семестры.ТекущаяСтрока;
    Если Строка.КП=ложь Тогда
    Строка.ОценкаКП=" ";
    КонецЕсли;

    Пробовала еще несколькопроцедур,но не работают.
  5. TopicStarter Overlay
    morfiy
    Offline

    morfiy

    Регистрация:
    8 апр 2008
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Хочу сказать спасибо всем,кто помог в разработке конфигурации, особенно поблагодарить Эмина. Диплом сделала и защитила на отлично!Спасибо,без вас бы не справилась!
  6. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Пожалуйста!!! :) Поздравляю с защитой!
  7. Ella
    Offline

    Ella

    Регистрация:
    8 фев 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Кто-нибудь работал в программе управление платным обучением? Что-то много непонятного
  8. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Я думаю, в другом месте вопрос задавать надо - здесь обсуждалось написание подобной системы с нуля.
    Вообще не так много кто с ней работал, поэтому может имеет смысл напрямую к производителю обратиться?

Поделиться этой страницей