8.х УПП процедура печати СФ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем TODD22, 18 фев 2015.

  1. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Здравствуйте.

    Есть в УПП в общем модуле "УчетНДС" замечательная процедура "ВывестиСчетФактуруВТабличныйДокумент".

    В ней есть такой кусок кода:
    Код:
    Иначе
            Если НужныСведенияОПодразделенииПокупателя Тогда
    
                //Если НЕ ТипЗнч(ДанныеДляПечати.Покупатель) = Тип("СправочникСсылка.Организации") Тогда
                РеквизитыПокупателя = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(ДанныеДляПечати.Покупатель, "ГоловнойКонтрагент, ОбособленноеПодразделение");
                Если РеквизитыПокупателя.ОбособленноеПодразделение И ЗначениеЗаполнено(РеквизитыПокупателя.ГоловнойКонтрагент) Тогда
                    СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(РеквизитыПокупателя.ГоловнойКонтрагент, Дата);
                    СведенияОПодразделенииПокупателя = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, Дата);
                Иначе
                    СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, Дата);
                    СведенияОПодразделенииПокупателя = Неопределено;
                КонецЕсли;
                //КонецЕсли;
    
    Строки с комментариями это добавил я.
    Проблема такого характера. Пытаемся распечатать СФ мы строили хоз способом. До обновления печаталось. Теперь после обновления код процедуры изменился.
    И получается такая проблема в переменной "ДанныеДляПечати.Покупатель" у меня не контрагент, а организация(спр.Организации). И у справочника Организации нет реквизита "ГоловнойКонтрагент" из за чего вываливается в ошибку. Релиз 1.3.60.3
    Может у кого нибудь есть УПП под руками того же релиза... А то как то не понятно это косяк релиза... или в чём то другом проблема.
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    В последнем релизе УПП код тот же по этому надо проверить 2 фактора
    1. это вот это НужныСведенияОПодразделенииПокупателя почему она истина и должо ли быть так
    2 ДанныеДляПечати.Покупатель почему организация
  3. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Потому что строим хоз способом. Получается сами себе СФ выставляем.
    И почему то контрагент в этой СФ не заполнен и не даёт редактировать. Должно быть так или нет пока разбираюсь.
    Чуть выше есть строка кода. Так как СФ на реализацию то и получаем значение Истина.
    Код:
    НужныСведенияОПодразделенииПокупателя = ДанныеДляПечати.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию
            ИЛИ ДанныеДляПечати.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс;
    Видимо надо копать в сторону Организации.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Видимо контрагента нужно создать с такими же реквизитами. Это как ИМХО :)
  5. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Ну в типовой такой же код
  6. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Не срабатывает. Добавил контрагента с точно такими же Наименованием, ИНН и КПП.
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Хм, странно. А отладчик что-нибудь говорит ?
  8. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Всё то же самое :) Говорит что организация. А надо что бы был контрагент.
  9. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    А можно посмотреть с\ф
    --- Объединение сообщений, 18 фев 2015 ---
    Вы делает реализацию или что и на основании этого с\ф можно скрины обоих
    или ккая цепочка. попробую у себя повторить
  10. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    СФ.jpg
    --- Объединение сообщений, 18 фев 2015 ---
    Мы делаем "Начисление НДС по СМР хоз способом". На основании этого документа вводим СФ.
    Последнее редактирование: 18 фев 2015
  11. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Ошибка повторилась. Скорее всего косяк 1С.
    --- Объединение сообщений, 18 фев 2015 ---
    у них в спискке ошибок этого нет. там запрос получается типа
    ГоловнойКонтрагент,
    ОбособленоеПодразделение
    ИЗ Справочники.Организации

    а реквизита такого нет...
  12. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Сейчас попробую типовую разверну....
  13. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Да у меня эти модули типовые - последний релиз. такая же ошибка.
  14. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    А у тебя УПП или с БИТ:Финансом?
  15. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Обычная.
    Да тут все просто
    вот код
    Код:
    НужныСведенияОПодразделенииПокупателя = ДанныеДляПечати.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию
            ИЛИ ДанныеДляПечати.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс;
    
    По документу Начисление НДС по СРМ (с\ф на него только на основании ввести можно, руками не дает т.к в списке нет выбора данноготипа документа) дает вид с\с на реализацию

    Соответвенно НужныСведенияОПодразделенииПокупателя истина

    И сразу же идет
    Код:
    Если НужныСведенияОПодразделенииПокупателя Тогда
                    РеквизитыПокупателя = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(Покупатель, "ГоловнойКонтрагент, ОбособленноеПодразделение");
    
    вот и все

    Этот документ особый
  16. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Да то что всё просто я уже понял :) Мне теперь ещё нужно в этом убедить заказчика. Он считает что это мой косяк. Так как после обновления перестало печатать. До обновления всё нормально печатает.
  17. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Написал в 1С.
    Просто есть база 51 релиза там как раз тупо было

    Код:
    СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, Дата);
        СведенияОПоставщике = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Поставщик, Дата);
       
        СведенияОПодразделенииПокупателя = Неопределено;
        Если ДанныеДляПечати.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию Тогда
           
            Если ТипЗнч(ДанныеДляПечати.Покупатель) = Тип("СправочникСсылка.Контрагенты") И ЗначениеЗаполнено(ДанныеДляПечати.Покупатель) Тогда
                РеквизитыПокупателя = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(ДанныеДляПечати.Покупатель, "ГоловнойКонтрагент, ОбособленноеПодразделение");
                Если РеквизитыПокупателя.ОбособленноеПодразделение И ЗначениеЗаполнено(РеквизитыПокупателя.ГоловнойКонтрагент) Тогда
                    СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(РеквизитыПокупателя.ГоловнойКонтрагент, Дата);
                    СведенияОПодразделенииПокупателя = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, Дата);
                КонецЕсли;
            КонецЕсли;
           
        КонецЕсли;
    
    Т.е. это делалось только для контрагентов
  18. TopicStarter Overlay
    TODD22
    Online

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Да у меня на 57 релизе то же нормально всё. А вот на 60.03 такая проблема.
    --- Объединение сообщений, 18 фев 2015 ---
    А они ошибку регистрируют? И потом она будет в зарегистрированных?
    Мне что бы заказчику показать.
  19. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Мыло в личку Скинь. я першлю ответ
  20. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Кому интересно, вчера 1С ответило
    «Ошибка зарегистрирована 10144607.»
Похожие темы
  1. Panchos
    Ответов:
    2
    Просмотров:
    1.435
Загрузка...

Поделиться этой страницей