8.х УПП УПП Документ "Распределение ЗП в регламентированном учете"

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем uriah, 12 дек 2008.

  1. TopicStarter Overlay
    uriah
    Offline

    uriah

    Регистрация:
    12 дек 2008
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    УПП релиз 1.2.19.1 Документ "Распределение ЗП в регламентированном учете" при обработке команды кнопки заполнить, выдает ошибку: по строке № не указан счетДт налогового учета.
    Соответствие счетов БУ и НУ установлено документом.
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Так в самом документе указан счет? :)
  3. TopicStarter Overlay
    uriah
    Offline

    uriah

    Регистрация:
    12 дек 2008
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    По кнопке "Заполнить" автоматически заполняются строки ТЧ "Основные начисления" и строки ТЧ "Дополнительные начисления", так вот, не заполняются автоматически колонки СчДтНУ
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    Если НЕ ЗначениеЗаполнено(Выборка.СчетДтНУ) Тогда
    Если (СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда или СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоВыплатеДоходов)
    и Не СчетДт.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.РасчетыПоСоциальномуСтрахованию) 
    и Не СчетДт.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.РасчетыПоНалогам) 
    и Не СчетДт.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.РасходыБудущихПериодов) 
    и Не СчетДт.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.НераспределеннаяПрибыль) 
    и Не СчетДт.ПринадлежитЭлементу(ПланыСчетов.Хозрасчетный.ПрочиеДоходыИРасходы)
    и (СчетДт <> ПланыСчетов.Хозрасчетный.РезервыПредстоящихРасходов)
    и Не Выборка.СчетДтОтноситсяКДеятельностиЕНВД Тогда
    Сообщение = "Не указан счет налогового учета!";
    КонецЕсли;
    Иначе
    Если (СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда или СчетДт = ПланыСчетов.Хозрасчетный.РасчетыПоВыплатеДоходов) Тогда
    Сообщение = "Проводки в дебет "+Выборка.НаименованиеСчетДт +" не должны отражаться в налоговом учете!";
    ИначеЕсли Выборка.СчетДтОтноситсяКДеятельностиЕНВД Тогда
    Сообщение = "Для вида деятельности, облагаемого ЕНВД, необходимо очистить счета Дт НУ и Кт НУ.";
    КонецЕсли;
    КонецЕсли;
    
  5. TopicStarter Overlay
    uriah
    Offline

    uriah

    Регистрация:
    12 дек 2008
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Данную функцию я смотрел - не могу понять с чем она сравнивает значения счетов.
    Уточню немного свой вопрос. Сначала я делаю документ "Ввод процента ЕНВД". Так вот косяки начинаются именно в этом документе - не заполняется счет затрат и ошибка в модуле при выборе статьи затрат ЗП. Может в УПП ЕНВД до конца не реализовано?
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Думаю, что вам стоит открыть руководство. Там достаточно подробно описан процесс начисления.

Поделиться этой страницей