8.х УПП УПП. Чем мативировать что нельзя закрыть 70-й счет?

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем DimkaAV, 13 июл 2012.

  1. TopicStarter Overlay
    DimkaAV
    Offline

    DimkaAV

    Регистрация:
    24 июн 2010
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    В общем... пришла беда в виде "а давайте закроем 70-й счет"...

    Повесили такой RLS на бухгалтерский и налоговый планы счетов.

    Код:
    #Если &ИспользоватьОграничениеПоСчету70 #Тогда
    ТекущаяТаблица ГДЕ (НЕ ТекущаяТаблица.Ссылка В
    (Значение(ПланСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда)))
    #КонецЕсли
    Как-бы счета не видно. <Объект не найден...> - ну тоже не смертельно, главное не показывает обороты.

    Но вот на таком вот коде
    Код:
    Процедура УстановитьВидимостьСубконто()
    Для Ном = 1 по 3 Цикл
    Если (Ном <= СчетУчетаРасчетовСКонтрагентом.ВидыСубконто.Количество()) и (ЗначениеЗаполнено(СчетУчетаРасчетовСКонтрагентом)) Тогда
    ЭлементыФормы["НадписьСубконтоДт"+Ном].Заголовок = СчетУчетаРасчетовСКонтрагентом.ВидыСубконто[Ном-1].ВидСубконто.Наименование;
    ЭлементыФормы["НадписьСубконтоДт"+Ном].Видимость = Истина;
    ЭлементыФормы["СубконтоДт"+Ном].Видимость = Истина;
    Иначе
    ЭлементыФормы["НадписьСубконтоДт"+Ном].Видимость = Ложь;
    ЭлементыФормы["СубконтоДт"+Ном].Видимость = Ложь;
    КонецЕсли;
    КонецЦикла;
    УстановитьВидимостьСубконтоНУ();
    КонецПроцедуры
    Вылетает ошибка...
    Код:
    {Документ.ПлатежноеПоручениеИсходящее.Форма.ФормаДокумента.Форма(152)}: Ошибка при получении значения атрибута контекста (ВидыСубконто)
    Если (Ном <= СчетУчетаРасчетовСКонтрагентом.ВидыСубконто.Количество()) и (ЗначениеЗаполнено(СчетУчетаРасчетовСКонтрагентом)) Тогда
    по причине:
    У пользователя недостаточно прав на исполнение операции над базой данных.
    что, в принципе, логично. Сами же и закрыли.
    Аналогичная ошибка при прямом обращении к 70-му счету - через ПланСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда).


    Я очень не хочу вешать ни RLS ни переписывать бух. отчеты на предмет закрытия счета. Да и "закрытие" это условное.
    Не раз читал/слышал о том что "1С рекомендует в таком случае не вести учет по сотрудникам, а вести сводно".
    Кто может указать, если ли официальное мнение 1С в виде информационного письма или чего-то аналогичного?
  2. alkras
    Offline

    alkras

    Регистрация:
    23 июл 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Была такая же задача. Сделал все стандартными средствами 1С (установил вести учет сводно). В результате обычный бухгалтер видит только общий оборот по компании, а расчетчик в своих отчетах может увидеть суммы по сотрудникам.
    Единственно при переходе необходимо закрыть текущие остатки по 70 счету.

Поделиться этой страницей