[РЕШЕНО] Упорядочивание в РМК по убыванию цены

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем ILUHA_86, 15 окт 2015.

  1. TopicStarter Overlay
    ILUHA_86
    Offline

    ILUHA_86

    Регистрация:
    18 май 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Люди добрые, я к Вам опять за помощью.
    1С:Предприятие 8.2 (8.2.15.318) Розница, редакция 1.0 (1.0.10.4)
    Хочу сделать чтоб в РМК, набранный товар на продажу, отображался по убыванию цены.

    В общем задумка такая:
    нужно запустить акцию, "на 3-ю вещь скидка 30%", вот поэтому и хочу упорядочить по убыванию цены, чтоб на 3-й товар сделать скидку. Но вот как это сделать автоматически пока не знаю. Если кто может, помогите пожалуйста.
    Заранее спасибо.
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Сортировка ТЧ по убыванию, по колонке "Цена". В синтаксис-помощнике все есть.
  3. TopicStarter Overlay
    ILUHA_86
    Offline

    ILUHA_86

    Регистрация:
    18 май 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста, эту сортировку мне искать в Конфигураторе, в свойствах колонки данной таблицы?
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Сортировка есть у ТаблицаЗначений.
  5. TopicStarter Overlay
    ILUHA_86
    Offline

    ILUHA_86

    Регистрация:
    18 май 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Код:
    //Проверим перебором табличные поля формы документа
        ТабличныеПоля = Новый Структура("Товары");
        Для Каждого ТекущееТабличноеПоле Из ТабличныеПоля Цикл
           
            ТабличноеПоле = ЭлементыФормы.Найти(ТекущееТабличноеПоле.Ключ);
            Если ТабличноеПоле <> Неопределено Тогда
                ТабличноеПоле.Доступность = ИзменятьТабличныеЧасти;
            Иначе
                Продолжить;
            КонецЕсли;
           
            КомманднаяПанельТабличногоПоля = ЭлементыФормы.Найти("КоманднаяПанель" + ТекущееТабличноеПоле.Ключ);
            Если КомманднаяПанельТабличногоПоля <> Неопределено тогда
                КомманднаяПанельТабличногоПоля.Доступность = ИзменятьТабличныеЧасти;
            КонецЕсли;
           
            КолонкаЦена = ТабличноеПоле.Колонки.Найти("Цена");
            //КолонкаЦена.Сортировать("Цена УБЫВ");
            Если КолонкаЦена <> Неопределено Тогда
                Значение                = ИзменятьЦену;
                КолонкаЦена.Доступность = Значение;
                //КолонкаЦена.Сортировать("Цена Убыв");
                КолонкаСумма            = ТабличноеПоле.Колонки.Найти("Сумма");
                Если КолонкаСумма <> Неопределено Тогда
                    КолонкаСумма.Доступность = Значение;
                КонецЕсли;
            КонецЕсли;
    Что-то делаю не так...(
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Для чего весь этот код? Сортировка строк в ТЧ объекта решается в 3 строки кода:
    1. Получить Т3 из ТЧ.
    2. Отсортировать ТЗ по нужным полям в нужном направлении.
    3. Поместить ТЗ в ТЧ объекта.
    ТЧ, однако, можно напрямую сортировать, не превращая ее в ТЗ.
    Последнее редактирование: 16 окт 2015
  7. TopicStarter Overlay
    ILUHA_86
    Offline

    ILUHA_86

    Регистрация:
    18 май 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Напишите пожалуйста эти 3 строки в виде кода. Чтоб я использовал его, как пример для выполнения своей задачи. Если Вам не трудно.
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    По пятницам я не пишу код :)
    alexburn нравится это.
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    зачееет :D
  10. TopicStarter Overlay
    ILUHA_86
    Offline

    ILUHA_86

    Регистрация:
    18 май 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    ;) с юмором у Вас всё отличнО! )))
    Ладно, и на том спасибо )
    --- Объединение сообщений, 16 окт 2015 ---
    Согласен :)
  11. TopicStarter Overlay
    ILUHA_86
    Offline

    ILUHA_86

    Регистрация:
    18 май 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Спасибо. Задача решена

Поделиться этой страницей