8.х Универсальный отчет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем denmember, 15 сен 2006.

  1. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте
    Для построения диаграмм я использую универсальный(общий) отчет "ОтчетДиаграмма". В некотором журнале документов я создал две кнопки при нажатии на которые должны выводится соответствующие диаграммы, различающиеся по разделам учета (имени регистра).
    Процедуры в модуле журнала документов:
    Код:
    
    Процедура ЧислоПретензийПоПродукции(Кнопка)
    Форма=Отчеты.ОтчетДиаграмма.ПолучитьФорму("ФормаОсновная");
    Форма.ПостроительОтчета.ИзмеренияСтроки.Очистить();
    Форма.Открыть();
    Форма.ИмяРегистра="ПретензииОтПокупателей";    
    Форма.ТипДиаграммыОтчета = ТипДиаграммы.Круговая;
    Форма.ПостроительОтчета.ИзмеренияСтроки.Очистить();
    Форма.ПостроительОтчета.ИзмеренияСтроки.Добавить("Продукция");
    Форма.ОбновитьОтчет();    
    КонецПроцедуры
    
    Процедура ЧислоДефектовПоПродукции(Кнопка)
    Форма=Отчеты.ОтчетДиаграмма.ПолучитьФорму("ФормаОсновная");
    Форма.Открыть();
    Форма.ИмяРегистра="Дефекты";    
    Форма.ТипДиаграммыОтчета = ТипДиаграммы.Круговая;
    Форма.ПостроительОтчета.ИзмеренияСтроки.Очистить();
    Форма.ПостроительОтчета.ИзмеренияСтроки.Добавить("Продукция");
    Форма.ОбновитьОтчет();    
    КонецПроцедуры
    
    
    Проблема в следующем:
    В режиме Предприятие я вывожу диаграмму по Разделу учета "ПретензииОтПокупателей" (все нормально), но если после этого я выведу диаграмму по другому Разделу учета ("Дефекты"), то диаграмма все равно выводится по предыдущему регистру ("ПретензииОтПокупателей").

    Подскажите пож с чем это связано и как от этой проблемы избавиться?
  2. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    структуру регистров покажи
  3. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Зачем тебе структура регистров? Мне кажется что здесь проблема связа с сохранениями настроек универсального отчета
  4. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    хочешь проверить сохранение настроек, тогда сначала выведи по Разделу учета ("Дефекты"), а после этого по ПретензииОтПокупателей"
  5. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Настройки не сохранятся. Свойства Отчета формы СохраненныеНастройки неопределено. Если я открываю диаграмму по разделу учета "Дефекты", то при открытии диаграммы по разделу "Претензии" выводится диаграмма по предыдущему разделу учета.

    Это фича связана со всеми универсальными отчетами, в том числе ОтчетОстаткиИОбороты
  6. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    попробуй диаграмму очистить
  7. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Каким образом?
  8. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    Диаграмма.Очистить();
  9. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Не помогло.

    Форма.ЭлементыФормы.Диаграмма.Очичтить(); сувал во все места кода - такая же фича

    уже часа три над этой проблемой парюсь, хотя решение наверное очень простое
  10. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    попробуй еще построительотчета.выполнить()
  11. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    в какую часть кода сувать то?
  12. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    после окончания итераций с построителемотчета :)
    например после
    Форма.ПостроительОтчета.ИзмеренияСтроки.Добавить("Продукция");
  13. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Все равно не прокатило

    Ты не разу не использовал этот инструмент для построения диаграмм? Очень удобно, но возникают такой праблем

    Все равно спасибо. Буду в модуле отчета лазить, может что полезное найду
  14. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    нет ни разу, так как не удобно выглядит
  15. TopicStarter Overlay
    denmember
    Offline

    denmember

    Регистрация:
    13 июл 2006
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    в модуле формы отчета есть процедура
    Процедура ПриЗакрытии()

    // Сохраним имя регистра
    СохранитьЗначение(Метаданные().Имя+"_ИмяРегистра", ИмяРегистра);

    КонецПроцедуры // ПриЗакрытии()

    Она и сохраняет имя регистра. Каким образом можно при открытии это имя очистить?
  16. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    либо придется сохранять с другим значением, либо попробовать пустое значение сохранить

Поделиться этой страницей