[РЕШЕНО] Универсальный отчет в УТ 10.3

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем lirikons, 25 авг 2014.

  1. TopicStarter Overlay
    lirikons
    Offline

    lirikons Опытный в 1С

    Регистрация:
    10 июн 2014
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Добрый день. Стал разбираться с универсальным отчетом. Нужно строить отчет по одному регистру сведений "Планирование продаж". Почему-то не выводятся колонки. Только группировки в одной колонке, если их задать, а если их нет, то только "СуммаПродавца" в одну колонку. Что может быть?

    ****************************************************************************************************************
    Код:
    Процедура УстановитьОбщиеПараметры()
        // Содержит название отчета, которое будет выводиться в шапке.
        // Тип: Строка.
        // Пример:
        // УниверсальныйОтчет.мНазваниеОтчета = "Название отчета";
        УниверсальныйОтчет.мНазваниеОтчета = СокрЛП(ЭтотОбъект.Метаданные().Синоним);
        // Содержит признак необходимости отображения надписи и поля выбора раздела учета в форме настройки.
        // Тип: Булево.
        // Значение по умолчанию: Истина.
        // Пример:
        // УниверсальныйОтчет.мВыбиратьИмяРегистра = Истина;
        УниверсальныйОтчет.мВыбиратьИмяРегистра = Ложь;
        // Содержит имя регистра, по метаданным которого будет выполняться заполнение настроек отчета.
        // Тип: Строка.
        // Пример:
        // УниверсальныйОтчет.ИмяРегистра = "ТоварыНаСкладах";
        УниверсальныйОтчет.ИмяРегистра = "";
        // Содержит признак необходимости вывода отрицательных значений показателей красным цветом.
        // Тип: Булево.
        // Значение по умолчанию: Ложь.
        // Пример:
        // УниверсальныйОтчет.ОтрицательноеКрасным = Истина;
        УниверсальныйОтчет.ОтрицательноеКрасным = Истина;
        // Содержит признак необходимости вывода в отчет общих итогов.
        // Тип: Булево.
        // Значение по умолчанию: Ложь.
        // Пример:
        // УниверсальныйОтчет.ВыводитьОбщиеИтоги = Ложь;
        // Содержит признак необходимости вывода детальных записей в отчет.
        // Тип: Булево.
        // Значение по умолчанию: Ложь.
        // Пример:
        УниверсальныйОтчет.ВыводитьДетальныеЗаписи = Истина;
        // Содержит признак необходимости отображения флага использования свойств и категорий в форме настройки.
        // Тип: Булево.
        // Значение по умолчанию: Истина.
        // Пример:
        УниверсальныйОтчет.мВыбиратьИспользованиеСвойств = Ложь;
        //УниверсальныйОтчет.мВыбиратьИспользованиеСвойств = Истина;
        // Содержит признак использования свойств и категорий при заполнении настроек отчета.
        // Тип: Булево.
        // Значение по умолчанию: Истина.
        // Пример:
        // УниверсальныйОтчет.ИспользоватьСвойстваИКатегории = Истина;
        //УниверсальныйОтчет.ИспользоватьСвойстваИКатегории = Истина;
        // Содержит признак использования простой формы настроек отчета без группировок колонок.
        // Тип: Булево.
        // Значение по умолчанию: Ложь.
        // Пример:
        //УниверсальныйОтчет.мРежимФормыНастройкиБезГруппировокКолонок = Истина;
    КонецПроцедуры
    ****************************************************************************************************************
    Процедура УстановитьТекстЗапроса()
        // Описание исходного текста запроса.
        ТекстЗапроса = "ВЫБРАТЬ
                      |    РегистрПланированиеПродаж.ФизЛица КАК ФизЛица,
                      |    РегистрПланированиеПродаж.Магазин КАК Магазин,
                      |    РегистрПланированиеПродаж.ДатаНачала КАК ДатаНачала,
                      |    РегистрПланированиеПродаж.ДатаОкончания КАК ДатаОкончания,
                      |    РегистрПланированиеПродаж.СуммаПродавца КАК СуммаПродавца
                      |{ВЫБРАТЬ
                      |    ФизЛица.*,
                      |    Магазин.*,
                      |    ДатаНачала,
                      |    ДатаОкончания,
                      |    СуммаПродавца}
                      |ИЗ
                      |    РегистрСведений.РегистрПланированиеПродаж КАК РегистрПланированиеПродаж
                      |ГДЕ
                      |    РегистрПланированиеПродаж.ДатаНачала >= &ДатаНачала
                      |    И РегистрПланированиеПродаж.ДатаОкончания <= &ДатаКонца
                      |{ГДЕ
                      |    РегистрПланированиеПродаж.ФизЛица.*,
                      |    РегистрПланированиеПродаж.Магазин.*,
                      |    РегистрПланированиеПродаж.ДатаНачала,
                      |    РегистрПланированиеПродаж.ДатаОкончания}
                      |{УПОРЯДОЧИТЬ ПО
                      |    Магазин.*,
                      |    ФизЛица.*}
                      |{ИТОГИ ПО
                      |    ФизЛица.*,
                      |    Магазин.*}";
                   
        //// В универсальном отчете включен флаг использования свойств и категорий.
        //Если УниверсальныйОтчет.ИспользоватьСвойстваИКатегории Тогда
        //    // Добавление свойств и категорий поля запроса в таблицу полей.
        //    // Необходимо вызывать для каждого поля запроса, предоставляющего возможность использования свойств и категорий.
        //    // УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля(<ПсевдонимТаблицы>.<Поле> , <ПсевдонимПоля>, <Представление>, <Назначение>);
        //    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля( "ИсточникДанных.Номенклатура" ,               "Номенклатура",               "Номенклатура",                ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура);
        //    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля( "ИсточникДанных.ХарактеристикаНоменклатуры" , "ХарактеристикаНоменклатуры", "Характеристика номенклатуры", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_ХарактеристикиНоменклатуры);
        //    // Добавление свойств и категорий в исходный текст запроса.
        //    УниверсальныйОтчет.ДобавитьВТекстЗапросаСвойстваИКатегории(ТекстЗапроса);
        //КонецЕсли;
        // Инициализация текста запроса построителя отчета
        УниверсальныйОтчет.ПостроительОтчета.Текст = ТекстЗапроса;
    КонецПроцедуры
    ****************************************************************************************************************
    Процедура УстановитьНачальныеНастройки(ДополнительныеПараметры = Неопределено) Экспорт
        // Настройка общих параметров универсального отчета
        УстановитьОбщиеПараметры();
        // Дополнительные параметры, переданные из отчета, вызвавшего расшифровку.
        // Информация, передаваемая в переменной ДополнительныеПараметры, может быть использована
        // для реализации специфичных для данного отчета параметрических настроек.
        УстановитьТекстЗапроса();
        // Представления полей отчета.
        // Необходимо вызывать для каждого поля запроса.
        // УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить(<ИмяПоля>, <ПредставлениеПоля>);
        УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить( "ФизЛица", "Продавец");
        УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить( "Магазин", "Магазин");
        УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить( "ДатаНачала", "Дата начала");
        УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить( "ДатаОкончания", "ДатаОкончания");
        УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить( "СуммаПродавца", "Сумма продавца");
        // Добавление показателей
        // Необходимо вызывать для каждого добавляемого показателя.
        // УниверсальныйОтчет.ДобавитьПоказатель(<ИмяПоказателя>, <ПредставлениеПоказателя>, <ВключенПоУмолчанию>, <Формат>, <ИмяГруппы>, <ПредставлениеГруппы>);
        //УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОстаток", "Количество", Истина, "ЧЦ=15; ЧДЦ=3");
        // Добавление предопределенных группировок строк отчета.
        // Необходимо вызывать для каждой добавляемой группировки строки.
        // УниверсальныйОтчет.ДобавитьИзмерениеСтроки(<ПутьКДанным>);
        //УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Магазин");
        //УниверсальныйОтчет.ДобавитьИзмерениеСтроки("ФизЛица");
        //УниверсальныйОтчет.ДобавитьИзмерениеСтроки("СуммаПродавца");
        //УниверсальныйОтчет.ДобавитьИзмерениеСтроки("ДокументРезерва");
        // Добавление предопределенных группировок колонок отчета.
        // Необходимо вызывать для каждой добавляемой группировки колонки.
        // УниверсальныйОтчет.ДобавитьИзмерениеКолонки(<ПутьКДанным>);
        // Добавление предопределенных отборов отчета.
        // Необходимо вызывать для каждого добавляемого отбора.
        // УниверсальныйОтчет.ДобавитьОтбор(<ПутьКДанным>);
        //УниверсальныйОтчет.ДобавитьОтбор("Магазин");
        //УниверсальныйОтчет.ДобавитьОтбор("ФизЛица");
        //УниверсальныйОтчет.ДобавитьОтбор("ДокументРезерва");
        // Установка связи подчиненных и родительских полей
        // УниверсальныйОтчет.УстановитьСвязьПолей(<ПутьКДанным>, <ПутьКДанным>);
        // Установка представлений полей
        // УниверсальныйОтчет.УстановитьПредставленияПолей(УниверсальныйОтчет.мСтруктураПредставлениеПолей, УниверсальныйОтчет.ПостроительОтчета);
        УниверсальныйОтчет.УстановитьПредставленияПолей(УниверсальныйОтчет.мСтруктураПредставлениеПолей, УниверсальныйОтчет.ПостроительОтчета);
        // Установка типов значений свойств в отборах отчета
        УниверсальныйОтчет.УстановитьТипыЗначенийСвойствДляОтбора();
        // Заполнение начальных настроек универсального отчета
        УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина);
        // Добавление дополнительных полей
        // Необходимо вызывать для каждого добавляемого дополнительного поля.
        // УниверсальныйОтчет.ДобавитьДополнительноеПоле(<ПутьКДанным>);
        УниверсальныйОтчет.ДобавитьДополнительноеПоле("СуммаПродавца");
    КонецПроцедуры
    Последнее редактирование модератором: 26 авг 2014
  2. TopicStarter Overlay
    lirikons
    Offline

    lirikons Опытный в 1С

    Регистрация:
    10 июн 2014
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Колонки задаются тут:
    УниверсальныйОтчет.ДобавитьПоказатель(<ИмяПоказателя>, <ПредставлениеПоказателя>, <ВключенПоУмолчанию>, <Формат>, <ИмяГруппы>, <ПредставлениеГруппы>);
    а представления полей, не очень понял, то ли представление группировок, что ли еще что

Поделиться этой страницей