8.х Уникальный идентификатор пользователя

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mhl, 26 мар 2008.

  1. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток. Подскажите пожалуйста, как можно отобрать документы, созданные пользователем с определенным уникальным идентификатором? Данный пользователь был удален, поэтому поиск производится только по идентификатору. Пробовал написать так
    Код:
    СтрокаGuid = "1234567890"; //допустим это его идентификатор
    ДокАванс = Документы.АвансовыйОтчет.Выбрать();
    Пока ДокАванс.Следующий() Цикл
    Если ДокАванс.Ответственный.УникальныйИдентификатор() = СтрокаGuid Тогда
    
    КонецЕсли;
    КонецЦикла;
    
    Но сравниваемые значения имеют разный тип. Заранее спасибо за помощь
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    А может взять какой нибудь документ, где еще есть ссылка на этого сотрудника, скопировать ее в переменную, и по ней искать?
  3. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Метод УникальныйИдентификатор() возвращает совсем другое значение - не строку.

    Вам надо или воспользоваться советом lazy или так:
    Код:
    УИДПользователя = Новый УникальныйИдентификатор(СТРОКА);
    ДокАванс = Документы.АвансовыйОтчет.Выбрать();
    Пока ДокАванс.Следующий() Цикл   
    Если ДокАванс.Ответственный.УникальныйИдентификатор() = УИДПользователя Тогда   
    ////
    КонецЕсли;
    КонецЦикла; 
    
    

Поделиться этой страницей